HDU 5532——Almost Sorted Array——————【技巧】

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 236    Accepted Submission(s): 113

Problem Description

We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1,a2,…,an, is it almost sorted?

Input

The first line contains an integer T indicating the total number of test cases. Each test case starts with an integer n in one line, then one line with n integers a1,a2,…,an.

1≤T≤2000
2≤n≤105
1≤ai≤105
There are at most 20 test cases with n>1000.

Output

For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).

Sample Input

3

3

2 1 7

3

3 2 1

5

3 1 4 1 5

Sample Output

YES

YES

NO

Source

2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

题目大意:给你n个数的序列,问你能否从中删除一个数,让剩下的序列为不递增或不递减。

解题思路:考虑第一个是否一定保留第一个数字。如果删除第一个数字,那么直接从第二个数字往后,判断序列是否是不递增或不递减的。如果不删除第一个数字,那么发现只删除一个数字满足的呈现这两种情况。以判断不递减为例。对于序列 7 8 1000 9 10 来说,中间那个数字过分得大了,如果保留1000,那么后边的序列都会不能用,所以,我们需要删除的是1000,这样序列才会呈现不递减。对于序列 7 8 1 9 10来说,很明显,1是要删除的。删除1后,这个序列才会呈现不递减。于是我们判断是否a[i]<a[i-1]。如果有,那么说明有元素需要删除,对于第一种情况,我们的i会指向9,同时我们需要判断,是否a[i]>=a[i-2],也就是这里的9与8。对于第二种情况,我们同样判断是否a[i]<a[i-1],但是这时候的i指向1,我们要判断是否a[i+1]>=a[i-1]。如果不满足,说明这里需要删除的元素不只一个,所以直接false,否则,记录已经删除过一个元素。如果下次又有a[i]<a[i-1],那么直接false。

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxn = 100010;
const int INF = 0x3f3f3f3f;
int a[maxn];
bool jud1(int n){
    int tmp = a[2];
    for(int i = 2; i <=n; i++){
        if(tmp > a[i]){
            return false;
        }else{
            tmp = a[i];
        }
    }
    return true;
}
bool jud2(int n){
    int tmp = a[2];
    for(int i = 2; i <= n; i++){
        if(tmp < a[i]){
            return false;
        }else{
            tmp = a[i];
        }
    }
    return true;
}
bool jud3(int n){
    a[0] = 0; a[n+1] = INF;
    int tim = 0;
    int fir = 0;
    for(int i = 2; i <= n; i++){
        if(a[i]<a[i-1]){
            if(fir == 1)
                return false;
            fir++;
            if(a[i+1]>=a[i-1]||a[i]>=a[i-2]){
                continue;
            }else{
                return false;
            }
        }
    }
    return true;
}
bool jud4(int n){
    a[0] = INF; a[n+1] = 0;
    int tim = 0;
    int fir = 0;
    for(int i = 2; i <= n; i++){
        if(a[i]>a[i-1]){
            if(fir == 1)
                return false;
            fir++;
            if(a[i+1]<=a[i-1]||a[i]<=a[i-2]){
                continue;
            }else{
                return false;
            }
        }
    }
    return true;
}
int main(){
    int T,n,m;
    scanf("%d",&T);
    while(T--){
       scanf("%d",&n);
       for(int i = 1; i <= n; i++){
            scanf("%d",&a[i]);
       }
        if(jud1(n)){
            puts("YES");
            continue;
        }
        if(jud2(n)){
            puts("YES");
            continue;
        }
        if(jud3(n)){
            puts("YES");
            continue;
        }
        if(jud4(n)){
            puts("YES");
            continue;
        }
        puts("NO");
    }
    return 0;
}
/*
555
4
8 6 7 8
4
8 6 7 7
5
1 2 1000 7 8
5
1 2 100 2 3
4
1 1 1 1
6
7 8 1 1 1 10

*/

  

时间: 2024-10-10 23:01:24

HDU 5532——Almost Sorted Array——————【技巧】的相关文章

hdu 5532 Almost Sorted Array nlogn 的最长非严格单调子序列

Almost Sorted Array Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)Total Submission(s): 2504    Accepted Submission(s): 616 Problem Description We are all familiar with sorting algorithms: quick sort, merge sort,

HDU 5532 Almost Sorted Array

Almost Sorted Array Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)Total Submission(s): 831    Accepted Submission(s): 293 Problem Description We are all familiar with sorting algorithms: quick sort, merge sort,

hdu 5532 Almost Sorted Array (水题)

Almost Sorted Array Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)Total Submission(s): 8541    Accepted Submission(s): 1982 Problem Description We are all familiar with sorting algorithms: quick sort, merge sort

【HDU 5532 Almost Sorted Array】水题,模拟

给出一个序列(长度>=2),问去掉一个元素后是否能成为单调不降序列或单调不增序列. 对任一序列,先假设其可改造为单调不降序列,若成立则输出YES,不成立再假设其可改造为单调不增序列,若成立则输出YES,不成立则输出NO. 由于持平不影响整体单调性,为了直观,我在以下把“不降”称为“递增/升序”,把“不增”称为“递减/降序”. 递增和递减是对称的,这里先考虑递增,递减改个符号和最值就好. 我们把为维护单调性而去掉的那个点称为“坏点”.由题目的要求,“可改造”可等价于“只存在一个坏点”. 对于“坏点

HDU 5532 Almost Sorted Array(最长不下降或不上升子序列)

题目戳这 题目:给你一个序列,问你,这个序列只减少一个元素,减少之后是否为不上升序列或者不下降序列. 思路:直接对序列求最长不下降和不上升子序列,如果这个子序列的长度为n-1或者n的话,就符合题目条件. 最长不下降子序列和最长不上升子序列:这里使用数据结构的方法求最长不上升(下降)子序列的长度.就是另外构造一个数组 f[] ,这个数组表示的意思是:f [ i ] 表示的是长度为 i 的子序列的最小(最大值),因为,同样长度的子序列,最后一个数字最小或最大的时候,更方便往后面放数字.这个时候可能会

2015ACM/ICPC亚洲区长春站 F hdu 5533 Almost Sorted Array

Almost Sorted Array Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)Total Submission(s): 447    Accepted Submission(s): 201 Problem Description We are all familiar with sorting algorithms: quick sort, merge sort,

HDU 5532 / 2015ACM/ICPC亚洲区长春站 F.Almost Sorted Array

Almost Sorted Array Problem Description We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted arr

leetcode 【 Merge Sorted Array 】python 实现

题目: Given two sorted integer arrays A and B, merge B into A as one sorted array. Note:You may assume that A has enough space (size that is greater or equal to m + n) to hold additional elements from B. The number of elements initialized in A and B ar

leetcode 【 Remove Duplicates from Sorted Array II 】python 实现

题目: Follow up for "Remove Duplicates":What if duplicates are allowed at most twice? For example,Given sorted array A = [1,1,1,2,2,3], Your function should return length = 5, and A is now [1,1,2,2,3]. 代码:oj测试通过 Runtime: 120 ms 1 class Solution: 2