POJ1001(C++处理大数)

Exponentiation

Time Limit: 500MS   Memory Limit: 10000K
Total Submissions: 158025   Accepted: 38470

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don‘t print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
const int MAXN=1005;
struct BigInt{
    int e[MAXN],len;
    int pis;//小数点位数
    BigInt()
    {
        memset(e,0,sizeof(e));
        len=0;
        pis=0;
    }
    void set(char s[])
    {
        int pp;
        for(int i=0;s[i];i++)
        {
            if(s[i]==‘.‘)
            {
                pp=i;
                break;
            }
        }
        int l=strlen(s)-1;
        pis=l-pp;
        for(int i=l;i>=0;i--)
        {
            if(s[i]==‘.‘)continue;
            e[len++]=s[i]-‘0‘;
        }
        while(e[len-1]==0&&len>1)    len--;
    }
    BigInt operator*(const BigInt& b)
    {
        BigInt res;
        for(int i=0;i<len;i++)
        {
            int up=0;
            for(int j=0;j<b.len;j++)
            {
                int z=(e[i]*b.e[j]+up+res.e[i+j]);
                res.e[i+j]=z%10;
                up=z/10;
            }
            if(up!=0)    res.e[i+b.len]=up;
        }
        res.pis=pis+b.pis;
        res.len=len+b.len;
        while(res.e[res.len-1]==0&&res.len>1)    res.len--;
        return res;
    }
    void print()
    {
        int limit=0;
        while(e[limit]==0&&limit<pis)    limit++;//去后导0
        if(pis>=len)
        {
            cout<<".";
            int i;
            for(int i=pis;i>len;i--)
            {
                cout<<0;
            }
            for(int i=len-1;i>limit;i--)
            {
                cout<<e[i];
            }
            cout<<e[limit]<<endl;
        }
        else
        {
            for(int i=len-1;i>=pis;i--)
            {
                cout<<e[i];
            }
            if(limit<pis)
            {
                cout<<".";
                for(int i=pis-1;i>limit;i--)
                {
                    cout<<e[i];
                }
                cout<<e[limit]<<endl;
            }
            else    cout<<endl;
        }
    }
    void print2()
    {
        for(int i=0;i<len-1;i++)
        {
            cout<<e[i];
        }
        cout<<e[len-1]<<endl;
    }
};
char buf[MAXN]="1.0";
char a[MAXN],b[MAXN];
int n;
int main()
{
    while(cin>>a>>n)
    {
        BigInt res,x;
        res.set(buf);
        x.set(a);
        for(int i=0;i<n;i++)
        {
            res=res*x;
        }
        res.print();
    }
    return 0;
}
时间: 2024-10-08 11:04:09

POJ1001(C++处理大数)的相关文章

poj1001 Exponentiation【java大数】

Exponentiation Time Limit: 500MS   Memory Limit: 10000K Total Submissions: 183034   Accepted: 44062 Description Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the n

poj1001(高精度)

Exponentiation Time Limit: 500MS   Memory Limit: 10000K Total Submissions: 132438   Accepted: 32334 Description Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the n

最短的计算大数乘法的c程序

#include <stdio.h> char s[99],t[99]; int m,n; void r(int i,int c) { int j=0,k=i; while(k)c+=s[j++]*t[k---1]; if(i)r(i-1,c/10); printf("%d",c%10); } void main() { gets(s);gets(t); while(s[n])s[n++]-=48; while(t[m])t[m++]-=48; r(m+n-1,0); }

light oj 1236 【大数分解】

给定一个大数,分解质因数,每个质因子的个数为e1,e2,e3,--em, 则结果为((1+2*e1)*(1+2*e2)--(1+2*em)+1)/2. //light oj 1236 大数分解素因子 #include <stdio.h> #include <iostream> #include <string.h> #include <algorithm> #include <math.h> #include <ctype.h> #i

nyoj 73 比大小 【java大数】

java大数. 代码: import java.util.Scanner; import java.math.*; public class Main{ public static void main(String[] args){ Scanner cin = new Scanner(System.in); BigInteger a, b; BigInteger t = BigInteger.valueOf(0); a = cin.nextBigInteger(); b = cin.nextBi

uva 1478 - Delta Wave(递推+大数+卡特兰数+组合数学)

题目链接:uva 1478 - Delta Wave 题目大意:对于每个位置来说,可以向上,水平,向下,坐标不能位负,每次上下移动最多为1, 给定n问说有多少种不同的图.结果对10100取模. 解题思路:因为最后都要落回y=0的位置,所以上升的次数和下降的次数是相同的,并且上升下降的关系满足出栈入栈的关系.即卡特兰数. 所以每次枚举i,表示有i个上升,i个下降,用组合数学枚举出位置,然后累加求和. C(2?in)?f(i)=C(2?i?2n)?f(i?1)?(n?2?i+1)?(n?2?i+2)

各类大数模板

ps:转自http://blog.csdn.net/y990041769/article/details/20116995 大数加法模板(本人验证过,其他还没用,只是写在这) 1 string sum(string s1,string s2) 2 { 3 if(s1.length()<s2.length()) 4 { 5 string temp=s1; 6 s1=s2; 7 s2=temp; 8 } 9 int i,j; 10 for(i=s1.length()-1,j=s2.length()-

【51Nod】1005 大数加法

给出2个大整数A,B,计算A+B的结果. Input 第1行:大数A 第2行:大数B (A,B的长度 <= 10000 需注意:A B有可能为负数) Output 输出A + B Input示例 68932147586 468711654886 Output示例 537643802472 ==================================================================================================== 问题解法

HDU 1018 大数(求N!的位数/相加)

Big Number Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 35382    Accepted Submission(s): 16888 Problem Description In many applications very large integers numbers are required. Some of these