HDOJ 4941 Magical Forest

STL map 记录对应原图是第几行/列

Magical Forest

Time Limit: 24000/12000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 394    Accepted Submission(s): 188

Problem Description

There is a forest can be seen as N * M grid. In this forest, there is some magical fruits, These fruits can provide a lot of energy, Each fruit has its location(Xi, Yi) and the energy can be provided Ci.

However, the forest will make the following change sometimes:

1. Two rows of forest exchange.

2. Two columns of forest exchange.

Fortunately, two rows(columns) can exchange only if both of them contain fruits or none of them contain fruits.

Your superior attach importance to these magical fruit, he needs to know this forest information at any time, and you as his best programmer, you need to write a program in order to ask his answers quick every time.

Input

The input consists of multiple test cases.

The first line has one integer W. Indicates the case number.(1<=W<=5)

For each case, the first line has three integers N, M, K. Indicates that the forest can be seen as maps N rows, M columns, there are K fruits on the map.(1<=N, M<=2*10^9, 0<=K<=10^5)

The next K lines, each line has three integers X, Y, C, indicates that there is a fruit with C energy in X row, Y column. (0<=X<=N-1, 0<=Y<=M-1, 1<=C<=1000)

The next line has one integer T. (0<=T<=10^5)

The next T lines, each line has three integers Q, A, B.

If Q = 1 indicates that this is a map of the row switching operation, the A row and B row exchange.

If Q = 2 indicates that this is a map of the column switching operation, the A column and B column exchange.

If Q = 3 means that it is time to ask your boss for the map, asked about the situation in (A, B).

(Ensure that all given A, B are legal. )

Output

For each case, you should output "Case #C:" first, where C indicates the case number and counts from 1.

In each case, for every time the boss asked, output an integer X, if asked point have fruit, then the output is the energy of the fruit, otherwise the output is 0.

Sample Input

1
3 3 2
1 1 1
2 2 2
5
3 1 1
1 1 2
2 1 2
3 1 1
3 2 2

Sample Output

Case #1:
1
2
1

Hint

No two fruits at the same location.

Author

UESTC

Source

2014 Multi-University Training Contest 7

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>

using namespace std;

typedef pair<int,int> pII;

map<pII,int> go;
map<int,int> hang;
map<int,int> lie;

int n,m,k,t;

int main()
{
    int T_T,cas=1;
    scanf("%d",&T_T);
    while(T_T--)
    {
        go.clear(); hang.clear(); lie.clear();
        scanf("%d%d%d",&n,&m,&k);
        for(int i=0;i<k;i++)
        {
            int x,y,c;
            scanf("%d%d%d",&x,&y,&c);
            go[make_pair(x,y)]=c;
            hang[x]=x; lie[y]=y;
        }
        scanf("%d",&t);
        printf("Case #%d:\n",cas++);
        while(t--)
        {
            int q,x,y;
            scanf("%d%d%d",&q,&x,&y);
            if(q==1)
            {
                int tx,ty;
                if(hang.count(x)==0)
                    hang[x]=x;
                tx=hang[x];

                if(hang.count(y)==0)
                    hang[y]=y;
                ty=hang[y];
                hang[x]=ty; hang[y]=tx;
            }
            else if(q==2)
            {
                int tx,ty;
                if(lie.count(x)==0)
                    lie[x]=x;
                tx=lie[x];

                if(lie.count(y)==0)
                    lie[y]=y;
                ty=lie[y];

                lie[x]=ty; lie[y]=tx;
            }
            else if(q==3)
            {
                int tx,ty;
                if(hang.count(x)==0)
                    tx=x;
                else tx=hang[x];
                if(lie.count(y)==0)
                    ty=y;
                else ty=lie[y];
                printf("%d\n",go[make_pair(tx,ty)]);
            }
        }
    }
    return 0;
}

HDOJ 4941 Magical Forest

时间: 2024-10-14 05:16:20

HDOJ 4941 Magical Forest的相关文章

hdu 4941 Magical Forest (map容器)

Magical Forest Time Limit: 24000/12000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 135    Accepted Submission(s): 69 Problem Description There is a forest can be seen as N * M grid. In this forest, there is so

hdu 4941 Magical Forest(Map)

http://acm.hdu.edu.cn/showproblem.php?pid=4941 因为地图的行和列很大,操作次数也很多,直接循环模拟肯定不行.但可以用map映射一下,当交换行和列的时候,直接交换它们的映射值,直接O(1)进行交换. #include <stdio.h> #include <iostream> #include <map> #include <set> #include <list> #include <stack

hdu 4941 Magical Forest(STL map &amp; 结构体运用)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4941 Magical Forest Time Limit: 24000/12000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 220    Accepted Submission(s): 105 Problem Description There is a forest c

HDU 4941 Magical Forest STL

这明明就是给纯C选手的大杀器啊. 题意:给你k坐标,表示 X,Y 有值C,有 3种操作 1) 交换A,B两行 2) 交换A,B两列 3) 询问(A,B)的值 解题思路:map离散化 解题代码: // File Name: 1007.cpp // Author: darkdream // Created Time: 2014年08月12日 星期二 21时05分18秒 #include<vector> #include<list> #include<map> #includ

hdu 4941 Magical Forest

被虐了一下午..离散化,开一个rr[mnx], cc[mnx],初始化为rr[i] = i, cc[i],然后换的时候就换这两个数组就好了.. 然后就是不断的lower_bound 1 #include<iostream> 2 #include<cstring> 3 #include<algorithm> 4 #include<cstdio> 5 #include<string> 6 #include<queue> 7 #includ

HDU 4941 Magical Forest 【离散化】【map】

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4941 题目大意:给你10^5个点,每个点有一个数值,点的xy坐标是0~10^9,点存在于矩阵中.然后给出10^5个操作,1代表交换行,2代表交换列,3代表查询坐标为xy点的数值. 数据量很大........ 所以一直没有思路 后来赛后看了题解是先用离散化然后存在线性map里面. #include <iostream> #include <cstdio> #include <map

HDU 4941 Magical Forest(离散化)

HDU 4941 Magical Forest 题目链接 题意:给定一些点,点有值,现在3种操作交换行,列,询问某个点值 思路:这是签到题,坐标系很大,所以把坐标离散化储存,每次交换的时候只要把相应的行列坐标交换即可,查询就在交换过的上面查就可以了 代码: #include <cstdio> #include <cstring> #include <algorithm> #include <map> using namespace std; #define

HDU 4941 Magical Forest _(:зゝ∠)_ 模拟题

模拟大法保平安_(:зゝ∠)_ #include <cstdio> #include <map> #include <set> #include <algorithm> using namespace std; const int N = 1; struct node{ int x, y, val; node(int a=0,int b=0,int c=0):x(a),y(b),val(c){} bool operator<(const node&am

hdu 4941 Magical Forest(hash映射)

题目链接:hdu 4941 Magical Forest 题目大意:给定N,M和K,表示在一个N*M的棋盘上有K个棋子,给出K个棋子的位置和值,然后是Q次操作,对应的是: 1 a b :交换a和b两行 2 a b : 交换a和b两列 3 a b :查询a b这个位置上棋子的值,没有棋子的话输出0 解题思路:一开始X[i]=i,X[j]=j,如果需要交换i和j,那么就令X[i]=j,X[j]=i即可,因为N和M很大,所以用map映射. #include <cstdio> #include <