SDUT 2894-C(最短路spfa)

C

Time Limit: 7000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

给出一个带权无向图,包含n个点,m条边。求出s,e的最短路。保证最短路存在。

输入

多组输入。

对于每组数据。

第一行输入n,m(1<= n && n<=5*10^5,1 <= m && m <= 2*10^6)。

接下来m行,每行三个整数,u,v,w,表示u,v之间有一条权值为w(w >= 0)的边。

最后输入s,e。

输出

对于每组数据输出一个整数代表答案。

示例输入

3 1
1 2 3
1 2

示例输出

3
这道题绝了。。点 边都太多,要么spfa过,要么bfs+优先队列爆搜(好像更快一些) 其他的方法都过不去,而其对内存卡的特别紧,vector过不去,照着标程敲的bfs挂了。。到现在不知道错在哪,怒换spfa,然后就过了
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cctype>
#include <cstdlib>
#include <algorithm>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <list>
using namespace std;
const  int maxn=500010;
const int INF=1<<29;
struct node{
	int p,w,next;
};
node eg[4000010];
bool vis[maxn];
int n,e,head[500010],dis[500010];
void adj_clear()
{
	memset(head,-1,sizeof(head));
	e=0;
}
void addnode(int u,int v,int c)
{
	eg[e].p=v;
	eg[e].w=c;
	eg[e].next=head[u];
	head[u]=e++;
}
void spfa(int src)
{
	queue <int> Q;int i;
	for(i=0;i<=n;i++){dis[i]=INF;vis[i]=0;}
	dis[src]=0;
	Q.push(src);
	while(!Q.empty()){
		int u=Q.front();Q.pop();
		vis[u]=0;
		for(i=head[u];i!=-1;i=eg[i].next)
		{
			int v=eg[i].p;
			int w=eg[i].w;
			if(dis[v]>dis[u]+w)
			{
				dis[v]=dis[u]+w;
				if(!vis[v])
				{
					vis[v]=1;
					Q.push(v);
				}
			}
		}
	}
}
int main()
{
	int u,v,m,w;
	while(scanf("%d%d",&n,&m)!=EOF){
	    adj_clear();
		while(m--){

			scanf("%d%d%d",&u,&v,&w);
			addnode(u,v,w);
			addnode(v,u,w);
		}
		int s,en;
		scanf("%d%d",&s,&en);
		spfa(s);
		printf("%d\n",dis[en]);
	}
	return 0;
}

时间: 2024-10-14 10:33:08

SDUT 2894-C(最短路spfa)的相关文章

最短路 spfa算法

问题描述 给定一个n个顶点,m条边的有向图(其中某些边权可能为负,但保证没有负环).请你计算从1号点到其他点的最短路(顶点从1到n编号). 输入格式 第一行两个整数n, m. 接下来的m行,每行有三个整数u, v, l,表示u到v有一条长度为l的边. 输出格式 共n-1行,第i行表示1号点到i+1号点的最短路. 样例输入 3 31 2 -12 3 -13 1 2 样例输出 -1-2 数据规模与约定 对于10%的数据,n = 2,m = 2. 对于30%的数据,n <= 5,m <= 10. 对

TOJ--2674--最短路(spfa)

厌死了......排位 晋级赛 两连跪 ... 三角形 的那题还是 无限WA  ... 还有 明天又要早起... 先还是来看下这题吧 话说 好久没写 最短路了 --------- spfa 是我最喜欢的最短路版本 touch me 这题 其实相比其它的最短路 还是有个很让人看不懂的地方---让我纠结了很久 首先 它告诉了我们城市的编号 是从 1~1000 然后 又突然告诉我们 哪些城市和我们的出发地相邻 假如是 1 10 100...之类的 最后 告诉我们 你想取哪些城市 我就在想 起点呢!!!

洛谷P1462 通往奥格瑞玛的道路 二分答案+最短路SPFA

洛谷P1462 通往奥格瑞玛的道路二分答案+最短路SPFA 二分交费最多的一次的钱数 然后只将符合要求的边加入图中 如果到终点的最短路大于等于血量 或者直接起点不能到达终点那么说明不符合要求 需要加大答案 时间复杂度 (log答案)* Ek 需要注意如果本来就不能到达 那么直接输出AFK 1 #include <bits/stdc++.h> 2 #define LL long long 3 #define For(i,j,k) for(int i=j;i<=k;i++) 4 using

hdu 2962 Trucking (二分+最短路Spfa)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2962 Trucking Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1763    Accepted Submission(s): 618 Problem Description A certain local trucking co

nyoj1006(最短路次短路spfa)

偷西瓜 时间限制:1000 ms  |  内存限制:65535 KB 难度:4 描述 对于农村的孩子来说最大的乐趣,莫过于和小伙伴们一块下地偷西瓜了,虽然孩子们条件不是很好,但是往往他们很聪明,他们总在计算着到达瓜田的距离,以及逃跑的路线,他们总是以最短的距离冲到瓜田里面,然后以最短的距离回到出发的地方,不过瓜田的大人们已经在他们来的路上等待他们.于是聪明的小伙伴们便不走过的路,即每条路只走一遍,如果小伙伴们回不到出发的地方,他们就说"eating", 我们假设 有 n (n<=

POJ3255:Roadblocks(次短路 SPFA+A星)

给出1-N 个点 的距离, 求从1号到N号的次短路, 直接用k短路来做了,,dj会TLE, 用spfa就过了 题目: I - RoadblocksTime Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Description Bessie has moved to a small farm and sometimes enjoys returning to visit o

It&amp;#39;s not a Bug, It&amp;#39;s a Feature! (poj 1482 最短路SPFA+隐式图+位运算)

Language: Default It's not a Bug, It's a Feature! Time Limit: 5000MS   Memory Limit: 30000K Total Submissions: 1353   Accepted: 516 Description It is a curious fact that consumers buying a new software product generally do not expect the software to

uva 10099 The Tourist Guide(单源最短路/spfa/dijkstra)

题目: 链接:点击打开链接 题意: 思路: 代码: #include <iostream> #include <cstring> #include <cstdio> using namespace std; int map[101][101]; void floyd(int n) { for(int k=1; k<=n; k++) for(int i=1; i<=n; i++) for(int j=1; j<=n; j++) map[i][j] = m

poj1511 最短路 spfa

// poj1511 最短路 spfa // // Bellman-Ford 队列优化 // // 留个spfa模板,精髓就是不断松弛,并将可能会影响 // 结果的点,如果在队列中不用加,不在就加入. #include <cstdio> #include <algorithm> #include <cstring> #include <iostream> #include <queue> typedef long long ll; using n