ZOJ 3204 Connect them(最小生成树:kruscal算法)

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3204

Connect them


Time Limit: 1 Second     Memory Limit:32768 KB



You have n computers numbered from 1 to
n
and you want to connect them to make a small local area network (LAN).All connections are two-way (that is connecting computersi andj is the same as connecting computersj and
i). The cost of connecting computeri and computerj is
cij
. You cannot connect some pairs of computers due to some particular reasons. You want to connect them so that every computer connects to any other one directly or indirectly and you also want to pay as little as possible.

Given n and each cij , find the cheapest way to connect computers.

Input

There are multiple test cases. The first line of input contains an integerT (T <= 100), indicating the number of test cases. ThenT test cases follow.

The first line of each test case contains an integern (1 <n <= 100). Thenn lines follow, each of which containsn integers separated by a space. Thej-th integer of thei-th
line in thesen lines is cij, indicating the cost of connecting computersi andj (cij = 0 means that you cannot connect them). 0 <=cij <= 60000,cij =
cji,cii = 0, 1 <=i, j <=n.

Output

For each test case, if you can connect the computers together, output the method in in the following fomat:

i1 j1
i
1 j1 ......

where ik ik (k >= 1) are the identification numbers of the two computers to be connected. All the integers must be separated by a space and there must be no extra space at the end of the line.If
there are multiple solutions, output the lexicographically smallest one (see hints for the definition of "lexicography small")If you cannot connect them, just output "-1" in the line.

Sample Input

2
3
0 2 3
2 0 5
3 5 0
2
0 0
0 0

Sample Output

1 2 1 3
-1

Hints:

A solution A is a line of p integers: a1,
a2
, ...ap.

Another solution B different from A is a line of q integers:b1,b2, ...bq.

A is lexicographically smaller than B if and only if:

(1) there exists a positive integer r (r <= p, r <=q) such thatai =bi for all 0 <i <
r andar <br

OR

(2) p < q and ai = bi for all 0 <i <=p

题目大意:题目大意:有几台电脑,怎么用最少的费用把他

们连接起来

  

解题思路:最小生成树问题。先将边从小到大排序,依次把

边两端的点用并查集合并。需要注意的是,题目中

给出的矩阵上三角和下三角是相同的,即只需处理

一半就可以啦。

<span style="font-size:24px;">///知识点:最小生成树
 #include<iostream>
 #include<cstdio>
 #include<algorithm>
 #include<cstring>
 using namespace std;

 const int maxn=110;
 int f[maxn];
 struct Edge
 {
     int from,to;
     int w;
 }edge[maxn*maxn];
 int tol;
 Edge ans[maxn*maxn];
 int cnt;
 void addedge(int u,int v,int w)
 {
     edge[tol].from=u;
     edge[tol].to=v;
     edge[tol].w=w;
     tol++;
 }
 bool cmp1(Edge a,Edge b)
 {
     if(a.w!=b.w) return a.w<b.w;
     else if(a.from!=b.from) return a.from<b.from;
     else return a.to<b.to;
 }
 bool cmp2(Edge a,Edge b)
 {
     if(a.from!=b.from) return a.from<b.from;
     else return a.to<b.to;
 }
 int find(int x)
 {
     if(f[x]==-1) return x;
     return f[x]=find(f[x]);
 }
 void kruscal()
 {
     memset(f,-1,sizeof(f));
     cnt=0;
     for(int k=0;k<tol;k++)
     {
         int u=edge[k].from;
         int v=edge[k].to;
         int t1=find(u);
         int t2=find(v);
         if(t1!=t2)
         {
             ans[cnt++]=edge[k];
             f[t1]=t2;
         }
     }
 }
 int main()
 {
     int T;
     scanf("%d",&T);
     int n;
     while(T--)
     {
         scanf("%d",&n);
         tol=0;
         int w;
         for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
         {
             scanf("%d",&w);
             if(j<=i) continue;
             if(w==0) continue;
             addedge(i,j,w);
         }
         sort(edge,edge+tol,cmp1);
         kruscal();
         if(cnt!=n-1)
         {
             printf("-1\n");
             continue;
         }
         else
         {
             sort(ans,ans+cnt,cmp2);
             for(int i=0;i<cnt-1;i++)
                printf("%d %d ",ans[i].from,ans[i].to);
             printf("%d %d\n",ans[cnt-1].from,ans[cnt-1].to);
         }
     }
     return 0;
 }</span>

版权声明:本文为博主原创文章,转载记得著名出处,谢谢!

时间: 2024-10-08 23:29:36

ZOJ 3204 Connect them(最小生成树:kruscal算法)的相关文章

ZOJ 3204 Connect them (C) 最小生成树kruskal

Connect them Time Limit: 1 Second      Memory Limit: 32768 KB You have n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN). All connections are two-way (that is connecting computers i and j is the sa

ZOJ 3204 Connect them(最小生成树之Krusal 输出字典序最小的)

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3367 You have n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN). All connections are two-way (that is connecting computers i and j is

ZOJ 3204 Connect them(最小生成树+最小字典序)

Connect them Time Limit: 1 Second      Memory Limit: 32768 KB You have n computers numbered from 1 to n and you want to connect them to make a small local area network (LAN). All connections are two-way (that is connecting computers iand j is the sam

zoj 3204 Connect them(最小生成树)

题意:裸最小生成树,主要是要按照字典序. 思路:模板 prim: #include<iostream> #include<stdio.h> #include<string.h> #include<algorithm> using namespace std; #define INF 0x7fffffff #define MAXN 128 bool vis[MAXN]; int lowu[MAXN];//记录起始边(已加入集合中的边) int lowc[MAX

ZOJ 3204 Connect them MST-Kruscal

这道题目麻烦在输出的时候需要按照字典序输出,不过写了 Compare 函数还是比较简单的 因为是裸的 Kruscal ,所以就直接上代码了- Source Code : //#pragma comment(linker, "/STACK:16777216") //for c++ Compiler #include <stdio.h> #include <iostream> #include <fstream> #include <cstring

zoj 1203 Swordfish 【最小生成树 prim 算法】

Swordfish Time Limit: 2 Seconds      Memory Limit: 65536 KB There exists a world within our world A world beneath what we call cyberspace. A world protected by firewalls, passwords and the most advanced security systems. In this world we hide our dee

ZOJ 3204: Connect Them

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3367 #include <iostream> #include <algorithm> #include <limits> #include <queue> using namespace std; const int MAXN = 105, INF = numeric_limits<int>::max(); typedef

hihocoder1098最小生成树(kruscal算法)

kruscal算法描述: kruscal算法的思路是:最初,把所有节点都看成孤立的集合,将图中所有的边按权重从小到大排序,然后依次遍历这些边,若边的两个端点在两个不同的集合中,则合并这条边的端点所属的两个集合,直到选出n-1条边将图中的所有n个节点都合并到了同一个集合,n-1次合并就选出了n-1条边,由这n-1条边和图上的n哥节点所构成的就是我们需要的该图的最小生成树. kruscal算法的性能依赖于边的数目,故对于稀疏图的最小生成树问题,采用kruscal算法比较优越. 我的代码: 1 #in

Hihocoder #1098 : 最小生成树二&#183;Kruscal算法 ( *【模板】 )

#1098 : 最小生成树二·Kruscal算法 时间限制:10000ms 单点时限:1000ms 内存限制:256MB 描述 随着小Hi拥有城市数目的增加,在之间所使用的Prim算法已经无法继续使用了——但是幸运的是,经过计算机的分析,小Hi已经筛选出了一些比较适合建造道路的路线,这个数量并没有特别的大. 所以问题变成了——小Hi现在手上拥有N座城市,且已知其中一些城市间建造道路的费用,小Hi希望知道,最少花费多少就可以使得任意两座城市都可以 通过所建造的道路互相到达(假设有A.B.C三座城市