【洛谷P2858·动态规划】[USACO06FEB]奶牛零食Treats for the Cows

题面

题目描述

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.Like fine wines and delicious cheeses, the treats improve with age and command greater prices.The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

约翰经常给产奶量高的奶牛发特殊津贴,于是很快奶牛们拥有了大笔不知该怎么花的钱.为此,约翰购置了N(1≤N≤2000)份美味的零食来卖给奶牛们.每天约翰售出一份零食.当然约翰希望这些零食全部售出后能得到最大的收益.这些零食有以下这些有趣的特性:

?零食按照1..N编号,它们被排成一列放在一个很长的盒子里.盒子的两端都有开口,约翰每

天可以从盒子的任一端取出最外面的一个.

?与美酒与好吃的奶酪相似,这些零食储存得越久就越好吃.当然,这样约翰就可以把它们卖出更高的价钱.

?每份零食的初始价值不一定相同.约翰进货时,第i份零食的初始价值为Vi(1≤Vi≤1000).

?第i份零食如果在被买进后的第a天出售,则它的售价是vi×a.

Vi的是从盒子顶端往下的第i份零食的初始价值.约翰告诉了你所有零食的初始价值,并希望你能帮他计算一下,在这些零食全被卖出后,他最多能得到多少钱.

输入输出格式

输入格式:

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)

输出格式:

Line 1: The maximum revenue FJ can achieve by selling the treats

输入输出样例

输入样例#1:

5
1
3
1
5
2

输出样例#1:

43

说明

Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

分析

思路:搜索、DP或贪心。

搜索没法用,因为这个题目数据范围不小,而且没法像求最小方案那样剪枝优化。

贪心很快能找到反例,例如(6, 1, 3, 4, 5),贪心做法是 5x1 + 4x2 + 3x3 + 1x4 + 6x5 = 56,然而存在着更优的解法:6x1 + 1x2 + 3x3 + 4x4 + 5x5 = 58。

因此只能用DP了。

思路我也不知道是怎么想出来的,也就是灵光一现吧。

设f[i][j]表示共拿了i个,右边拿了j个所得的最大收益;a[i]表示第i格零食的原始价值(即vi)。

那么有:

f[0][0]=0

f[i][0]=f[i-1][0]+a[i]*i

f[i][j]=max{a[i-1][j-1]+a[n-j+1]*i, a[i-1][j]+a[i-j]*i}

f[i][i]=f[i-1][i-1]+a[n-i+1]*i

第一个方程,如果取了0个东西,那收益就为0。

第二个方程,取了i个东西、右边取出0个,换句话说就是全部都从左边取。那么价值就是从左边取了(i-1)个东西+第i个东西的当前价值

第三个方程分为两个部分,一个是a[i-1][j-1]+a[n-j+1]*i,另一个是a[i-1][j]+a[i-j]*i。

举个例子,比如“左边取了2个,右边取了3个”的状态,可以通过“左边取了1个,右边取了3个“+左数第2个东西的当前价值、或“左边取了2个,右边取了2个“+右数第3个东西的当前价值得到。

第一个是拿右边,第二个是拿左边。

这就是这个方程的由来。

第四个方程和第二个类似。

(区间DP?什么是区间DP?)

程序

#include <cstdio>
#include <algorithm>
using namespace std;
int a[2005];
int dp[2005][2005];
int main(){
    int i, j;
    int n;
    int ans=0;

    scanf("%d", &n);
    for(i=1; i<=n; i++)
        scanf("%d", &a[i]);

    for(i=1; i<=n; i++){
        dp[i][0]=dp[i-1][0]+a[i]*i;
        //明显只能拿左边
        for(j=1; j<i; j++){
            dp[i][j]=max(dp[i-1][j-1]+a[n-j+1]*i, dp[i-1][j]+a[i-j]*i);
            //前一个是拿右边,后一个是不拿右边
        }
        dp[i][i]=dp[i-1][i-1]+a[n-i+1]*i;
    }

    for(i=0; i<=n; i++)
        ans=max(ans, dp[n][i]);
    printf("%d", ans);
    return 0;
}
时间: 2024-11-09 00:42:14

【洛谷P2858·动态规划】[USACO06FEB]奶牛零食Treats for the Cows的相关文章

AC日记——[USACO06FEB]奶牛零食Treats for the Cows 洛谷 P2858

[USACO06FEB]奶牛零食Treats for the Cows 思路: 区间DP: 代码: #include <bits/stdc++.h> using namespace std; #define maxn 2005 #define ll long long ll n,ai[maxn],dp[maxn][maxn],sum[maxn]; inline void in(ll &now) { char Cget=getchar();now=0; while(Cget>'9'

洛谷 P2858 [USACO06FEB]奶牛零食Treats for the Cows

题目描述 FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time. The treats are interesting for many re

P2858 [USACO06FEB]奶牛零食Treats for the Cows

题目描述 FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time. The treats are interesting for many re

[Luogu] P2858 [USACO06FEB]奶牛零食Treats for the Cows

题目描述 约翰经常给产奶量高的奶牛发特殊津贴,于是很快奶牛们拥有了大笔不知该怎么花的钱.为此,约翰购置了N(1≤N≤2000)份美味的零食来卖给奶牛们.每天约翰售出一份零食.当然约翰希望这些零食全部售出后能得到最大的收益.这些零食有以下这些有趣的特性: •零食按照 1...N 编号,它们被排成一列放在一个很长的盒子里.盒子的两端都有开口,约翰每天可以从盒子的任一端取出最外面的一个. •与美酒与好吃的奶酪相似,这些零食储存得越久就越好吃.当然,这样约翰就可以把它们卖出更高的价钱. •每份零食的初始

[luoguP2858] [USACO06FEB]奶牛零食Treats for the Cows(DP)

传送门 f[i][j][k] 表示 左右两段取到 i .... j 时,取 k 次的最优解 可以优化 k 其实等于 n - j + i 则 f[i][j] = max(f[i + 1][j] + a[i] * (n - j + i), f[i][j - 1] + a[j] * (n - j + i)) 边界 f[i][i] = a[i] * n 递推顺序不好求,所以选择记忆化搜索. ——代码 1 #include <cstdio> 2 #include <iostream> 3 4

洛谷 P2915 【[USACO08NOV]奶牛混合起来Mixed Up Cows】

类似于n皇后的思想,只要把dfs表示放置情况的数字压缩成一个整数,就能实现记忆化搜索了. 一些有关集合的操作: {i}在集合S内:S&(1<<i)==1: 将{i}加入集合S:S=S|(1<<i): 集合S内包含了{0,1,2,...,n-2,n-1}:S==(1<<n)-1: 1 #include <cstdio> 2 #include <cstring> 3 #include <cmath> 4 using namespa

动态规划 洛谷P1868 饥饿的奶牛

P1868 饥饿的奶牛 题目描述 有一条奶牛冲出了围栏,来到了一处圣地(对于奶牛来说),上面用牛语写着一段文字. 现用汉语翻译为: 有N个区间,每个区间x,y表示提供的x~y共y-x+1堆优质牧草.你可以选择任意区间但不能有重复的部分. 对于奶牛来说,自然是吃的越多越好,然而奶牛智商有限,现在请你帮助他. 输入输出格式 输入格式: 第一行,N,如题 接下来N行,每行一个数x,y,如题 输出格式: 一个数,最多的区间数 输入输出样例 输入样例#1: 3 1 3 7 8 3 4 输出样例#1: 5

洛谷 1345 [USACO5.4]奶牛的电信Telecowmunication

题目描述 农夫约翰的奶牛们喜欢通过电邮保持联系,于是她们建立了一个奶牛电脑网络,以便互相交流.这些机器用如下的方式发送电邮:如果存在一个由c台电脑组成的序列a1,a2,...,a(c),且a1与a2相连,a2与a3相连,等等,那么电脑a1和a(c)就可以互发电邮. 很不幸,有时候奶牛会不小心踩到电脑上,农夫约翰的车也可能碾过电脑,这台倒霉的电脑就会坏掉.这意味着这台电脑不能再发送电邮了,于是与这台电脑相关的连接也就不可用了. 有两头奶牛就想:如果我们两个不能互发电邮,至少需要坏掉多少台电脑呢?请

洛谷P2868 [USACO07DEC]观光奶牛 Sightseeing Cows

题目描述 Farmer John has decided to reward his cows for their hard work by taking them on a tour of the big city! The cows must decide how best to spend their free time. Fortunately, they have a detailed city map showing the L (2 ≤ L ≤ 1000) major landma