POJ 3252- Round Numbers(求区间中二进制数中0个数大于1的数的总数)

Round Numbers

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 10008   Accepted: 3628

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone‘ (also known as ‘Rock, Paper, Scissors‘, ‘Ro, Sham, Bo‘, and a host of other names) in order to make arbitrary decisions such as who gets to be milked first.
They can‘t even flip a coin because it‘s so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,

otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus,
9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start..Finish

Sample Input

2 12

Sample Output

6

题意:输入两个十进制正整数a和b,求闭区间[a ,b]内有多少个Round number。所谓的Round Number就是把一个十进制数转换为一个无符号二进制数,若该二进制数中0的个数大于等于1的个数,则它就是一个Round Number。

思路:

要知道闭区间[a ,b]内有多少个Round number,只需要分别求出

闭区间[0 ,a]内有T个RN,闭区间[0 ,b+1]内有S个RN

再用S – T就是闭区间[a ,b]内的RN数了

至于为什么是b+1,因为对于闭区间[0 ,k],我下面要说的算法求出的是比k小的RN数,就是说不管k是不是RN,都没有被计算在内,所以若要把闭区间[a ,b]的边界a和b都计算在内,就要用上述的处理方法。

详细解答:点击打开链接

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;
const double eps=1e-10;
const double pi= acos(-1.0);
int c[35][35]= {0};
int two[35];
int len;
void C() {//从n件物品中取m件有多少种取法
  int i,j;
  c[0][0]=1;
  for(i=1;i<36;i++)
    for(j=0;j<=i;j++)
    if(!j)
    c[i][j]=c[i-1][j];
  else
    c[i][j]=c[i-1][j]+c[i-1][j-1];
}
void Ten_to_two(int x)//逆序存储二进制数
{
    len=0;
    while(x) {
        two[len++]=x%2;
        x=x/2;
    }
}
int RN(int n) {//求RN
    int i,j;
    int sum=0;
    Ten_to_two(n);
    //求二进制长度小于len的所有二进制数中RN的个数
    for(i=1; i<len-1; i++)//i+1(i+1<len)位数的二进制位数,第一位必为1,故不计入
        for(j=i/2+1; j<=i; j++)//j为其中0的位数
            sum+=c[i][j];
    int zero=0;//从高位向低位搜索中0的位的个数
    //求二进制长度等于len的所有二进制数中RN的个数
    for(i=len-2;i>=0;i--)
        if(two[i])//当前位为1
        for(j=(len+1)/2-(zero+1);j<=i;j++)
        sum+=c[i][j];
        else
        zero++;//zero记录在搜索过程中,已发现的0的个数
    return sum;
}

int main()
{
    int a,b;
    C();
    while(~scanf("%d %d",&a,&b)){
        printf("%d\n",RN(b+1)-RN(a));//此处亦有讲究,由于我们的round()所得为小于n的RN的个数,所b+1
    }
    return 0;
}
时间: 2024-07-30 10:27:20

POJ 3252- Round Numbers(求区间中二进制数中0个数大于1的数的总数)的相关文章

[ACM] POJ 3252 Round Numbers (一个区间内二进制中0的个数大于等于1的个数有多少个,组合)

Round Numbers Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 8590   Accepted: 3003 Description The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors',

POJ 3252 Round Numbers (区间DP,基础)

题意: 统计区间[L,R]有多少个数,其二进制表示法中的0的个数不少于1的个数?(不允许前缀0) 思路: 状态表示为 [当前第几位][总位数][1的个数],最后判断一下1的个数是否满足条件,要注意前导0的问题,可以通过枚举二进制的位数来解决. 1 //#include <bits/stdc++.h> 2 #include <iostream> 3 #include <cstdio> 4 #include <cstring> 5 #include <cm

poj 3252 Round Numbers 【推导&#183;排列组合】

以sample为例子 [2,12]区间的RoundNumbers(简称RN)个数:Rn[2,12]=Rn[0,12]-Rn[0,1] 即:Rn[start,finish]=Rn[0,finish]-Rn[0,start-1] 所以关键是给定一个X,求出Rn[0,X] 现在假设X=10100100  这个X的二进制总共是8位,任何一个小于8位的二进制都小于X 第一部分,求出长度为[0,7]区间内的二进制是RoundNumber的个数  对于一个长度为Len的二进制(最高位为1),如何求出他的Rou

POJ 3252 Round Numbers 数学题解

Description The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets

POJ 3252 Round Numbers

Round Numbers Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 12824   Accepted: 4946 Description The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors',

POJ 3252 Round Numbers(数位dp&amp;amp;记忆化搜索)

题目链接:[kuangbin带你飞]专题十五 数位DP E - Round Numbers 题意 给定区间.求转化为二进制后当中0比1多或相等的数字的个数. 思路 将数字转化为二进制进行数位dp,由于一个二进制数的最高位必须为1.所以设置变量first记录前面位是否有1,若有1,则可随意放,否则,仅仅可放1. 同一时候.上面的推断决定了搜索时len的大小与二进制本身的长度不一定相等,所以需两个变量对1和0的个数进行记录. 用dp[a][b][c]保存长度a,b个0,c个1的数字个数.记忆化搜索.

poj 3252 Round Numbers (组合数学)

链接 :poj 3252 题意:一个数转化成二进制之后,0的个数大于等于1的为round数, 给定一个区间[m,n],问这区间内有多少round数 分析:要求[m,n]间的的round数, 可以用[1,n+1)的个数减去[1,m)的个数, 对于比N小的round数的个数: 化为二进制的长度比N的长度小的数:如果长度为L,那么高位肯定是1, 然后枚举0的个数,利用组合数求即可 长度和N相等但比N小的数: 从高位开始枚举,若出现1,则将这位看作0,再枚举之后的低位,肯定是比原数小的 依次下去,注意统

POJ 3252 Round Numbers 组合数学

Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 13381   Accepted: 5208 Description The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo

POJ 3252 Round Numbers(组合数学)

Round Numbers Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 10223   Accepted: 3726 Description The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors',