AcWing 793.高精度乘法

AcWing 793.高精度乘法

题目描述

给定两个正整数A和B,请你计算A * B的值。

输入格式

共两行,第一行包含整数A,第二行包含整数B。

输出格式

共一行,包含A * B的值。

数据范围

1≤A的长度≤100000,
1≤B≤10000

输入样例

2
3

输出样例

6

题目思路

低角标存低位,高角标存高位;依次进位,用A[i]乘整个b

#include<iostream>
#include<string>
#include<vector>
using namespace std;

vector<int> mul(vector<int> &A,int &b)
{
    vector<int> C;
    for(int i=0,t=0;i<A.size()||t;i++)
    {
        if(i<A.size())
            t += A[i] * b;
        C.push_back(t%10);
        t /= 10;
    }
    return C;
}

int main()
{
    string a;
    int b;
    cin >> a >> b;
    vector<int> A,C;
    for(int i=a.size()-1;i>=0;i--) A.push_back(a[i] - '0');

    C = mul(A,b);

    for(int i=C.size()-1;i>=0;i--) printf("%d",C[i]);
    return 0;
}

原文地址:https://www.cnblogs.com/fsh001/p/12242588.html

时间: 2024-11-05 22:54:54

AcWing 793.高精度乘法的相关文章

高精度乘除法模板(AcWing.793 794)

高精度乘法一般都是由一个大数乘以一个可以由int存放的整数类型. #include <iostream> #include <vector> using namespace std; vector<int> mul(vector<int> &a,int b){ int t = 0; vector<int> c; for (int i=0;i<a.size()||t; i++){ //判断程序终止的条件有两个一个是i小于数组长度另一个

高精度乘法程序

对于超过20位的数的乘法问题,我们无法使用普通的方法!!!即使是longlong也会超出范围的!像这样的数,我们只能使用高精度的知识利用数组的方法解决问题!对于高精度乘法的问题,其实思路和高精度加法的思路差不多,都需要使用字符数组来存放每次算完的结果!        1  2  3        *4  5  6    ________________      12  15  18   8  10  124  5   6  _____________________4 13   28   27

POJ 1306 Combinations 高精度乘法

题目大意:给出mn,让你求C(m,n). 思路:公式都给你了,就100,暴力就可以关键还是高精度.如果按照算法"它让你怎么做你就怎么做",那么很显然你需要写一个高精度除法.然而可以证明,这个除法是不会产生余数的.所以我们可以数论分析,然后避免高精度除法. 方法就是暴力求每个数的质因数,然后把被除数和除数相同的质因数消去,最后除数肯定会被消没.这样只要做高精度乘法就可以了. CODE: #include <cstdio> #include <cstring> #i

poj1001(高精度乘法)

1.题目表述 Exponentiation Time Limit: 500MS   Memory Limit: 10000K Total Submissions: 135893   Accepted: 33256 Description Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation o

真真真&#183;?高精度乘法!!!!!

RX-0奉上哈哈哈哈哈哈哈哈哈哈哈哈哈™™™ 先奉上真真真·高精度乘法源代码: 高精度乘法 RX-0制作最后修改:2016年7月6日#include<stdio.h>#include<string.h>#include<math.h>char s[10000],b;int a[10000];int c[10000];int main(){ int x,l=0,y=1,i,j,m,l1=0; long long s1=0; //freopen("hp.in&qu

[转]高精度乘法计算

转载自: Daywei 高精度乘法计算 高精度乘法计算基础 1.高精度浮点运算方法 高精度浮点(Floating Point,FP)运算可以转换成整数型运算.由于高精度浮点数可以看成是由整数部分(Integer Part,IP)与小数部分(Decimal Part,DP)的组合,因此其乘法可以看成以下3种运算的组合,即整数x整数(IxI).整数x小数(IxD)和小数x小数(DxD).用表达式表示, 则FP1*FP2=IP1*IP2+(IP1*DP2+IP2*DP1)+DP1*DP2 (1)对于I

[vijos P1040] 高精度乘法

如果这次noip没考好,完全是因为从7月29日之后就没有再写过程序了.说起来,真是一个泪流满面的事实… 那这样一个弱智题练手恢复代码能力,竟然还花了我两个晚上(当然不是两整个晚上…) 第一天TLE了,好在我机智,一看到解题里说要压位就自动脑补出压位了. 代码风格非常诡异,弱智题竟然写到2KB我也是醉了. program vijos_p1040; const maxn=10020; var a,b,aa,bb:array[1..maxn] of integer; c:array[1..2*maxn

【PKU1001】Exponentiation(高精度乘法)

Exponentiation Time Limit: 500MS   Memory Limit: 10000K Total Submissions: 145642   Accepted: 35529 Description Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the n

HDU 1042.N!【高精度乘法】【8月24】

N! Problem Description Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N! Input One N in one line, process to the end of file. Output For each N, output N! in one line. Sample Input 1 2 3 Sample Output 1 2 6 高精度乘法.数组存,每一位存5位数,不然会严重超时.另外,