hdu Swipe Bo(bfs+状态压缩)错了多次的题

Swipe Bo

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1549    Accepted Submission(s): 315

Problem Description

“Swipe Bo” is a puzzle game that requires foresight and skill.

The main character of this game is a square blue tofu called Bo. We can swipe up / down / left / right to move Bo up / down / left / right. Bo always moves in a straight line and nothing can stop it except a wall. You need to help Bo find the way out.

The picture A shows that we needs three steps to swipe Bo to the exit (swipe up, swipe left, swipe down). In a similar way, we need only two steps to make Bo disappear from the world (swipe left, swipe up)!

Look at the picture B. The exit is locked, so we have to swipe Bo to get all the keys to unlock the exit. When Bo get all the keys, the exit will unlock automatically .The exit is considered inexistent if locked. And you may notice that there are some turning
signs, Bo will make a turn as soon as it meets a

turning signs. For example, if we swipe Bo up, it will go along the purple line.

Now, your task is to write a program to calculate the minimum number of moves needed for us to swipe Bo to the exit.

Input

The input contains multiple cases, no more than 40.

The first line of each test case contains two integers N and M (1≤N, M≤200), which denote the sizes of the map. The next N lines give the map’s layout, with each line containing M characters. A character is one of the following: ‘#‘: represents the wall; ‘S‘
represents the start point of the Bo; ‘E‘ represents the exit; ‘.‘ represents an empty block; ‘K’ represents the key, and there are no more than 7 keys in the map; ‘L‘,‘U‘,‘D‘,‘R‘ represents the turning sign with the direction of left, up, down, right.

Output

For each test case of the input you have to calculate the minimal amount of moves which are necessary to make Bo move from the starting point to the exit. If Bo cannot reach the exit, output -1. The answer must be written on a single line.

Sample Input

5 6
######
#....#
.E...#
..S.##
.#####
5 6
######
#....#
.....#
SEK.##
.#####
5 6
######
#....#
....K#
SEK.##
.#####
5 6
######
#....#
D...E#
S...L#
.#####

Sample Output

3
2
7
-1

Source

2013 Multi-University Training Contest 4

题意:有一个迷宫,包含墙、空白格子、起点S、终点E、方向格子(LRUD)和钥匙K。要求如下:

(1)每次转弯只能在碰到墙壁时(每次转弯的选择和初始时从S出发的方向选择均称为一次操作);

(2)对于方向格子,若到达该格子,不管周围是不是墙,必须转向该格子指示的方向(这个不算一次操作);

(3)若迷宫中没有钥匙存在,则求出S到E的最少操作次数;若有钥匙,则必须先遍历到每个钥匙之后才能去E(在这个过程中可以经过E也就是E不算做障碍)。

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;

const int N  = 225;
const int inf = 1<<29;
struct node{
    int x,y,sta,stp;
};
int n,m,k;
char mapt[N][N];
int K[N][N];
bool vist[N][N][1<<7];
int dir[4][2]={0,-1,0,1,-1,0,1,0};

int judge1(node& now,int &e){
    int flag=0;
        if(now.x<0||now.x>=n||now.y<0||now.y>=m)
            return 0;
        if(mapt[now.x][now.y]!='#'){

            if(mapt[now.x][now.y]=='L')
                    e=0,flag=1;
            else if(mapt[now.x][now.y]=='R')
                        e=1,flag=1;
            else if(mapt[now.x][now.y]=='U')
                        e=2,flag=1;
            else if(mapt[now.x][now.y]=='D')
                        e=3,flag=1;
             else if(mapt[now.x][now.y]=='K')
                        now.sta|=(1<<K[now.x][now.y]);
            if(flag&&vist[now.x][now.y][now.sta])
                return 0;
            else if(flag) vist[now.x][now.y][now.sta]=1;  //固定方向的位置,可以直接标记
            return 1;
        }
        else    //遇到墙,退一格,在当前位置停止
        {
            now.x-=dir[e][0];
            now.y-=dir[e][1];
            return 2;
        }

}
int bfs(int sx,int sy){
    queue<node>q;
    node now,pre;

    for(int i=0; i<n; i++)
        for(int j=0; j<m; j++)
         for(int sta=0; sta<(1<<k); sta++)
          vist[i][j][sta]=0;

        now.x=sx,now.y=sy,now.sta=0,now.stp=0;
        q.push(now);
        vist[now.x][now.y][now.sta]=1;

    while(!q.empty()){
        pre=q.front(); q.pop();
        pre.stp++;

        for(int te=0; te<4; te++){
            int e=te;
            now=pre;
            while(1){   //找到一个停止点,或不能走,或走过了,则跳出
                now.x+=dir[e][0];
                now.y+=dir[e][1];

                int flag=judge1(now,e);

                if(flag==0)break;
                if(flag==1&&mapt[now.x][now.y]=='E'&&now.sta==(1<<k)-1){
                    return now.stp;
                }
                if(flag==2){
                    if(vist[now.x][now.y][now.sta])break;
                    vist[now.x][now.y][now.sta]=1;
                    q.push(now);
                    break;
                }
            }
        }
    }

    return -1;
}
int main()
{
    int sx,sy;
    while(scanf("%d%d",&n,&m)>0){
            k=0;
        for(int i=0; i<n; i++){
            scanf("%s",mapt[i]);
            for(int j=0; j<m; j++)
            if(mapt[i][j]=='S')
             sx=i,sy=j;
            else if(mapt[i][j]=='K')
                K[i][j]=k++;
        }
        printf("%d\n",bfs(sx,sy));
    }
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-11-05 01:17:06

hdu Swipe Bo(bfs+状态压缩)错了多次的题的相关文章

hdu 4856 Tunnels(bfs+状态压缩)

题目链接:hdu 4856 Tunnels 题目大意:给定一张图,图上有M个管道,管道给定入口和出口,单向,现在有人想要体验下这M个管道,问最短需要移动的距离,起点未定. 解题思路:首先用bfs处理出两两管道之间移动的距离,然后后用状态压缩求出最短代价,dp[i][j],i表示的已经走过的管道,j是当前所在的管道. #include <cstdio> #include <cstring> #include <queue> #include <algorithm&g

hdu 5094 Maze bfs+状态压缩

Maze Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 100000/100000 K (Java/Others) Total Submission(s): 642    Accepted Submission(s): 229 Problem Description This story happened on the background of Star Trek. Spock, the deputy captain of St

hdu 3001 Travelling (bfs+状态压缩)

Travelling Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3905    Accepted Submission(s): 1234 Problem Description After coding so many days,Mr Acmer wants to have a good rest.So travelling is

hdu 1429 (bfs+状态压缩)

胜利大逃亡(续) Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 5283    Accepted Submission(s): 1815 Problem Description Ignatius再次被魔王抓走了(搞不懂他咋这么讨魔王喜欢)-- 这次魔王汲取了上次的教训,把Ignatius关在一个n*m的地牢里,并在地牢的某些地方安装了

HDU 1885Key Task(bfs + 状态压缩)

Key Task Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1529 Accepted Submission(s): 631 Problem Description The Czech Technical University is rather old - you already know that it celebrates 300

hdu 1429(BFS+状态压缩)

胜利大逃亡(续) Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 8379    Accepted Submission(s): 3008 Problem Description Ignatius再次被魔王抓走了(搞不懂他咋这么讨魔王喜欢)--这次魔王汲取了上次的教训,把Ignatius关在一个n*m的地牢里,并在地牢的某些地方安装了带锁

HDU 3247 Resource Archiver (AC自己主动机 + BFS + 状态压缩DP)

题目链接:Resource Archiver 解析:n个正常的串.m个病毒串,问包括全部正常串(可重叠)且不包括不论什么病毒串的字符串的最小长度为多少. AC自己主动机 + bfs + 状态压缩DP 用最短路预处理出状态的转移.能够优化非常多 AC代码: #include <cstdio> #include <iostream> #include <cstring> #include <algorithm> #include <queue> us

HDU 3247 Resource Archiver (AC自动机 + BFS + 状态压缩DP)

题目链接:Resource Archiver 解析:n个正常的串,m个病毒串,问包含所有正常串(可重叠)且不包含任何病毒串的字符串的最小长度为多少. AC自动机 + bfs + 状态压缩DP 用最短路预处理出状态的转移.可以优化很多 AC代码: #include <cstdio> #include <iostream> #include <cstring> #include <algorithm> #include <queue> using n

HDU 1885 Key Task 状态压缩+搜索

点击打开链接 Key Task Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1176    Accepted Submission(s): 462 Problem Description The Czech Technical University is rather old - you already know that it c