poj_1050

题目:

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner: 

9 2
-4 1
-1 8
and has a sum of 15.
Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output

Output the sum of the maximal sub-rectangle.
Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2
Sample Output

15

题目分析:(参考:http://blog.csdn.net/hitwhylz/article/details/11848439)

1、一维的最大子段和问题,给出一个序列a[0],a[1],a[2]...a[n],求出连续的一段,使其总和最大。
a[i]表示第i个元素
dp[i]表示以a[i]结尾的最大子段和
则动态转移方程为:dp[i] = max{a[i], dp[i-1] + a[i]}
解释一下方程:
如果dp[i-1] > 0,则 dp[i] = dp[i-1] + a[i]
如果dp[i-1] < 0,则 dp[i] = a[i]
因为不用记录位置信息,所以dp[]可以用一个变量dp代替:
如果dp > 0,则dp += a[i]
如果dp < 0,则dp = a[i]
2、二维的最大子矩阵问题
我们可以利用矩阵压缩把二维的问题转化为一维的最大子段和问题,将求二维矩阵最大和问题转变为求一维序列的最大连续各问题。因为是矩阵和,所以我们可以把这个矩形的高压缩成1,用加法就行了。什么叫做压缩呢?也就是把两行数组的元素,按列相加,组成新的数组;在题目中的具体应用是,如果是选择了起始行为1, 末行为3, 则其压缩成的数组的各个 元素有如下情况b[i] = a[0][i] + a[1][i] + a[2][i];

相关代码:

#include<stdio.h>
//dp[i] = max{dp[i-1] + v[i] , v[i]};
int MaxArray(int len, int* array) {
    int bp = array[0], i, max;
    max = bp;
    for(i = 1; i < len; ++i) {
        bp = bp > 0 ? (bp + array[i]) : array[i];;
        max = max < bp ? bp : max;
    }
    return max;
}

int main() {
    int n, i, j, k, max, sum;
    int tect[110][110], tmp[110];
    scanf("%d", &n);
    for(i = 0; i < n; ++i) {
        for(j = 0; j < n; ++j)
             scanf("%d", &tect[i][j]);
    }
    max = tect[0][0];

    for(i = 0; i < n; ++i) { //首行
        //当行变化时,压缩的新一维数组要初始化
        for(j = 0; j < n; ++j) {
            tmp[j] = 0;
        }

        for(j = i;j < n; ++j) { //末行
            for(k = 0; k < n; ++k) { //进行压缩转换为一维序列
                tmp[k] += tect[j][k];
            }
            sum = MaxArray(n, tmp); //转化为求一维的最大子序列和
            max = sum > max ? sum : max;
        }
    }
    printf("%d\n", max);
}
时间: 2024-10-06 20:28:17

poj_1050的相关文章