poj3311--Hie with the Pie(状压dp)

Hie with the Pie

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 4860   Accepted: 2581

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before
he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you
to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating
the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting
any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from
location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

题目大意,0代表商店,1到n代表去送货的地点,Map[i][j]代表从i到j的距离,每个点可以多次访问。问从商店出发,将商品送到n个地点再回到商店的最短时间。

首先floyd找出任意两点之间的最短距离。

状态代表访问了那几个地点,二进制数中第i个1表示第i个地点被访问,dp[i][j]在状态i时,以j为当前点的最短时间。

最后在找出 最后到达的地点+该地点到商店的 最小值。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;
#define INF 0x3f3f3f
int Map[15][15] , a[15] ;
int dp[5000][15] ;
void floyd(int n)
{
    int i , j , k ;
    for(k = 0 ; k <= n ; k++)
        for(i = 0 ; i <= n ; i++)
            for(j = 0 ; j <= n ; j++)
                if( Map[i][j] > Map[i][k] + Map[k][j])
                    Map[i][j] = Map[i][k] + Map[k][j] ;
}
int main()
{
    int n , i , j , k , x , ans ;
    while( scanf("%d", &n) && n )
    {
        for(i = 0 ; i <= n ; i++)
            for(j = 0 ; j <= n ; j++)
                scanf("%d", &Map[i][j]) ;
        floyd(n) ;
        x = 1<<n ;
        for(i = 0 ; i < x ; i++)
            for(j = 0 ; j < n ; j++)
                dp[i][j] = INF ;
        for(i = 0 ; i < n ; i++)
            dp[ 1<<i ][i] = Map[0][i+1] ;
        for(i = 1 ; i < x ; i++)
        {
            //printf("%d----", i) ;
            for(j = 0 ; j < n ; j++)
            {
                if( i & 1<<j )
                    a[j] = 1 ;
                else
                    a[j] = 0 ;
                //printf("%d ", a[j]) ;
            }
            //printf("\n") ;
            for(j = 0 ; j < n ; j++)
            {
                if( a[j] )
                {
                    for(k = 0 ; k < n ; k++)
                    {
                        if( !a[k] )
                        {
                            dp[i+(1<<k)][k] = min( dp[i+(1<<k)][k],dp[i][j] + Map[j+1][k+1] ) ;
                        }
                    }
                }
            }
            /*for(j = 0 ; j < n ; j++)
                printf("%d ", dp[i][j]) ;
            printf("\n") ;*/
        }
        int min1 = INF ;
        for(i = 0 ; i < n ; i++)
            min1 = min(min1,dp[x-1][i]+Map[i+1][0]);

        printf("%d\n", min1) ;
    }
    return 0;
}
时间: 2024-08-09 02:18:36

poj3311--Hie with the Pie(状压dp)的相关文章

poj3311(Hie with the Pie)状压dp

题目链接:http://poj.org/problem?id=3311 解法:标准的状压dp类型,先floyd获得两两之间最短距离.然后dp[i][j]表示剩下集合i没走,已经走到j的最短距离: 代码: /****************************************************** * @author:xiefubao *******************************************************/ #pragma comment(

POJ 3311 Hie with the Pie (状压DP)

状态压缩DP dp[i][j]表示在i状态(用二进制表示城市有没有经过)时最后到达j城市的最小时间 转移方程dp[i][j]=min(dp[i][k]+d[k][j],dp[i][j]) d[k][j]是k城市到j城市的最短距离 要先用flody处理 #include<bits.stdc++.h> using namespace std; int d[20][20],dp[1<<11][20]; int n,m; void flody() { for(int k=0;k<=n

poj3311Hie with the Pie状压dp

tsp,但是它可以每个点经过不止一次,所以求一遍最短路,然后搞. #include <cstdio> #include <cstring> #include <cmath> #include <algorithm> #include <climits> #include <string> #include <iostream> #include <map> #include <cstdlib> #i

状压DP Poj3311 Hie with the Pie

本人水平有限,题解不到为处,请多多谅解 本蒟蒻谢谢大家观看 题目: Problem C: Poj3311 Hie with the Pie Time Limit: 1 Sec  Memory Limit: 128 MBSubmit: 58  Solved: 29[Submit][Status][Web Board] Description The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast

POJ 3311 Hie with the Pie (状压DP)

题意: 每个点都可以走多次的TSP问题:有n个点(n<=11),从点1出发,经过其他所有点至少1次,并回到原点1,使得路程最短是多少? 思路: 同HDU 5418 VICTOR AND WORLD (可重复走的TSP问题,状压DP)这道题几乎一模一样. 1 //#include <bits/stdc++.h> 2 #include <iostream> 3 #include <cstdio> 4 #include <cstring> 5 #includ

poj 3311 Hie with the Pie 经过所有点(可重)的最短路径 状压dp

题目链接 题意 给定一个\(N\)个点的完全图(有向图),求从原点出发,经过所有点再回到原点的最短路径长度(可重复经过中途点). 思路 因为可多次经过同一个点,所以可用floyd先预处理出每两个点之间的最短路径. 接下来就是状压dp的部分. 将已经经过的点的状态用\(state\)表示, 则\(dp[state][k]\)表示当前到达点\(k\)后状态为\(state\)时的最短路径长度. \[ans=min_{i=1}^{n}(dp[(1<<n)-1][i]+dis[i][0])\] 可用记

Hie with the Pie(POJ 3311)状压DP

Description The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be

Travel(HDU 4284状压dp)

题意:给n个城市m条路的网图,pp在城市1有一定的钱,想游览这n个城市(包括1),到达一个城市要一定的花费,可以在城市工作赚钱,但前提有工作证(得到有一定的花费),没工作证不能在该城市工作,但可以走,一个城市只能工作一次,问pp是否能游览n个城市回到城市1. 分析:这个题想到杀怪(Survival(ZOJ 2297状压dp) 那个题,也是钱如果小于0就挂了,最后求剩余的最大钱数,先求出最短路和 Hie with the Pie(POJ 3311状压dp) 送披萨那个题相似. #include <

poj3311 Hie with the Pie 旅行商问题(TSP)

题目链接 http://poj.org/problem?id=3311 Hie with the Pie Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 5094   Accepted: 2716 Description The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortuna

POJ3311——Hie with the Pie

Hie with the Pie Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 4646   Accepted: 2457 Description The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can affo