1047. Student List for Course (25)

题目例如以下:

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student‘s name (3 capital English letters
plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students‘
names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

这是一道比較简单的统计、输出题目,由于输出不涉及查询,而是顺序输出。因此不必使用map进行倒排索引。仅仅须要给每门课一个vector<char*>,把全部选这门课的人压入对应容器,然后按字典序排序,最后输出。

须要注意的是。对于字符处理的题目,要尽量使用char*而避免使用string,尽管string非常方便,可是对于string的比較和拷贝操作会消耗大量时间。easy超时。

char*没有string好用,可是在c++特性下我么能够使用char* name = new char[4];来创建一个刚好容纳名字的空间,然后把它压入容器中。

对于char*的比較,刚開始我使用的是strcmp,可是它是s1<s2返回-1,s1==s2返回0,s1>s2返回1,而sort函数默认使用<比較,返回1代表满足,因此二者不是非常匹配,我最后採用了手动比較每一位的方法。

代码例如以下:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <map>
#include <vector>
#include <string>
#include <string.h>
#include <algorithm>

using namespace std;

int compare(const char *name1, const char *name2){

    for(int i = 0; i < 4; i++){
        if(name1[i] < name2[i]){
            return 1;
        }else if(name1[i] == name2[i]){
            continue;
        }else{
            return 0;
        }
    }

}

int main()
{
    int N,K,C,num;
    cin >> N >> K;
    vector<vector<char*> > course(K+1);
    for(int i = 0; i < N; i++){
        char* name = new char[4];
        scanf("%s%d",name,&C);
        for(int j = 0; j < C; j++){
           scanf("%d",&num);
           course[num].push_back(name);
        }
    }
    for(int j = 1; j <= K; j++){
        sort(course[j].begin(),course[j].end(),compare);
        printf("%d %d\n",j,course[j].size());
        for(int k = 0; k < course[j].size(); k++){
            printf("%s\n",course[j][k]);
        }
    }
    return 0;
}
时间: 2024-09-30 16:36:11

1047. Student List for Course (25)的相关文章

PAT 1047. Student List for Course (25)

1047. Student List for Course (25) Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses. Input Specification: Each

1047 Student List for Course (25 分)

1047 Student List for Course (25 分) Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses. Input Specification: E

PAT Advanced 1047 Student List for Course (25分)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses. Input Specification: Each input file contains one test cas

PAT:1047. Student List for Course (25) AC

#include<stdio.h> #include<string.h> #include<vector> #include<algorithm> using namespace std; const int MAX=40010; int n,k; //n个人,k门课 char name[MAX][5]; //存n个人的名字 vector<int> course[MAX]; //记录每个课程选的学生 bool cmp(int a,int b) {

【PAT甲级】1047 Student List for Course (25 分)

题意: 输入两个正整数N和K(N<=40000,K<=2500),接下来输入N行,每行包括一个学生的名字和所选课程的门数,接着输入每门所选课程的序号.输出每门课程有多少学生选择并按字典序输出学生的名字. 代码: #define HAVE_STRUCT_TIMESPEC#include<bits/stdc++.h>using namespace std;string s[40007];vector<string>v[2507];int main(){ ios::sync_

A1047. Student List for Course (25)

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses. Input Specification: Each input file contains one test case.

1047 Student List for Course

1039 Course List for Student 依靠unordered_map<string,set<int>> ans 解决问题. 这次依靠unordered_map<int ,vector<string>> ans;如果vector改成set(自带自排序+去重)最后一个测试点会超时导致无法通过. 所以每次输出结果之前,都要对vector重新排序一次. STL:unordered_map,vector,sort,string. #include&

C++ STL vector A1047 Student List for Course(25) (注意字符串型的存储方式:用char [N][5]来存储)

没有想到以二维数组 char [N][5] 存放输入的姓名,自己尝试用vector<char> 失败了. 小技巧:如果排序时直接对字符串排序,那么会导致大量的字符串移动,非常耗时间,因此比较合适的做法是使用字符串的下标来代替字符串本身进行排序,这样消耗的时间会少得多 strcmp 的返回值不一定是 -1 , 0 , +1 ,也有可能是其他正数和负数.因此在写cmp函数时不能写strcmp的返回值等于-1 , 必须写 < 0 #include <bits/stdc++.h> #

PAT1047: Student List for Course

1047. Student List for Course (25) 时间限制 400 ms 内存限制 64000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output