POJ1862 Stripies 【贪心】

Stripies

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 12522   Accepted: 5929

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent
amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish
that the weight of the new stripie isn‘t equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our
chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies.

You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

Source

Northeastern Europe 2001, Northern Subregion

贪心方法是把大数尽量多开方几次,所以每次选择最大的两个数拿出来开方。因为开方对于大数变小的幅度更大,所以对它多开方,-_-|||应该大概是这个道理吧...

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>

#define maxn 102

double arr[maxn], ans;

double cal(double a, double b) {
    return 2.0 * sqrt(a * b);
}

int main() {
    int i, j, n;
    scanf("%d", &n);
    for(i = 0; i < n; ++i)
        scanf("%lf", &arr[i]);
    std::sort(arr, arr + n);
    ans = arr[--n];
    while(n) ans = cal(ans, arr[--n]);
    printf("%.3f\n", ans);
    return 0;
}
时间: 2024-08-06 16:28:12

POJ1862 Stripies 【贪心】的相关文章

poj1862(Stripies)贪心

Description Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The str

POJ 1862 Stripies 贪心+优先队列

http://poj.org/problem?id=1862 题目大意: 有一种生物能两两合并,合并之前的重量分别为m1和m2,合并之后变为2*sqrt(m1*m2),现在给定n个这样的生物,求合并成一个的最小重量 思路: m1+m2 >=  2*sqrt(m1*m2) 所以每次取大的去合并,能变小. 直接优先队列就可以啦. #include<cstdio> #include<cmath> #include<queue> using namespace std;

poj1862 Stripies

思路: 简单贪心. 实现: 1 #include <iostream> 2 #include <cstdio> 3 #include <algorithm> 4 #include <cmath> 5 using namespace std; 6 7 int a[105], n; 8 9 bool cmp(const int & a, const int & b) 10 { 11 return a > b; 12 } 13 14 int

POJ 1862 Stripies#贪心(水)

(- ̄▽ ̄)-* #include<iostream> #include<cstdio> #include<cmath> #include<algorithm> using namespace std; int main() { int n; double w[105]; while(~scanf("%d",&n)) { for(int i=0;i<n;i++) { int m; scanf("%d",&

POJ 1862 &amp; ZOJ 1543 Stripies(贪心 | 优先队列)

题目链接: PKU:http://poj.org/problem?id=1862 ZJU:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=543 Description Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian -

POJ 1862 Stripies【哈夫曼/贪心/优先队列】

Stripies Time Limit: 1000MS   Memory Limit: 30000K Total Submissions: 18198   Accepted: 8175 Description Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, bu

9 POJ 1862 Stripies 简单贪心

观察发现m1+m2变为2*sqrt(m1*m2)质量是能够减少的, 因此按质量从大到小排序,每次取最大质量的两个合并,减少的质量是最多的. 合并n-1次,最终得到的一个数就是结果. 这里用优先队列写的比较方便. #include<cstdio> #include<queue> #include<cmath> using namespace std; priority_queue<double> q; int main() { int n,i; double

zoj 1543 贪心

Stripies Time Limit: 2 Seconds      Memory Limit: 65536 KB Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name

【uva 1615】Highway(算法效率--贪心 区间选点问题)

题意:给定平面上N个点和一个值D,要求在x轴上选出尽量少的点,使得对于给定的每个店,都有一个选出的点离它的欧几里德距离不超过D. 解法:先把问题转换成模型,把对平面的点满足条件的点在x轴的直线上可得到一个个区间,这样就是选最小的点覆盖所有的区间的问题了.我之前的一篇博文有较详细的解释:关于贪心算法的经典问题(算法效率 or 动态规划).代码实现我先空着.挖坑~