poj-2420 A Star not a Tree?(模拟退火算法)

题目链接:

A Star not a Tree?

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5219   Accepted: 2491

Description

Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you to connect any number of computers together in a linear arrangement. Luke is particulary proud that he solved a nasty NP-complete problem in order to minimize the total cable length. 
Unfortunately, Luke cannot use his existing cabling. The 100mbs system uses 100baseT (twisted pair) cables. Each 100baseT cable connects only two devices: either two network cards or a network card and a hub. (A hub is an electronic device that interconnects several cables.) Luke has a choice: He can buy 2N-2 network cards and connect his N computers together by inserting one or more cards into each computer and connecting them all together. Or he can buy N network cards and a hub and connect each of his N computers to the hub. The first approach would require that Luke configure his operating system to forward network traffic. However, with the installation of Winux 2007.2, Luke discovered that network forwarding no longer worked. He couldn‘t figure out how to re-enable forwarding, and he had never heard of Prim or Kruskal, so he settled on the second approach: N network cards and a hub.

Luke lives in a loft and so is prepared to run the cables and place the hub anywhere. But he won‘t move his computers. He wants to minimize the total length of cable he must buy.

Input

The first line of input contains a positive integer N <= 100, the number of computers. N lines follow; each gives the (x,y) coordinates (in mm.) of a computer within the room. All coordinates are integers between 0 and 10,000.

Output

Output consists of one number, the total length of the cable segments, rounded to the nearest mm.

Sample Input

4
0 0
0 10000
10000 10000
10000 0

Sample Output

28284题目:求一个多边形的费马点到所有点的距离和,费马点是多边形内到顶点距离和最短的点;思路:更poj1379一个人思路,用模拟退火算法找费马点求距离;AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <ctime>
#include <algorithm>
using namespace std;
const int num=100;
const int cnt=20;
const double PI=acos(-1.0);
const double inf=1e12;
struct node
{
    double px,py,dis;
};
node ans[100];
int n;
double x[105],y[105];
double get_dis(double a,double b,double c,double d)
{
    return sqrt((c-a)*(c-a)+(d-b)*(d-b));
}
void Iint()
{
    for(int i=0;i<num;i++)
    {
        ans[i].px=1.0*(rand()%32767)/32767*10000;
        ans[i].py=1.0*(rand()%32767)/32767*10000;
        ans[i].dis=0;
        for(int j=0;j<n;j++)
        {
            ans[i].dis+=get_dis(ans[i].px,ans[i].py,x[j],y[j]);
        }
    }
}
int main()
{
    srand((unsigned)time(NULL));
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%lf%lf",&x[i],&y[i]);
    }
    Iint();
    double temp=get_dis(0,0,10000,10000);
    while(temp>0.2)
    {
        for(int i=0;i<num;i++)
        {
            double fx,fy;
            for(int j=0;j<cnt;j++)
            {
                double cur=2.0*PI*(rand()%32767)/32767;
                fx=ans[i].px+cos(cur)*temp;
                fy=ans[i].py+sin(cur)*temp;
                if(fx<0||fx>10000||fy<0||fy>10000)continue;
                double dist=0;
                for(int k=0;k<n;k++)
                {
                    dist+=get_dis(fx,fy,x[k],y[k]);
                }
                if(dist<ans[i].dis)
                {
                    ans[i].px=fx;
                    ans[i].py=fy;
                    ans[i].dis=dist;
                }
            }
        }
       temp*=0.8;
    }
    double ans_dis=inf;
    int ans_x,ans_y;
    for(int i=0;i<num;i++)
    {
        if(ans[i].dis<ans_dis)
        {
            ans_dis=ans[i].dis;
        }
    }
    printf("%.0lf\n",ans_dis);
    return 0;
}
时间: 2024-10-26 22:15:30

poj-2420 A Star not a Tree?(模拟退火算法)的相关文章

POJ 2420 A Star not a Tree? (模拟退火)

题目地址:POJ 2420 今天在比赛遇到了这题..于是现场学了一下模拟退火.... 这题是先初始化为一个点,然后不断趋近距离和最短的点.还是挺简单的.. 代码如下: #include <iostream> #include <cstdio> #include <string> #include <cstring> #include <stdlib.h> #include <math.h> #include <ctype.h&g

POJ 2420 A Star not a Tree? 爬山算法

B - A Star not a Tree? Time Limit: 20 Sec Memory Limit: 256 MB 题目连接 http://acm.hust.edu.cn/vjudge/contest/view.action?cid=88808#problem/B Description Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10ba

poj 2420 A Star not a Tree?——模拟退火

题目:http://poj.org/problem?id=2420 精度设成1e-17,做三遍.ans设成double,最后再取整. #include<iostream> #include<cstdio> #include<cstring> #include<algorithm> #include<cmath> #include<cstdlib> #include<ctime> #define db double usin

三分 POJ 2420 A Star not a Tree?

题目传送门 1 /* 2 题意:求费马点 3 三分:对x轴和y轴求极值,使到每个点的距离和最小 4 */ 5 #include <cstdio> 6 #include <algorithm> 7 #include <cstring> 8 #include <cmath> 9 10 const int MAXN = 1e2 + 10; 11 const int INF = 0x3f3f3f3f; 12 double x[MAXN], y[MAXN]; 13 i

[POJ 2420] A Star not a Tree?

A Star not a Tree? Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 4058   Accepted: 2005 Description Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you

POJ 2420 A Star not a Tree? (计算几何-费马点)

A Star not a Tree? Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 3435   Accepted: 1724 Description Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you

POJ 2420 A Star not a Tree?【爬山法】

题目大意:在二维平面上找出一个点,使它到所有给定点的距离和最小,距离定义为欧氏距离,求这个最小的距离和是多少(结果需要四舍五入)? 思路:如果不能加点,问所有点距离和的最小值那就是经典的MST,如果只可以加一个点问最小值就是广义的费马点的问题,如果加点的数目不加限制,那问题就成了斯坦纳树的问题(介个属于NPC问题) 这题显然就是广义费马点问题,可以采用局部贪心法,从一个初始点出发,不断向上下左右四个方向拓展,如果在一个方向上走过去到所有点的距离和小于目前这个点到所有点的距离和,那就更新目前点的值

UVA 10228 - Star not a Tree?(模拟退火)

UVA 10228 - Star not a Tree? 题目链接 题意:给定一些点,费马点(到这些点距离和最短),输出距离和 思路:模拟退火去搞,初始温度1W步,降温系数设为0.83,然后每次找周围4个方向,做10次保证答案准确 代码: #include <cstdio> #include <cstring> #include <cmath> #include <ctime> #include <cstdlib> #include <al

poj2420A Star not a Tree?(模拟退火)

链接 求某一点到其它点距离和最小,求这个和,这个点 为费马点. 做法:模拟退火 1 #include <iostream> 2 #include<cstdio> 3 #include<cstring> 4 #include<algorithm> 5 #include<stdlib.h> 6 #include<vector> 7 #include<cmath> 8 #include<queue> 9 #inclu