A Knight's Journey (DFS)

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<set>
#include<vector>
#include<stack>
#include<queue>
#include<algorithm>
#include<cstdio>
#include<algorithm>
#include<functional>
#include<sstream>
int n1, n2;
int xx[30], yy[30];
int visit[30][30];
int flag;
int dir[8][2] = { { -2,-1 },{ -2,1 },{ -1,-2 },{ -1,2 },{ 1,-2 },{ 1,2 },{ 2,-1 },{ 2,1 } };
int go(int x, int y)
{
    if (1 <= x&&x <= n1 && 1 <= y&&y <= n2)
        return 1;
    return 0;
}
void dfs(int x, int y, int num)
{
    int i, xxx, yyy;
    xx[num] = x;
    yy[num] = y;
    if (num == n1*n2)
    {
        flag = 1;
        return;
    }
    for (i = 0; i<8; i++)
    {
        xxx = x + dir[i][0];
        yyy = y + dir[i][1];
        if (go(xxx, yyy) && !visit[xxx][yyy] && !flag)
        {
            visit[xxx][yyy] = 1;
            dfs(xxx, yyy, num + 1);
            visit[xxx][yyy] = 0;
        }
    }
}
int main()
{
    int i, k, t;
    scanf("%d", &t);
    for (k = 1; k <= t; k++)
    {
        scanf("%d%d", &n2, &n1);
        memset(visit, 0, sizeof(visit));
        visit[1][1] = 1;
        flag = 0;
        dfs(1, 1, 1);
        printf("Scenario #%d:\n", k);
        if (flag)
        {
            for (i = 1; i <= n1*n2; i++)
                printf("%c%d", xx[i] + ‘A‘ - 1, yy[i]);
        }
        else
            printf("impossible");
        printf(k == t ? "\n" : "\n\n");
    }
    return 0;
}

A Knight's Journey (DFS)

时间: 2024-09-30 23:58:44

A Knight's Journey (DFS)的相关文章

poj A Knight&#39;s Journey(DFS)

题目链接:http://acm.hrbust.edu.cn/vj/index.php?c=problem-problem&id=190592 题意:给出p*q的棋盘,从(A,1)开始,走“日”字,问能否走完棋盘上所有的点,如果能,按字典序输出路径: 思路:DFS,并保存路径即可,注意处理走的方向顺序int dir[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}}; #include <stdio.h> #in

POJ 2488-A Knight&#39;s Journey(DFS)

A Knight's Journey Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 31702   Accepted: 10813 Description Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey ar

poj 2488 A Knight&#39;s Journey (DFS)

A Knight's Journey Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 34660   Accepted: 11827 Description Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey ar

POJ 2488-A Knight&amp;#39;s Journey(DFS)

A Knight's Journey Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 31702   Accepted: 10813 Description Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey ar

POJ2488-A Knight&#39;s Journey(DFS+回溯)

题目链接:http://poj.org/problem?id=2488 A Knight's Journey Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 36695   Accepted: 12462 Description Background The knight is getting bored of seeing the same black and white squares again and again

poj 2488 A Knight&#39;s Journey(dfs+字典序路径输出)

转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents 题目链接:http://poj.org/problem?id=2488 ---------------------------------------------------------------------------------------------------------------------------------------------------------- 欢

pku 2488 A Knight&#39;s Journey (搜索 DFS)

A Knight's Journey Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 28697   Accepted: 9822 Description Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey aro

poj-2488 a knight&#39;s journey(搜索题)

Time limit1000 ms Memory limit65536 kB Background The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey around the world. Whenever a knight moves, it is two squares in one direction a

论深度优先(DFS)和广度优先搜索(BF)的优点及不足(更新ing)

例题: POJ 1915 Knight Moves 骑士遍历问题(跳马问题) 在一个m*m的棋盘上,从任意一个给定的位置(sx , sy)出发,为象棋中的马找一条路通过最少的步数到达另一位置(ex ,ey),输出最少所需要的步数. 利用bfs求解. 当马在位置(x , y)的时候其后继节点(后继选择)是什么? 对于马,有八个方向可以选择,马可以跳到如下几个位置: (x+2 , y+1) , (x+1 , y+2 ) , (x-1 , y+2) , (x-2 , y+1), (x+2 , y -1