poj 2886 Who Gets the Most Candies?(线段树+约瑟夫环+反素数)

Who Gets the Most Candies?

Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 9934   Accepted: 3050
Case Time Limit: 2000MS

Description

N children are sitting in a circle to play a game.

The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the
circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (?A)-th
child to the right.

The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p.
Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 500,000) and K (1 ≤ K ≤ N) on the first line. The next N lines contains the names of the children
(consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing
spaces.

Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

Sample Input

4 2
Tom 2
Jack 4
Mary -1
Sam 1

Sample Output

Sam 3

题解及代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <set>
#include <map>
#include <queue>
#include <string>
#define maxn 500010
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define ALL %I64d
using namespace std;
typedef long long  ll;
int pos,ans;      //pos记录每次跳出的人的所处的叶子节点的位置,ans为最后输出最大的F(k)的值

const int antiprime[] = {1,2,4,6,12,24,36,48,60,120,180,240,360,720,840,1260,1680,2520,5040,7560,10080,15120,20160,25200,27720,45360,50400,55440,83160,110880,166320, 221760, 277200, 332640, 498960, 554400, 665280};
const int factorNum[] = {1, 2, 3, 4, 6, 8, 9, 10, 12, 16, 18, 20, 24, 30, 32, 36, 40, 48, 60, 64, 72, 80, 84, 90, 96, 100, 108, 120, 128, 144, 160, 168, 180, 192, 200, 216, 224};

int find_max(int n,int &x)   //寻找1--n中最大的F(k)值,并返回k
{
    int i=0;
    while(i<35)
    {
        if(antiprime[i]>n)
            break;
        i++;
    }
    x=factorNum[i-1];
    return antiprime[i-1];
}

struct segment     //定义线段树的节点
{
    int l,r;
    int value;
    char s[12];    //叶子节点中信息,非叶子节点无用
    int dir;       //读者也可以去掉这里,自行优化空间
} son[maxn*3];

void PushUp(int rt)
{
    son[rt].value=son[rt<<1].value+son[rt<<1|1].value;
}

void Build(int l,int r,int rt)
{
    son[rt].l=l;
    son[rt].r=r;
    if(l==r)
    {
        scanf("%s%d",son[rt].s,&son[rt].dir);
        son[rt].value=1;
        return;
    }
    int m=(l+r)/2;
    Build(lson);
    Build(rson);
    PushUp(rt);
}

void Update(int w,int rt)      //查找跳出的人的叶子节点
{
    if(son[rt].l==son[rt].r)
    {
        son[rt].value=0;       //标记为跳出
        pos=rt;                //记录叶子节点的位置,下一次计算查找的位置要用到son[rt].dir
        return;
    }

    int m=(son[rt].l+son[rt].r)/2;

    if(son[rt<<1].value>w)
        Update(w,rt<<1);
    else
    {
        w-=son[rt<<1].value;
        Update(w,rt<<1|1);
    }
    PushUp(rt);
}

int main()
{
    int n,fpos;
    while(scanf("%d%d",&n,&fpos)!=EOF)
    {
        Build(1,n,1);

        fpos--;
        int m=find_max(n,ans);

        //printf("%d %d\n",m,ans);
        for(int i=1;i<=m;i++)
        {
            Update(fpos,1);
            //printf("%s\n",son[pos].s);
            if(n!=i)
            {
                if(son[pos].dir>0)                                      //这里分成向左跳和向右跳两种情况,开始总是出错
                fpos=((fpos+son[pos].dir-1)%(n-i)+(n-i))%(n-i);         //后来仔细想了一下,当我们向右跳的时候,去除改点
                else fpos=((fpos+son[pos].dir)%(n-i)+(n-i))%(n-i);      //之后没一点都相当于向前移动一个位置
            }                                                           //而向前跳,改点删除之后,后面的点向前移动,而前面的点不用
        }                                                                //读者可以自己模拟一下跳出后每个点的下标就好了
        printf("%s %d\n",son[pos].s,ans);
    }
    return 0;
}
/*
这道题的意思就是一个约瑟夫环的变形问题,当我们跳到某个点的时候根据当前值向左或者向右跳。
然后记录第i个跳出的人的糖果数为F(i),然后在求出F(i)的最大值和对应的人是谁。

这里我们可以预先处理出F(1)--F(n)的最大值为F(k),然后再找到第k个跳出来的人是谁就可以了。
这里F(i)的定义是i的因子的数目,求1--n中因子数最多的数k就是就小于n最大的反素数是谁。
那么我们就可以是用模版预先处理出反素数的序列,以及他们对应的因子数的个数。

然后对于n,找出最大的反素数k,那么这个k代表我们要求出第k个跳出来的人思谁。

这里我们使用能够线段树来维护某段区间中,未跳出的人的数目,然后每次查找到跳出的人是谁,
标记为跳出,维护区间人数,计算下一个跳出的人的位置,循环直到找到第k个人。

*转载请注明出处,谢谢。
*/

poj 2886 Who Gets the Most Candies?(线段树+约瑟夫环+反素数),布布扣,bubuko.com

时间: 2024-10-18 15:12:57

poj 2886 Who Gets the Most Candies?(线段树+约瑟夫环+反素数)的相关文章

POJ 2886 Who Gets the Most Candies?(线段树&#183;约瑟夫环)

题意  n个人顺时针围成一圈玩约瑟夫游戏  每个人手上有一个数val[i]   开始第k个人出队  若val[k] < 0 下一个出队的为在剩余的人中向右数 -val[k]个人   val[k] > 0 时向左数val[k]个  第m出队的人可以得到m的约数个数个糖果  问得到最多糖果的人是谁 约瑟夫环问题  n比较大 直接模拟会超时   通过线段树可以让每次出队在O(logN)时间内完成  类似上一道插队的题  线段树维护对应区间还有多少个人没出队  那么当我们知道出队的人在剩余人中排第几个

poj 2886 Who Gets the Most Candies? 线段树动态求第k大的数

题意: n个小孩站一圈,每个小孩拿一个数字,从第k个孩子开始出局,然后下一个出局的孩子是刚刚出局的孩子之前或之后第v个(刚刚出局的孩子的数字是+v则之后v个,-v则之前v个),这样所有孩子终将出局,第p个出局的孩子得f(p)分,f(p)定义为p的因子个数.求分数最高的孩子. 分析: 设顺时针为正方向,关键是模拟出每次出局的孩子是剩下的孩子中的正方向的第几个,设当前要出局的是第k个,然后要求出第k个小孩的下标(pos)以便下一次计算下一个出局的孩子是第几个,这些步骤可用线段树维护. 代码: //p

[poj 2886] Who Gets the Most Candies? 线段树

Description N children are sitting in a circle to play a game. The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the oth

poj 2886 线段树的更新+反素数

Who Gets the Most Candies? Time Limit: 5000 MS Memory Limit: 0 KB 64-bit integer IO format: %I64d , %I64u Java class name: Main [Submit] [Status] [Discuss] Description N children are sitting in a circle to play a game. The children are numbered from

POJ 2886 Who Gets the Most Candies(线段树+约瑟夫环)

题目链接:POJ 2886 Who Gets the Most Candies [题目]N个孩子顺时针坐成一个圆圈,从1~N编号,每个孩子手中有一张标有非零整数的卡片.第K个孩子先出圈,如果他手中卡片上的数字A>0,下一个出圈的是他左手边第A个孩子.A<0,下一个出圈的是他右手边第(-A)个孩子.第p个出圈的孩子会得到F(p)个糖果,F(p)为p的因子数.输出得到糖果数最多的孩子的名字及糖果数目. [思路]孩子数目很大(1~500000),于是想到要用线段树来优化,然后就是模拟出圈过程.并更新

poj 2886 Who Gets the Most Candies? (树状数组+二分+反素数)

Who Gets the Most Candies? Time Limit: 5000MS   Memory Limit: 131072K Total Submissions: 11597   Accepted: 3616 Case Time Limit: 2000MS Description N children are sitting in a circle to play a game. The children are numbered from 1 to N in clockwise

POJ 2886 Who Gets the Most Candies? 反素数+线段树

题意:变形的约瑟夫环模型,每个人有一个数字a,从第K个人开始出列,如果数字是正的,就往后数a个人出列,如果书负数,就往反方向数. 然后用最基本的线段树处理约瑟夫环的方法即可 但是题目要求的是第x个出列的人的名字,x为1-N中约数最多的数中的最小的那个.这里需要求反素数,即不大于N约数最多的. 写起来比较多,容易写错,一开始连素数打表都写作了QAQ #include <cstdio> #include <iostream> #include <cstring> #incl

POJ 2886 Who Gets the Most Candies?(线段树模拟约瑟夫环,高合成数)

POJ 2886 Who Gets the Most Candies?(线段树模拟约瑟夫环,高合成数) ACM 题目地址:POJ 2886 Who Gets the Most Candies? 题意: N 个小孩围成一圈,他们被顺时针编号为 1 到 N.每个小孩手中有一个卡片,上面有一个非 0 的数字,游戏从第 K 个小孩开始,他告诉其他小孩他卡片上的数字并离开这个圈,他卡片上的数字 A 表明了下一个离开的小孩,如果 A 是大于 0 的,则下个离开的是左手边第 A 个,如果是小于 0 的, 则是

POJ - 2886 Who Gets the Most Candies? (反素数+线段树)

Description N children are sitting in a circle to play a game. The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the oth