Agri-Net
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 37109 | Accepted: 14982 |
Description
Farmer John has been elected mayor of his town!
One of his campaign promises was to bring internet connectivity to all farms in
the area. He needs your help, of course.
Farmer John ordered a high speed
connection for his farm and is going to share his connectivity with the other
farmers. To minimize cost, he wants to lay the minimum amount of optical fiber
to connect his farm to all the other farms.
Given a list of how much fiber
it takes to connect each pair of farms, you must find the minimum amount of
fiber needed to connect them all together. Each farm must connect to some other
farm such that a packet can flow from any one farm to any other farm.
The
distance between any two farms will not exceed 100,000.
Input
The input includes several cases. For each case,
the first line contains the number of farms, N (3 <= N <= 100). The
following lines contain the N x N conectivity matrix, where each element shows
the distance from on farm to another. Logically, they are N lines of N
space-separated integers. Physically, they are limited in length to 80
characters, so some lines continue onto others. Of course, the diagonal will be
0, since the distance from farm i to itself is not interesting for this
problem.
Output
For each case, output a single integer length that
is the sum of the minimum length of fiber required to connect the entire set of
farms.
Sample Input
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
Sample Output
28
【题目来源】
【题目大意】
给定一个强连通图,让你求最小生成树的权值之和。
【题目分析】
数据很水,用Kruskal或者prim都能水过。
#include<cstdio>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
#define MAX 600*300
using namespace std;
struct Node
{
int a,b,c;
};
Node node[MAX];
int parent[MAX];
int num[600][600];
int sum;
int temp;int Find(int x)
{
return x==parent[x]?x:parent[x]=Find(parent[x]);
}void Kruskal()
{
int x,y;
int i,j;
for(i=0;i<temp;i++)
{
x=node[i].a;
y=node[i].b;
x=Find(x);
y=Find(y);
if(x!=y)
{
parent[x]=y;
sum+=node[i].c;
}
}
}bool cmp(Node a,Node b)
{
return a.c<b.c;
}int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
sum=0;
int i,j;
for(i=0;i<MAX;i++)
parent[i]=i;
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
{
scanf("%d",&num[i][j]);
}
}
temp=0;
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
{
node[++temp].a=i;
node[temp].b=j;
node[temp].c=num[i][j];
}
}
sort(node,node+temp,cmp);
Kruskal();
printf("%d\n",sum);
}
return 0;
}
最小生成树 --- 求最小权值、MST