POJ 题目3694 Network(tarjan,LCA,求桥)

Network

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 7179   Accepted: 2600

Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers.
The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can‘t be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate
all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers
N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).

Each of the following M lines contains two integers A and B ( 1≤
AB ≤ N), which indicates a link between computer A and
B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.

The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.

The i-th line of the following Q lines contains two integer
A
and B (1 ≤ ABN), which is the
i
-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and
Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first
i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2
0

Source

2008 Asia Hefei Regional Contest Online by USTC

给出一张图,Q个询问,每个询问都是在前面询问的基础上,每个询问连一条边,问现在还有几个桥。

ac代码

#include<iostream>
#include<math.h>
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<vector>
#include<queue>
#include<map>
#include<set>
using namespace std;
#define B(x) (1<<(x))
typedef long long ll;
void cmax(int& a,int b){ if(b>a)a=b; }
void cmin(int& a,int b){ if(b<a)a=b; }
const int oo=0x3f3f3f3f;
const int MOD=1000000007;
const int maxn=110000;
const int maxm=210000;
struct EDGE{
    int v,next,c,f;
}E[maxm<<1];
int head[maxn],tol;
int low[maxn],dfn[maxn];
int isbridge[maxn],fa[maxn];
int g_cnt,bcnt;

void Init(){
    memset(head,-1,sizeof head);
    tol=0;
    memset(low,0,sizeof low);
    memset(dfn,0,sizeof dfn);
    memset(isbridge,0,sizeof isbridge);
    g_cnt=bcnt=0;
}

void add_edge(int u,int v){
    E[tol].v=v;
    E[tol].next=head[u];
    head[u]=tol++;
}

void Tarjan(int u,int pre){
    dfn[u]=low[u]=++g_cnt;
    for(int i=head[u];i!=-1;i=E[i].next){
        int v=E[i].v;
        if(v==pre)continue;
        if(!dfn[v]){
            fa[v]=u;
            Tarjan(v,u);
            if(low[v]<low[u])
                low[u]=low[v];
            if(low[v]>dfn[u]){
                bcnt++;
                isbridge[v]=1;
            }
        }else if(dfn[v]<low[u])
            low[u]=dfn[v];
    }
}

void LCA(int u,int v){
    if(dfn[u]<dfn[v])swap(u,v);
    while(dfn[u]>dfn[v]){
        if(isbridge[u])bcnt--;
        isbridge[u]=0;
        u=fa[u];
    }
    while(u!=v){
        if(isbridge[u])bcnt--;
        if(isbridge[v])bcnt--;
        isbridge[u]=isbridge[v]=0;
        u=fa[u];
        v=fa[v];
    }
}

int main(){
    //freopen("E:\\read.txt","r",stdin);
    int n,m,u,v,Q;
    int cas=1;
    while(scanf("%d %d",&n,&m)!=EOF){
        if(n==0&&m==0)break;
        Init();
        for(int i=1;i<=m;i++){
            scanf("%d %d",&u,&v);
            add_edge(u,v);
            add_edge(v,u);
        }
        fa[1]=1;
        Tarjan(1,-1);
        scanf("%d",&Q);
        printf("Case %d:\n",cas++);
        while(Q--){
            scanf("%d %d",&u,&v);
            LCA(u,v);
            printf("%d\n",bcnt);
        }
        puts("");
    }
    return 0;
}

题目大意:

时间: 2024-10-30 04:46:07

POJ 题目3694 Network(tarjan,LCA,求桥)的相关文章

POJ 3694 Network (tarjan + LCA)

题目链接:http://poj.org/problem?id=3694 题意是给你一个无向图n个点,m条边,将m条边连接起来之后形成一个图,有Q个询问,问将u和v连接起来后图中还有多少个桥. 首先用tarjan标记点的low和dfn值,那么u和v相连的边是桥的条件是dfn[u] < low[v](说明v与u不在一个连通分量里面,v无法通过回溯到达u点,画个图模拟会清楚).那么bridge[v]++表示u与v相连的边是桥(若是标记bridge[u]++,则最后的答案可能会出错,亲测).要是u和v相

POJ 3694——Network——————【连通图,LCA求桥】

Network Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u Submit Status Practice POJ 3694 Description A network administrator manages a large network. The network consists of N computers and M links between pairs of compute

tarjan算法求桥双连通分量 POJ 3177 Redundant Paths

POJ 3177 Redundant Paths Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 12598   Accepted: 5330 Description In order to get from one of the F (1 <= F <= 5,000) grazing fields (which are numbered 1..F) to another field, Bessie and the re

Network POJ - 3694 (连通图标求桥)

#include <iostream> #include <cstdio> #include <cstring> #include <queue> #include <vector> #include <stack> #include <algorithm> #include <cmath> #define mem(a, b) memset(a, b, sizeof(a)) using namespace st

D - Network - poj3694(LCA求桥)

题意:有一个网络有一些边相互连接,现在有Q次操作,求每次操作后的桥的个数 分析:开始竟然不知道还有LCA这么个东西....... ***************************************************************** #include<stdio.h>#include<string.h>#include<algorithm>using namespace std; const int MAXN = 1e5+5; /******

[POJ3694]Network(LCA, 割边, 桥)

题目链接:http://poj.org/problem?id=3694 题意:给一张图,每次加一条边,问割边数量. tarjan先找出所有割边,并且记录每个点的父亲和来自于哪一条边,然后询问的时候从两个点向上找lca,沿途更新割边数量和割边状态即可. AC代码 1 /* 2 ━━━━━┒ギリギリ♂ eye! 3 ┓┏┓┏┓┃キリキリ♂ mind! 4 ┛┗┛┗┛┃\○/ 5 ┓┏┓┏┓┃ / 6 ┛┗┛┗┛┃ノ) 7 ┓┏┓┏┓┃ 8 ┛┗┛┗┛┃ 9 ┓┏┓┏┓┃ 10 ┛┗┛┗┛┃ 11 ┓

POJ 题目1236 Network of Schools(强联通)

Network of Schools Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 12015   Accepted: 4783 Description A number of schools are connected to a computer network. Agreements have been developed among those schools: each school maintains a li

POJ 3177 Redundant Paths (tarjan无向图求缩点)

#include <iostream> #include<cstring> #include<cmath> #include<algorithm> #include<vector> #include<cstdio> #include<stack> #include <map> #define lson(p) (p<<1) #define rson(p) (p<<1|1) #define

POJ 3164 Command Network 最小树形图-朱刘算法裸题

题目来源:POJ 3164 Command Network 题意:求以1为根的最小树形图 没有输出字符串 思路:直接高朱刘算法 不懂的可以百度 学会了就是直接套模板的事情 其实就是不断消圈而已 不构成圈就有解 无法从根到达其他点就无解 #include <cstdio> #include <cstring> #include <cmath> const int maxn = 110; const int maxm = 50010; const double INF =