Silver Cow Party---poj3268

Silver Cow Party

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow‘s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: AiBi, and Ti. The described road runs from farm Ai to farm Bi, requiring Titime units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

题意: 有n个农场,将在农场x举行party,农场a->b用时c;有向图;求所有农场中的牛去到农场x再回去所需的最长时间;可以两次运用Dij算法,用dist[i]表示起点到i

的最短时间

#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#define INF 0xfffffff
#define N 1100
using namespace std;
#define max(a,b) (a>b?a:b)
#define min(a,b) (a<b?a:b)
int x,n,m,dist1[N],dist2[N],vis[N];
int maps[N][N];

void Dij1()
{
    int i,j;

    vis[x]=0;

    dist1[x]=0;

    for(i=1; i <= n; i++)
    {
        int Min=INF,index=-1;

        for(j = 1; j <= n; j++)
        {
            if(vis[j] == 0 && Min > dist1[j])
            {
                Min = dist1[j];
                index = j;
            }
        }
        if(index==-1)break;
        vis[index]=1;

        for(j = 1; j <= n; j++)
            dist1[j] = min(dist1[j],dist1[index] + maps[index][j]);
    }
}
void Dij2()
{
    int i,j;

    vis[x]=0;

    dist2[x]=0;

    for(i=1; i <= n; i++)
    {
        int Min=INF,index=-1;

        for(j = 1; j <= n; j++)
        {
            if(vis[j] == 0 && Min > dist2[j])
            {
                Min = dist2[j];
                index = j;
            }
        }
        if(index==-1)break;
        vis[index]=1;

        for(j = 1; j <= n; j++)
            dist2[j] = min(dist2[j],dist2[index] + maps[j][index]);
    }
}

int main()
{
    int i,a,b,c;
    while(scanf("%d%d%d",&n,&m,&x)!=EOF)
    {
        for(i=0;i<=n;i++)
        {
            dist1[i]=dist2[i]=INF;
            for(int j=1;j<=n;j++)
                maps[i][j]=INF;
        }
        while(m--)
        {
            scanf("%d%d%d", &a, &b, &c);

            maps[a][b] = c;
        }

        memset(vis,0,sizeof(vis));
        Dij1();//去

        memset(vis,0,sizeof(vis));
        Dij2();//回来;

        int ans=0;

        for(i=1;i<=n;i++)
        {
            ans=max(ans,dist1[i]+dist2[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}

时间: 2024-10-08 18:18:52

Silver Cow Party---poj3268的相关文章

Silver Cow Party.(POJ-3268)

本来想用Floyd算法,可惜超时,毕竟复杂度太高,而且并没有必要求出任意两点间的最短距离. 求两点间的最短路有两种方法,dijkstra和Bellman ,前者不能有负圈,后者可以有负圈,另外,Floyd也可以求带负圈的最短距离. 我们只需要求出x到其他个点的最短距离和个点到它的最短距离就行了.当然,我所写的还求了很多多余的量,是可以优化的. #include<cstdio> #include<cstring> #include<iostream> #include&l

POJ3268 Silver Cow Party 【Dijkstra】

Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 13183   Accepted: 5932 Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X 

POJ3268 Silver Cow Party(dijkstra+矩阵转置)

Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 15156   Accepted: 6843 Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X

POJ3268 Silver Cow Party —— 最短路

题目链接:http://poj.org/problem?id=3268 Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 24527   Accepted: 11164 Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big co

POJ 3268 Silver Cow Party

Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 20274   Accepted: 9278 Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X 

POJ 3268 Silver Cow Party(SPFA)

Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i re

图论 ---- spfa + 链式向前星 ---- poj 3268 : Silver Cow Party

Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 12674   Accepted: 5651 Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X 

POJ 3268 Silver Cow Party 最短路—dijkstra算法的优化。

POJ 3268 Silver Cow Party Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects

poj 3268 Silver Cow Party(dijkstra||SPFA)(中等)

Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 14900   Accepted: 6746 Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X 

poj 3268 Silver Cow Party (最短路)

Silver Cow Party Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 12913   Accepted: 5778 Description One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X