HDU 1237:简单计算器【栈】

简单计算器

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6429    Accepted Submission(s): 2044

Problem Description

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

Input

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

Output

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

Sample Input

1 + 2 4 + 2 * 5 - 7 / 11 0

Sample Output

3.00 13.36

AC-code:

#include<stdio.h>
#include<stack>
#include<string>
#include<iostream>
using namespace std;
char perc(char a,char c);
double operate(double a,char c,double b);

int main()
{
	double a,b;
	string s;
	char c,theta;
	while(getline(cin,s),s!="0")
	{
		stack<char>fuhao;
		stack<double>zifu;
		int i=0;
		zifu.push(s[i]-48);
		c=s[++i];
		while(c!='\0')
		{
			if(c==' ')
			{
				c=s[++i];
				continue;
			}
			else if(c<='9'&&c>='0')
			{
				if(s[i-1]>='0'&&s[i-1]<='9')//判断是否是非个位数
				{
					a=zifu.top()*10+c-48;
					zifu.pop();
					zifu.push(a);
				}
				else
					zifu.push(c-48);
				c=s[++i];
			}
			else
			{
				if(!fuhao.empty())
				{
					switch(perc(fuhao.top(),c))
					{
						case '<': fuhao.push(c);c=s[++i];break;
						case '>':
							theta=fuhao.top();
							fuhao.pop();
							a=zifu.top();
							zifu.pop();
							b=zifu.top();
							zifu.pop();
							zifu.push(operate(b,theta,a));
							//c=s[++i];注意这里千万不能加上这一句~因为C还没有放进fuhao中
							break;
					}
				}
				else
				{
					fuhao.push(c);
					c=s[++i];
				}
			}
		}
		while(!fuhao.empty())//有可能剩余的有符号
		{
			theta=fuhao.top();
			fuhao.pop();
			a=zifu.top();
			zifu.pop();
			b=zifu.top();
			zifu.pop();
			zifu.push(operate(b,theta,a));
		}
		printf("%.2lf\n",zifu.top());
	}
	return 0;
}
char perc(char a,char c)//判断优先级
{
	if(a=='+'||a=='-')
		switch(c)
		{
			case '+':
			case '-': return '>';break;
			case '*':
			case '/': return '<';break;
		}
	else if(a=='*'||a=='/')
		return '>';
}

double operate(double a,char c,double b)//计算
{
	switch(c)
	{
		case '+': return (a+b);break;
		case '-': return (a-b);break;
		case '*': return a*b;break;
		case '/': return a/b;break;
	}
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

时间: 2024-11-08 20:19:07

HDU 1237:简单计算器【栈】的相关文章

HDU 1237 简单计算器(栈)

题目链接 Problem Description 读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值. Input 测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔.没有非法表达式.当一行中只有0时输入结束,相应的结果不要输出. Output 对每个测试用例输出1行,即该表达式的值,精确到小数点后2位. Sample Input 1 + 2 4 + 2 * 5 - 7 / 11 0 Sample Output 3.00

hdu 1237 简单计算器(栈处理)

简单计算器 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 26553    Accepted Submission(s): 9626 Problem Description 读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值. Input 测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整

HDU 1237 简单计算器(后缀式+栈)

简单计算器 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16351    Accepted Submission(s): 5604 Problem Description 读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值. Input 测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,

HDU 1237 简单计算器

简单计算器 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 12832    Accepted Submission(s): 4222 Problem Description 读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值. Input 测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整

Hdu 1237简单计算器

简单计算器 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 21184    Accepted Submission(s): 7599 Problem Description 读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值. Input 测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整

hdu 1237 简单计算器 逆波兰~~

简单计算器 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 13852    Accepted Submission(s): 4613 Problem Description 读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值. Input 测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,

HDU 1237 简单计算器 (栈 )

#include<cstdio> #include<cstring> #include<iostream> #include<algorithm> #include<stack> using namespace std; char str[300]; double ans; double chcd(char x) { return (x-'0')*1.0; } double ch(int l,int r) { //printf("%d

HDU 1237 简单计算器(stack)

Problem Description 读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值. Input 测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔.没有非法表达式.当一行中只有0时输入结束,相应的结果不要输出. Output 对每个测试用例输出1行,即该表达式的值,精确到小数点后2位. Sample Input 1 + 2 4 + 2 * 5 - 7 / 11 0 Sample Output 3.00 13.3

hdu-1237简单计算器(栈的运用)

http://acm.hdu.edu.cn/showproblem.php?pid=1237 简单的栈的运用. 首先将数字和运算符分离,分别保存在两个数组中,然后按原来的式子的顺序,首先将第一个数和第一个运算符分别压 如个自的栈,然后判取出两个栈头部的元素,判断符号,如果是乘除就用当前数值乘取出的数字(优先),然后将乘后的数压入栈, 如果是加则将数和取出的数按原序入栈,如果减,就把新的数变负,将数和取出的数按原序入栈. 最后栈中所有元素的和就是结果. 1 #include<stdio.h> 2

hdoj 1237 简单计算器

简单计算器 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 14512    Accepted Submission(s): 4920 Problem Description 读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值. Input 测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整