【POJ 3616】Milking Time

Milking Time

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6129   Accepted: 2571

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri <ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ‘s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

Source

USACO 2007 November Silver

简单的DP题。

首先要按结束时间排序。

然后我们开始建立状态转移方程。

f[i] 代表在结束时间为 i 的挤奶阶段挤奶的最大值。

那么很明显,方程就是:f[i] = max{f[j] | 0 <= j <= 结束时间对应的开始时间 - R} + 结束时间所对应的奶的数量,如果开始时间-R是小于0,直接取f[0](即0)。

纯DP时间复杂度就是O(NM),N是106,M是1000,会死人的。。。

那么,现在看看DP方程。我们只是要找1~开始时间-R范围内的最大值。那么很简单,线段树优化。

更新就更新i~i这个范围,不用我多说了吧。

#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

const int MAXN = 1000005;
const int MAXM = 1005;

struct Milk
{
    int s, e, p;

    bool operator < (const Milk &b) const
    {
        return (e < b.e) || (e == b.e && s < b.s);
    }

}milk[MAXM];

int maxv[MAXN << 2];
int f[MAXN];
int n, m, r, ans;
int _max, y1, y2;

void query(int o, int L, int R)
{
    if (y1 <= L && R <= y2)
    {
        _max = max(_max, maxv[o]);
        return;
    }
    int mid = (L + R) >> 1;
    int lc = o << 1, rc = lc + 1;
    if (mid >= y1) query(lc, L, mid);
    if (mid + 1 <= y2) query(rc, mid + 1, R);
}

void update(int o, int L, int R, int v, int delx)
{
    if (L == R)
    {
        maxv[o] = max(maxv[o], delx);
        return;
    }
    int mid = (L + R) >> 1;
    int lc = o << 1, rc = lc + 1;
    if (mid >= v) update(lc, L, mid, v, delx);
    if (mid + 1 <= v) update(rc, mid + 1, R, v, delx);
    maxv[o] = max(maxv[lc], maxv[rc]);
}

int main()
{
    scanf("%d%d%d", &n, &m, &r);
    for (int i = 0; i < m; ++i) scanf("%d%d%d", &milk[i].s, &milk[i].e, &milk[i].p);
    sort(milk, milk + m);
    memset(maxv, 0, sizeof(maxv));
    memset(f, 0, sizeof(f));
    for (int i = 0; i < m; ++i)
    {
        _max = 0;
        if (milk[i].s - r > 0)
        {
            y1 = 1;
            y2 = milk[i].s - r;
            query(1, 1, n - 1);
        }
        f[milk[i].e] = max(f[milk[i].e], _max + milk[i].p);
        update(1, 1, n - 1, milk[i].e, f[milk[i].e]);
    }
    ans = 0;
    for (int i = 1; i < MAXN; ++i) ans = max(ans, f[i]);
    printf("%d\n", ans);
    return 0;
}
时间: 2024-11-05 04:49:33

【POJ 3616】Milking Time的相关文章

【POJ 1408】 Fishnet (叉积求面积)

[POJ 1408] Fishnet (叉积求面积) 一个1*1㎡的池塘 有2*n条线代表渔网 问这些网中围出来的最大面积 一个有效面积是相邻两行和相邻两列中间夹的四边形 Input为n 后面跟着四行 每行n个浮点数 每一行分别代表a,b,c,d 如图 并且保证a(i) > a(i-1) b(i) > b(i-1) c(i) > c(i-1) d(i) > d(i-1) n(n <= 30)*2+4(四个岸)条边 枚举点数就行 相邻的四个四个点枚举 找出围出的最大面积 找点用

【POJ 2513】Colored Sticks

[POJ 2513]Colored Sticks 并查集+字典树+欧拉通路 第一次做这么混的题..太混了-- 不过题不算难 字典树用来查字符串对应图中的点 每个单词做一个点(包括重复单词 题意就是每个边走且直走一次(欧拉通路 欧拉图的判定: 没有或者只有两个奇数度的点的图叫做欧拉图 有这些就可以解答此题了 另外需要注意题目范围是25W个木棍 所以最多可能有50W个点 卡了好多个RE 代码如下: #include <iostream> #include <cstdlib> #incl

2292: 【POJ Challenge 】永远挑战

2292: [POJ Challenge ]永远挑战 Time Limit: 10 Sec  Memory Limit: 128 MBSubmit: 553  Solved: 230[Submit][Status][Discuss] Description lqp18_31和1tthinking经常出题来虐ftiasch.有一天, lqp18_31搞了一个有向图,每条边的长度都是1. 他想让ftiasch求出点1到点 N 的最短路."水题啊.", ftiasch这么说道. 所以1tth

【POJ 1201】 Intervals(差分约束系统)

[POJ 1201] Intervals(差分约束系统) 11 1716的升级版 把原本固定的边权改为不固定. Intervals Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 23817   Accepted: 9023 Description You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. Write a p

【POJ 1228】Grandpa&#39;s Estate 凸包

找到凸包后暴力枚举边进行$check$,注意凸包是一条线(或者说两条线)的情况要输出$NO$ #include<cmath> #include<cstdio> #include<cstring> #include<algorithm> #define N 1003 #define read(x) x = getint() using namespace std; inline int getint() { int k = 0, fh = 1; char c

【POJ 2750】 Potted Flower(线段树套dp)

[POJ 2750] Potted Flower(线段树套dp) Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 4566   Accepted: 1739 Description The little cat takes over the management of a new park. There is a large circular statue in the center of the park, surrou

【POJ 2480】Longge&#39;s problem(欧拉函数)

题意 求$ \sum_{i=1}^n gcd(i,n) $ 给定 $n(1\le n\le 2^{32}) $. 链接 分析 用欧拉函数$φ(x)$求1到x-1有几个和x互质的数. gcd(i,n)必定是n的一个约数.若p是n的约数,那么gcd(i,n)==p的有$φ(n/p)$个数,因为要使gcd(i,n)==p,i/p和n/p必须是互质的.那么就是求i/p和n/p互质的i在[1,n]里有几个,就等价于,1/p,2/p,...,n/p里面有几个和n/p互质,即φ(n/p). 求和的话,约数为p

【POJ 3321】 Apple Tree (dfs重标号设区间+树状数组求和)

[POJ 3321] Apple Tree (dfs重标号设区间+树状数组求和) Apple Tree Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 21966   Accepted: 6654 Description There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. K

【POJ 1260】Pearls

[POJ 1260]Pearls dp问题 最近做背包做多了 一做动规就往背包想-- 这题其实也有点背包的意思(然而只是做背包做的看啥都像背包-- c件物品 有各自的数量a 和价值p 每进行一次交易的花费cost = (物品数+10)*价格 低价物品可以用高价一起购买 一次交易只能按照一种价值购买 初始dp[0] = 0 dp数组下标为物品件数 枚举物品种类 没枚举一种物品 遍历该物品之前物品量 假设之前有num件物品 当前枚举到的物品价值p 那么就要找到min(dp[k(0~num)] + (