hdu2054 A == B ? (大数)

A == B ?

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 91202    Accepted Submission(s): 14548

Problem Description

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".

Input

each test case contains two numbers A and B.

Output

for each case, if A is equal to B, you should print "YES", or print "NO".

Sample Input

1 2
2 2
3 3
4 3

Sample Output

NO
YES
YES
NO

Author

8600 && xhd

Source

校庆杯Warm Up

Recommend

linle   |   We have carefully selected several similar problems for you:  2072 2052 2055 2053 2057

Statistic | Submit | Discuss | Note

java大数真是开挂般的存在啊

如果用c做的话  不要忘记00005=5,0.5000=0.5

import java.math.BigDecimal;
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner sca=new Scanner(System.in);
        while(sca.hasNext()){
            BigDecimal a=sca.nextBigDecimal();
            BigDecimal b=sca.nextBigDecimal();
            String num1=a.stripTrailingZeros().toString();
            String num2=b.stripTrailingZeros().toString();
            if(num1.equals(num2)){
                System.out.println("YES");
            }
            else{
                System.out.println("NO");
            }
        }
        sca.close();
    }
}
时间: 2024-10-10 16:46:39

hdu2054 A == B ? (大数)的相关文章

HNNU 11654 大还是小?【 湖南省第十一届大学生计算机程序设计竞赛,Java大数比较】

原题链接:http://acm.hunnu.edu.cn/online/?action=problem&type=show&id=11654&courseid=0 大数比较,果断用Java,但也要注意细节. 注意:比较的时候不能用 equals,如果用的话0.0和0.00是不相等的,有点像HDU2054,那题有详细解释 http://blog.csdn.net/hurmishine/article/details/51382141 AC代码: import java.math.Bi

HDU2054 A == B ?

问题链接:HDU2054 A == B ?. 问题简述:输入两个数,比较两个数的大小,相等的话输出"YES",不等的话输出"NO". 问题分析:可能是一个大数,需要特殊处理.如果没有小数点,就可以直接进行字符串比较,如果有小数点,则需要处理小数点后多余的"0",即删除那些"0",然后再进行字符串比较. 程序说明:编写函数mystrchange()对大数进行调整,去掉小数点后的"0".需要注意的是数可能很大,

最短的计算大数乘法的c程序

#include <stdio.h> char s[99],t[99]; int m,n; void r(int i,int c) { int j=0,k=i; while(k)c+=s[j++]*t[k---1]; if(i)r(i-1,c/10); printf("%d",c%10); } void main() { gets(s);gets(t); while(s[n])s[n++]-=48; while(t[m])t[m++]-=48; r(m+n-1,0); }

light oj 1236 【大数分解】

给定一个大数,分解质因数,每个质因子的个数为e1,e2,e3,--em, 则结果为((1+2*e1)*(1+2*e2)--(1+2*em)+1)/2. //light oj 1236 大数分解素因子 #include <stdio.h> #include <iostream> #include <string.h> #include <algorithm> #include <math.h> #include <ctype.h> #i

nyoj 73 比大小 【java大数】

java大数. 代码: import java.util.Scanner; import java.math.*; public class Main{ public static void main(String[] args){ Scanner cin = new Scanner(System.in); BigInteger a, b; BigInteger t = BigInteger.valueOf(0); a = cin.nextBigInteger(); b = cin.nextBi

uva 1478 - Delta Wave(递推+大数+卡特兰数+组合数学)

题目链接:uva 1478 - Delta Wave 题目大意:对于每个位置来说,可以向上,水平,向下,坐标不能位负,每次上下移动最多为1, 给定n问说有多少种不同的图.结果对10100取模. 解题思路:因为最后都要落回y=0的位置,所以上升的次数和下降的次数是相同的,并且上升下降的关系满足出栈入栈的关系.即卡特兰数. 所以每次枚举i,表示有i个上升,i个下降,用组合数学枚举出位置,然后累加求和. C(2?in)?f(i)=C(2?i?2n)?f(i?1)?(n?2?i+1)?(n?2?i+2)

各类大数模板

ps:转自http://blog.csdn.net/y990041769/article/details/20116995 大数加法模板(本人验证过,其他还没用,只是写在这) 1 string sum(string s1,string s2) 2 { 3 if(s1.length()<s2.length()) 4 { 5 string temp=s1; 6 s1=s2; 7 s2=temp; 8 } 9 int i,j; 10 for(i=s1.length()-1,j=s2.length()-

【51Nod】1005 大数加法

给出2个大整数A,B,计算A+B的结果. Input 第1行:大数A 第2行:大数B (A,B的长度 <= 10000 需注意:A B有可能为负数) Output 输出A + B Input示例 68932147586 468711654886 Output示例 537643802472 ==================================================================================================== 问题解法

HDU 1018 大数(求N!的位数/相加)

Big Number Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 35382    Accepted Submission(s): 16888 Problem Description In many applications very large integers numbers are required. Some of these