[ACM] POJ 2418 Hardwood Species (Trie树或map)

Hardwood Species

Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 17986   Accepted: 7138

Description

Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter.

America‘s temperate climates produce forests with hundreds of hardwood species -- trees that share certain biological characteristics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the
hardwood species represent 40 percent of the trees in the United States.

On the other hand, softwoods, or conifers, from the Latin word meaning "cone-bearing," have needles. Widely available US softwoods include cedar, fir, hemlock, pine, redwood, spruce and cypress. In a home, the softwoods are used primarily as structural lumber
such as 2x4s and 2x6s, with some limited decorative applications.

Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species.

Input

Input to your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters. There are no more than 10,000 species and no more than 1,000,000 trees.

Output

Print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to 4 decimal places.

Sample Input

Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow

Sample Output

Ash 13.7931
Aspen 3.4483
Basswood 3.4483
Beech 3.4483
Black Walnut 3.4483
Cherry 3.4483
Cottonwood 3.4483
Cypress 3.4483
Gum 3.4483
Hackberry 3.4483
Hard Maple 3.4483
Hickory 3.4483
Pecan 3.4483
Poplan 3.4483
Red Alder 3.4483
Red Elm 3.4483
Red Oak 6.8966
Sassafras 3.4483
Soft Maple 3.4483
Sycamore 3.4483
White Oak 10.3448
Willow 3.4483
Yellow Birch 3.4483

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceeded.

Source

Waterloo Local 2002.01.26

解题思路:

给出一系列的字符串。有同样的,问每一个字符串出现的次数站总字符串个数的百分比是多少,输出的时候按字符串的字典序输出。

第一种方法:用STL里面的map<string ,int >, first为字符串。int为出现的个数。更重要的是map是默认string按字典序从小到大排列的,所以输出的时候直接从头到尾就能够了。

另外一种方法:建立Trie树,对于输入的每个字符串都插入到树中。每个字符串在树中的最后一个字母节点保存着该字符串出现的次数,并用一个ok标记该节点是不是一个字符串的最后一个字母节点。

注意:折腾了非常长时间,发现用string 保存字符串比用 字符数组慢的太多太多。。。

以后还是用字符数组来保存字符串把。

第一种方法代码:

#include <iostream>
#include <stdio.h>
#include <iomanip>
#include <string.h>
#include <map>
using namespace std;

int main()
{
    map<string,int>mp;
    int cnt=0;
    string s;
    while(getline(cin,s))
    {
        mp[s]++;
        cnt++;
    }
    map<string,int >::iterator i;
    for(i=mp.begin();i!=mp.end();i++)
    {
        cout<<setiosflags(ios::fixed)<<setprecision(4)<<i->first<<" "<<100.0*(i->second)/cnt<<endl;
    }
    return 0;
}

另外一种方法代码:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
#include <iomanip>
using namespace std;
int num;//字符串的总个数

struct Trie
{
    int cnt;//某个字符串出现的总个数
    char name[40];//保存的字符串
    bool ok;//是不是走到了字符串的最后一个字母,保存最后一个字母的那个节点也保存着整个字符串的Name
    Trie *next[127];//子节点,ASCII最大值为126
    Trie()
    {
        ok=0;
        cnt=0;
        for(int i=0;i<127;i++)
            next[i]=NULL;
    }
}root;

void create(char s[])
{
    int len=strlen(s);
    Trie*p=&root;
    for(int i=0;i<len;i++)
    {
        int id=s[i];
        if(p->next[id]==NULL)
            p->next[id]=new Trie;
        p=p->next[id];
    }
    p->cnt++;//走到字符串的最后一个字母的节点
    strcpy(p->name,s);
    p->ok=1;
}

void dfs(Trie *root)//递归输出
{
    Trie*p=root;
    if(p->ok)
        cout<<p->name<<" "<<setiosflags(ios::fixed)<<setprecision(4)<<100.0*p->cnt/num<<endl;
    for(int i=0;i<127;i++)
    {
        if(p->next[i]!=NULL)
        {
            dfs(p->next[i]);
        }
    }
}

int main()
{
    char s[40];
    while(gets(s))
    {
        create(s);
        num++;
    }
    dfs(&root);
    return 0;
}

版权声明:本文博主原创文章。博客,未经同意不得转载。

时间: 2024-08-26 12:13:42

[ACM] POJ 2418 Hardwood Species (Trie树或map)的相关文章

[ACM] POJ 2418 Hardwood Species (Trie树或者map)

Hardwood Species Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 17986   Accepted: 7138 Description Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. Ameri

poj 2418 Hardwood Species (trie树)

poj   2418   Hardwood Species http://poj.org/problem?id=2418 trie树+dfs 题意: 给你多个单词,问每个单词出现的频率. 方法:通过字典树,将所有单词放入树中,通过dfs遍历(题目要求按ASSIC码顺序输出单词及其频率),dfs可满足 注意:单词中不一定只出现26个英文字母,ASSIC码表共有256个字符 1 #include <stdio.h> 2 #include <string.h> 3 #include &l

POJ 2418 Hardwood Species Trie解法

计算一个字符串数组中有多少个重复字符串出现. 如果直接使用map容器,那么这条题就很简单了,一下就AC了,因为map已经处理好一切了: 不过时间超过1532ms,有点慢. 如下: int main() { map<string, int> msi; int total = 0; char treeName[40]; while (gets(treeName)) { msi[treeName]++; total++; } for (map<string, int>::iterator

POJ 2418 Hardwood Species(字典树)

Hardwood Species Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 20085   Accepted: 7911 Description Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. Ameri

POJ 2418 Hardwood Species(字典树)

题目链接:POJ 2418 Hardwood Species [题意]给出一大串树的名字,可能有重复,然后按字典序输出名字和百分比. [思路]我已开始偷懒用了map来做,这道题给的时间是10s,用map的8s也还是水过了,真是神奇啊,后来还是写了一下字典树,700ms+就过了,效率提升显著啊.这里要注意的是建字典树的ChildSize是256,题目输入不只有字母,还有一些其它字符. 下面贴上代码,先是map的: 1 /* 2 ** POJ 2418 Hardwood Species 3 ** C

[字典树] poj 2418 Hardwood Species

题目链接: http://poj.org/problem?id=2418 Hardwood Species Time Limit: 10000MS   Memory Limit: 65536K Total Submissions: 17511   Accepted: 6949 Description Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and gene

POJ训练计划2418_Hardwood Species(Trie树)

解题报告 Tire树. #include <iostream> #include <cstring> #include <cstdio> #include <algorithm> using namespace std; struct node { int v; node *next[256]; }; int cnt=0,q; char ch[100],str1[100]; node *newnode() { node *p=new node; p->

POJ 2418 Hardwood Species(STL中map的应用)

题目地址:POJ 2418 通过这个题查了大量资料..知道了很多以前不知道的东西.... 在代码中注释说明吧. 代码如下: #include <iostream> #include <cstdio> #include <string> #include <cstring> #include <stdlib.h> #include <math.h> #include <ctype.h> #include <queue&

[ACM] POJ 2513 Colored Sticks (Trie树,欧拉通路,并查集)

Colored Sticks Time Limit: 5000MS   Memory Limit: 128000K Total Submissions: 29736   Accepted: 7843 Description You are given a bunch of wooden sticks. Each endpoint of each stick is colored with some color. Is it possible to align the sticks in a st