HDOJ 2594 Simpsons’ Hidden Talents (KMP)

链接:http://acm.hdu.edu.cn/showproblem.php?pid=2594



题目:

Problem Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton

homer

riemann

marjorie

Sample Output

0

rie 3


题意:

给出s1,s2两个串 求出既为s1的前缀又为s2后缀的子串

思路:

把s1 s2两个串合并成一个新字符串S 把题目转换成求S串的既是前缀又是后缀的最长子串

因为是s1 s2串的子串 要留意在S串中求出来子串的长度是否超过s1和s2的长度 如果超过 就是直接将s1或s2串当作子串



代码:

#include <bits/stdc++.h>

using namespace std;
const int maxn=5e4+10;
int nx[maxn*2];
string s,t;

void getnx(string S,int len){
    int j=0,k=-1;
    nx[0]=-1;
    while(j<len){
        if(k==-1 || S[j]==S[k]) nx[++j]=++k;
        else k=nx[k];
    }
}

int main(){
 //   freopen("1.in","r",stdin);
    while(cin>>s){
        cin>>t;
        memset(nx,0,sizeof(nx));
        string S=s+t;
        int len=S.length();
        getnx(S,len);
        if(nx[len]>0){
            if(nx[len]>min(s.length(),t.length())){
                if(s.length()>t.length()){
                    cout<<t<<" "<<t.length()<<endl;
                }
                else cout<<s<<" "<<s.length()<<endl;
            }
            else{
                string tmp=S.substr(0,nx[len]);
                int tlen=tmp.length();
                cout<<tmp<<" "<<tlen<<endl;
            }
        }
        else cout<<"0"<<endl;
    }
    return 0;
}

原文地址:https://www.cnblogs.com/whdsunny/p/10859074.html

时间: 2024-08-04 23:58:36

HDOJ 2594 Simpsons’ Hidden Talents (KMP)的相关文章

HDU 2594 Simpsons’ Hidden Talents KMP题解

KMP的应用.直接使用s1产生next 数组,然后在s2中搜索s1,那么记录最后一个搜索到的数值,就是s1的前缀在s2中的最长后缀了. 本题应该不能直接调用strstr了吧. #include <stdio.h> #include <vector> #include <string.h> #include <algorithm> #include <iostream> #include <string> #include <li

HDU 2594 Simpsons’ Hidden Talents (KMP)

#include <stdio.h> #include <string.h> int next[50005]; char str1[50005],str2[50005]; void build_next(int len2) { int i=0,j=-1; next[0] = -1; while (i < len2) { if (j==-1 || str2[i] == str2[j]) { i++; j++; if (str2[i] != str2[j]) { next[i]

hdu 2594 Simpsons’ Hidden Talents(KMP入门)

Simpsons’ Hidden Talents Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 4543    Accepted Submission(s): 1648 Problem Description Homer: Marge, I just figured out a way to discover some of the t

HDU 2594 - Simpsons’ Hidden Talents(KMP)

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=2594 题目描述: 给定两个字符串s1,s2,问是否存在一个最长的子串,使得这个子串既是s1的前缀又是s2的后缀. 题解: 既然是要求s1的前缀与s2后缀,那么只要将s1与s2合并成一个字符串str,再来对这个字符串进行一波kmp就可以知道题目要求的前后缀是否存在了. 字符串的合并最方便的是string,所以用C++的做法做这道题. 不过这种做法要注意的是,如果s1与s2的内容相同,那么最终会得到超

HDU 2594 Simpsons’ Hidden Talents (字符串-KMP)

Simpsons' Hidden Talents Problem Description Homer: Marge, I just figured out a way to discover some of the talents we weren't aware we had. Marge: Yeah, what is it? Homer: Take me for example. I want to find out if I have a talent in politics, OK? M

HDU 2594 Simpsons’ Hidden Talents (KMP)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2594 这题直接用KMP算法就可以做出来,不过我还尝试了用扩展的kmp,这题用扩展的KMP效率没那么高. KMP算法: #include<stdio.h> #include<iostream> #include<string.h> using namespace std; int next[50001]; char p[50000],s[50000]; void getnex

HDU 2594 Simpsons’ Hidden Talents(辛普森一家的潜在天赋)

HDU 2594 Simpsons’ Hidden Talents(辛普森一家的潜在天赋) Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) [Description] [题目描述] Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had. Marge:

hdu 2594 Simpsons’ Hidden Talents 【KMP】

题目链接:http://acm.acmcoder.com/showproblem.php?pid=2594 题意:求最长的串 同时是s1的前缀又是s2的后缀.输出子串和长度. 思路:kmp 代码: #include <vector> #include <string> #include <algorithm> #include <iostream> #include <stdio.h> #include <string.h> usin

hdu 2594 Simpsons’ Hidden Talents

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=2594 题目: Problem Description Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.Marge: Yeah, what is it?Homer: Take me for example. I want to find out if I hav