HDU - 2328 Corporate Identity

Description

Beside other services, ACM helps companies to clearly state their “corporate identity”, which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently
asked ACM for a help with their new identity. IBM do not want to change their existing logos and trademarks completely, because their customers are used to the old ones. Therefore, ACM will only change existing trademarks instead of creating new ones.

After several other proposals, it was decided to take all existing trademarks and find the longest common sequence of letters that is contained in all of them. This sequence will be graphically emphasized to form a new logo. Then, the old trademarks may still
be used while showing the new identity.

Your task is to find such a sequence.

Input

The input contains several tasks. Each task begins with a line containing a positive integer N, the number of trademarks (2 ≤ N ≤ 4000). The number is followed by N lines, each containing one trademark. Trademarks will be composed
only from lowercase letters, the length of each trademark will be at least 1 and at most 200 characters.

After the last trademark, the next task begins. The last task is followed by a line containing zero.

Output

For each task, output a single line containing the longest string contained as a substring in all trademarks. If there are several strings of the same length, print the one that is lexicographically smallest. If there is no such non-empty
string, output the words “IDENTITY LOST” instead.

Sample Input

 3
aabbaabb
abbababb
bbbbbabb
2
xyz
abc
0 

Sample Output

 abb
IDENTITY LOST
题意:求所有串的最长公共串
思路:枚举第一个串的字串,然后匹配查找
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int Maxn = 4010;
const int N = 210;

int n, next[Maxn];
char words[Maxn][N];

int cmp(const void *str1, const void *str2) {
	return strlen((char *)str1) - strlen((char *)str2);
}

void getNext(char *str) {
	int m = strlen(str);
	next[0] = next[1] = 0;
	for (int i = 1; i < m; i++) {
		int j = next[i];
		while (j && str[i] != str[j])
			j = next[j];
		next[i+1] = str[i] == str[j] ? j+1 : 0;
	}
}

int kmp(char *text, char *str) {
	getNext(str);
	int n = strlen(text);
	int m = strlen(str);
	int j = 0;
	for (int i = 0; i < n; i++) {
		while (j && text[i] != str[j])
			j = next[j];
		if (str[j] == text[i])
			j++;
		if (j == m)
			return 1;
	}
	return 0;
}

int main() {
	while (scanf("%d", &n) != EOF && n) {
		for (int i = 0; i < n; i++)
			scanf("%s", words[i]);
		qsort(words, n, sizeof(words[0]), cmp);
		char ans[Maxn], tmp[Maxn];
		int len = strlen(words[0]);
		int Max = 0;
		for (int i = 0; i < len; i++) {
			memset(tmp, '\0', sizeof(tmp));
			int pos = 0;
			for (int j = i; j < len; j++) {
				tmp[pos++] = words[0][j];
				getNext(tmp);

				int flag = 1;
				for (int k = 1; k < n; k++)
					if (kmp(words[k], tmp) == 0) {
						flag = 0;
						break;
					}
				if (flag && Max < pos) {
					Max = pos;
					memcpy(ans, tmp, sizeof(tmp));
				}
				else if (flag && Max == pos && strcmp(ans, tmp) > 0)
					memcpy(ans, tmp, sizeof(tmp));
			}
		}

		if (Max)
			printf("%s\n", ans);
		else printf("IDENTITY LOST\n");
	}
	return 0;
}
时间: 2024-10-15 19:07:43

HDU - 2328 Corporate Identity的相关文章

hdu 2328 Corporate Identity(kmp)

Problem Description Beside other services, ACM helps companies to clearly state their “corporate identity”, which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recentl

(KMP 暴力)Corporate Identity -- hdu -- 2328

http://acm.hdu.edu.cn/showproblem.php?pid=2328 Corporate Identity Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 698    Accepted Submission(s): 281 Problem Description Beside other services, AC

hdu2328 Corporate Identity 扩展KMP

Beside other services, ACM helps companies to clearly state their "corporate identity", which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently asked ACM for

POJ 3450 Corporate Identity KMP题解

本题要求求一组字符串的最长公共子串,其实是灵活运用KMP快速求最长前缀. 注意肯爹的题意:要求按照字典顺序输出. 还有要提醒的就是:有人也是用KMP来解这道题,但是很多人都把KMP当成暴力法来用了,没有真正处理好细节,发挥KMP的作用.而通常这些人都大喊什么暴力法可以解决本题,没错,的确暴力法是可以解决本题的,本题的数据不大,但是请不要把KMP挂上去,然后写成暴力法了,那样会误导多少后来人啊. 建议可以主要参考我的getLongestPre这个函数,看看是如何计算最长前缀的. 怎么判断你是否把本

POJ-3450 Corporate Identity (KMP+后缀数组)

Description Beside other services, ACM helps companies to clearly state their "corporate identity", which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently a

POJ 题目3450 Corporate Identity(KMP 暴力)

Corporate Identity Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 5493   Accepted: 2015 Description Beside other services, ACM helps companies to clearly state their "corporate identity", which includes company logo but also other

N - Corporate Identity

Beside other services, ACM helps companies to clearly state their "corporate identity", which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently asked ACM for

POJ 3450 Corporate Identity 求所有字符的最长公共子串

Description Beside other services, ACM helps companies to clearly state their "corporate identity", which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently a

hdu2328 Corporate Identity【string库使用】【暴力】【KMP】

Corporate Identity Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 3308    Accepted Submission(s): 1228 Problem Description Beside other services, ACM helps companies to clearly state their "cor