HDOJ Square Coins 1398【母函数】

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9761    Accepted Submission(s): 6692

Problem Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are
available in Silverland.

There are four combinations of coins to pay ten credits:

ten 1-credit coins,

one 4-credit coin and six 1-credit coins,

two 4-credit coins and two 1-credit coins, and

one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

Sample Input

2
10
30
0

Sample Output

1
4
27

Source

Asia 1999, Kyoto (Japan)

Recommend

Ignatius.L   |   We have carefully selected several similar problems for you:  1171 1085 2152 2082 1709

注意:k+=i*i

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>

using namespace std;

int n,m;
int c1[300];
int c2[300];
int f[310];
int generation(int x)
{
	for(int i=0;i<=x;i++){
		c1[i]=1;
		c2[i]=0;
	}
	for(int i=2;i<=17;i++){
		for(int j=0;j<=x;j++){
			for(int k=0;k+j<=x;k+=i*i){
				c2[j+k]+=c1[j];
			}
		}
		for(int j=0;j<=x;j++){
			c1[j]=c2[j];
			c2[j]=0;
		}
	}
	return c1[x];
}

void init()
{
	for(int i=1;i<301;i++){
		f[i]=generation(i);
	}
}

int main()
{
	int n;
	init();
	while(scanf("%d",&n),n){
		printf("%d\n",f[n]);
	}
	return 0;
}

版权声明:本文为博主原创文章,转载请注明出处。

时间: 2024-10-14 22:38:22

HDOJ Square Coins 1398【母函数】的相关文章

hdu 1398 Square Coins(母函数|完全背包)

http://acm.hdu.edu.cn/showproblem.php?pid=1398 题意:有价值为1^2,2^2....7^2的硬币共17种,每种硬币都有无限个.问用这些硬币能够组成价值为n的钱数共有几种方案数. 母函数: #include <stdio.h> #include <iostream> #include <map> #include <set> #include <stack> #include <vector>

hdu 1398 Square Coins(母函数,完全背包)

链接:hdu 1398 题意:有17种货币,面额分别为i*i(1<=i<=17),都为无限张, 给定一个值n(n<=300),求用上述货币能使价值总和为n的方案数 分析:这题可以用母函数的思想,对300以内的值进行预处理即可 也可用完全背包思想求300以内的方案数 母函数: #include<stdio.h> int main() { int c1[305],c2[305],i,j,k,n; for(i=0;i<=300;i++){ c1[i]=1; c2[i]=0;

HDU1398 Square Coins 【母函数模板】

Square Coins Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7995    Accepted Submission(s): 5416 Problem Description People in Silverland use square coins. Not only they have square shapes but

HDU 1398 Square Coins(母函数或DP)

Square Coins Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 12929    Accepted Submission(s): 8885 Problem Description People in Silverland use square coins. Not only they have square shapes but

HDU 1398 Square Coins (母函数-整数拆分变形)

Square Coins Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7612    Accepted Submission(s): 5156 Problem Description People in Silverland use square coins. Not only they have square shapes but

Square Coins(母函数)

Square Coins Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 9926    Accepted Submission(s): 6806 Problem Description People in Silverland use square coins. Not only they have square shapes but

hdu 1398 Square Coins(母函数)

代码: #include<cstdio> using namespace std; int main() { int n; int a[18]; for(int i=1;i<=17;i++) a[i]=i*i; while(scanf("%d",&n)&&n) { long long c1[350],c2[350]; for(int i=0;i<=n;i++) { c1[i]=1; c2[i]=0; } for(int i=2;a[i]&

HDU1398 Square Coins【母函数】

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1398 题目大意: Silverland居住的人们使用方币,这种硬币的价值都是平方数.硬币的价值分别为1分.4分.9分, -,最大为289(17^2)分.要得到10分钱,共有四种硬币组合 10个1分硬币.1个4分硬币和6个1分硬币.2个4分硬币和2个1分硬币,1个9分硬币和1个1分硬币. 现在给你一个数,问:得到这个值,共有多少种不同的硬币组合方式. 思路: 典型的母函数问题. 可列出母函数 g(x

hdu1398 Square Coins(母函数)

题目类似于整数拆分,很明显用母函数来做. 母函数的写法基本固定,根据具体每项乘式的不同做出一些修改就行了.它的思路是从第一个括号开始,一个括号一个括号的乘开,用c1数组保存之前已经乘开的系数,即c1[j]表示在之前已经乘开过的那些括号处理后x的j次方的系数,c2数组是一个临时更新的统计数组,每处理一个括号就更新一遍c1数组即可. #include<iostream> #include<cstdio> #include<cstdlib> #include<cstri