A1051. Pop Sequence (25)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO
#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <string>
#include <stack>
using namespace std;

int main(){
    stack<int> st;
    int m,n,k;
    scanf("%d %d %d",&m,&n,&k);
    int a[n];
    while(k--)
    {
        //初始化栈
        while(!st.empty())
        {
            st.pop();
        }
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        int current=0;
        bool flag=true;
        for(int i=1;i<=n;i++)
        {
            st.push(i);
            if(st.size()>m)
            {
                flag=false;
                break;
            }
            while(!st.empty()&&st.top()==a[current])
            {
                st.pop();
                current++;
            }
        }

        if(st.empty()==true&&flag==true)
        printf("YES\n");
        else
        printf("NO\n");

    }
    return 0;
}
时间: 2024-07-31 07:55:14

A1051. Pop Sequence (25)的相关文章

数据结构专题 ——栈的应用 A1051.Pop Sequence(25)

解法1:(自己码的) #include <bits/stdc++.h> #include<math.h> #include <string> using namespace std; const int MAXN = 10000; stack<int> stk; int main(){ int M,N,K; scanf("%d%d%d",&M,&N,&K); int temp[N]; bool flag; int

1051. Pop Sequence (25)

1051. Pop Sequence (25) 时间限制 100 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence

PAT 1051. Pop Sequence (25)

1051. Pop Sequence (25) Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if

PAT 甲级 1051 Pop Sequence (25 分)(模拟栈,较简单)

1051 Pop Sequence (25 分) Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if

1051 Pop Sequence (25分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we ca

数据结构练习 02-线性结构3. Pop Sequence (25)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we ca

PAT1051. Pop Sequence (25)

#include <iostream> #include <stack> using namespace std; int sizeMax,n,k; stack<int> sta; int queueNum; int num; int j;int flag=0; int main(){ cin>>sizeMax>>n>>k; while(k--){ while(!sta.empty()){sta.pop();} queueNum=1;

Pop Sequence (25)

已知栈的输入序列,给出一个输出序列,检查能否按此顺序输出? 怎么做? 输入 1 2 3 4 5 输出 1 4 3 2 5 最大容量3 我们把输入和输出都定义为队列( 模仿输入输出流嘛 ) 再定义一个堆栈,上面的例子该怎么检查呢? 要输出的第一个数是1 我就从in里取数到stack,直取stack的top元素是1为止 in 2 3 4 5 out 1 4 3 2 5 stack 1 这时同时pop out和stack in 2 3 4 5 out 4 3 2 5 stack 要输出4 我就从in里

PAT甲题题解-1051. Pop Sequence (25)-堆栈

将1~n压入最多为m元素的栈 给出k个出栈序列,问你是否能够实现. 能输出YES 否则NO 模拟一遍即可,水题. #include <iostream> #include <cstdio> #include <string.h> #include <algorithm> using namespace std; const int maxn=1005; int m,n,k; int seq[maxn]; int stacks[maxn]; int rear=