POJ 3026 Borg Maze(BFS+最小生成树【有坑】)

Borg Maze

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 12012 Accepted: 3924

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance.

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space ‘‘ stands for an open space, a hash mark#” stands for an obstructing wall, the capital letter A‘‘ stand for an alien, and the capital letterS” stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the “S”. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
#####
#A#A##
# # A#
#S  ##
#####
7 7
#####
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  

Sample Output

8

11

【坑点】:n,m之后有一堆空格,,,,坑死大大了,,,以后大家可以注意下。getchar()都用gets()代替

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#include<iostream>
#define INF 0x7fffffff
#define eps 1e-6
using namespace std;
int n,m,xl,yl;
int cot;
int xx[]= {-1,1,0,0};
int yy[]= {0,0,-1,1};
struct lx
{
    int u,v,len;
} l[50*1001];
int fa[1001];

bool vis[151][151];
char g[151][151];
int site[151][151];
struct node
{
    int x,y,lv;
} point[1001];
bool cmp(lx a,lx b)
{
    return a.len<b.len;
}
int father(int x)
{
    if(x!=fa[x])
        return fa[x]=father(fa[x]);
}
void BFS(node S)
{
    memset(vis,0,sizeof(vis));
    queue<node>q;
    q.push(S);
    vis[S.x][S.y]=1;
    int u=site[S.x][S.y];
    int num=1;
    while(!q.empty())
    {
        node now,tmp;
        tmp=q.front();
        q.pop();
        int v=site[tmp.x][tmp.y];
        if(v>=1&&u!=v)
        {
            l[cot].u=u;
            l[cot].v=v;
            l[cot++].len=tmp.lv;
            num++;
        }
        if(num==n)break;
        for(int k=0; k<4; k++)
        {
            int x=tmp.x+xx[k];
            int y=tmp.y+yy[k];
            if(y>=yl||y<0||x>=xl||x<0||g[x][y]==‘#‘||vis[x][y])
                continue;
            vis[x][y]=1;
            now.lv=tmp.lv+1;
            now.x=x,now.y=y;
            q.push(now);
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&xl,&yl);
        char str[51];
        memset(site,0,sizeof(site));
        n=1;
        gets(str);
        for(int i=0; i<yl; i++)
        {
            gets(str);
            for(int j=0; j<xl; j++)
            {
                g[i][j]=str[j];
                if(str[j]==‘A‘||str[j]==‘S‘)
                {
                    site[i][j]=n;
                    point[n].x=i,point[n].y=j;
                    point[n++].lv=0;

                }
            }
        }
        cot=0;
        n--;
        for(int i=1; i<=n; i++)
            BFS(point[i]);
        for(int i=1; i<=n; i++)
            fa[i]=i;
        sort(l,l+cot,cmp);
        int ans=0;
        for(int i=0; i<cot; i++)
        {
            int fu=father(l[i].u);
            int fv=father(l[i].v);
            if(fu==fv)continue;
            fa[fv]=fu;
            ans+=l[i].len;
        }
        printf("%d\n",ans);
    }
    return 0;
}
时间: 2024-10-07 06:14:41

POJ 3026 Borg Maze(BFS+最小生成树【有坑】)的相关文章

poj 3026 Borg Maze (bfs + 最小生成树)

链接:poj 3026 题意:y行x列的迷宫中,#代表阻隔墙(不可走),空格代表空位(可走),S代表搜索起点(可走) A代表外星人站(可走),现在要从S出发,将S和所有的A之间都连通,求路线总距离最小值 分析:可以先用bfs将所有的A,S两两之间的最短距离,题目的目的是将S与所有的A连通,使得总距离最小, 所有任选一点开始按最小生成树的算法做就行,并非非要从S点开始 注:题目输入x,y后可能有很多空格,可以用gets将多余的空格取走,开数组是尽量开大点,之前虽然开的比题目数据     稍大,但一

POJ - 3026 Borg Maze BFS加最小生成树

Borg Maze 题意: 题目我一开始一直读不懂.有一个会分身的人,要在一个地图中踩到所有的A,这个人可以在出发地或者A点任意分身,问最少要走几步,这个人可以踩遍地图中所有的A点. 思路: 感觉就算读懂了题目,也比较难想到这用到了最小生成树的知识,因为可以分身,所以每个点可以向其他点都连上边.可以用bfs预处理出所有的S点,A点的连线,再跑一遍最小生成树,即可得出答案.这里有几点注意,一开始我bfs没有记录step,而是直接找到一点后算曼哈顿距离,这是不对的,因为可能是绕了一个圈到了这个点.还

poj 3026 Borg Maze(bfs+prim)

Borg Maze Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 10810   Accepted: 3574 Description The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to desc

poj 3026 Borg Maze(最小生成树+bfs)

题目链接:http://poj.org/problem?id=3026 题意:题意就是从起点开始可以分成多组总权值就是各组经过的路程,每次到达一个‘A'点可以继续分组,但是在路上不能分组 于是就是明显的最小生成树,点与点的距离要用bfs或者dfs求一下.这题bfs要稍微优化一下.不能下暴力的bfs就是两点两点之间 bfs这样会有很多重复的查询会超时,所以要一次性的bfs找到一个点就bfs到底. #include <iostream> #include <algorithm> #in

POJ 3026 Borg Maze(bfs + prime)

解题思路: 先用BFS预处理出每个字母节点到其它节点的最短路径,然后套用prime算法. #include <iostream> #include <cstring> #include <cstdlib> #include <cstdio> #include <algorithm> #include <queue> #include <stack> #include <vector> #include <

POJ 3026 Borg Maze &amp; UVA 10307 Killing Aliens in Borg Maze(BFS,最小生成树)

http://poj.org/problem?id=3026 http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1248 Borg Maze Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 8498   Accepted: 2862 Description The Bor

POJ 3026 Borg Maze

Borg Maze Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7998   Accepted: 2675 Description The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to descr

POJ3026——Borg Maze(BFS+最小生成树)

Borg Maze DescriptionThe Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked

POJ 3026 Borg Maze【BFS+最小生成树MST】

Borg Maze Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 12014 Accepted: 3925 Description The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe