多校7.21A——OO’s Sequence

Problem Description

OO has got a array A of size n ,defined a function f(l,r) represent the number of i (l<=i<=r) , that there‘s no j(l<=j<=r,j<>i) satisfy ai mod aj=0,now OO want to know

∑i=1n∑j=inf(i,j) mod (109+7).

Input

There are multiple test cases. Please process till EOF.
In each test case: 
First line: an integer n(n<=10^5) indicating the size of array
Second line:contain n numbers ai(0<ai<=10000)

Output

For each tests: ouput a line contain a number ans.

Sample Input

5
1 2 3 4 5

Sample Output

23

Source

2015 Multi-University Training Contest 1

Recommend

We have carefully selected several similar problems for you:  5299 5298 5297 5296 5295

/*
 题意:对于所有的子区间找a[i]在这个区间没有因子的所有的情况
 对于一个数a[i]它的价值是L[i]:从左往右最接近的因子的下标,R[[i]:从右往左最接近的因子下标,a[i]在这个区间内都是可以的那么总共的种类区间有(i - L[i]) * (R[i] - i)
总复杂度O(n根号n)
用index数组来记录该因子出现的位置
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

const int MAX = 100000 + 10;
const int mod = 1e9 + 7;
int a[MAX];
int L[MAX], R[MAX], index[MAX];

int main()
{
    int n;
    while(~scanf("%d", &n)){
        for(int i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        memset(index, -1, sizeof(index));
        for(int i = 1; i <= n; i++){
            int temp = sqrt(1.0 * a[i]);
            int l = 0;
            for(int j = 1; j <= temp; j++){
                if(a[i] % j == 0){
                    if(index[j] != -1)
                        l = max(index[j], l);
                    if(index[a[i] / j] != -1)
                        l = max(index[a[i] / j], l);
                }
            }
                index[a[i]] = i;
                L[i] = l;
        }
        memset(index, -1, sizeof(index));
            for(int i = n; i >= 1 ;i--){
                int temp = sqrt(1.0 * a[i]);
                int r = n + 1;
                for(int j = 1; j <= temp; j++){
                    if(a[i] % j == 0){
                        if(index[j] != -1)
                            r = min(index[j], r);
                        if(index[a[i] / j] != -1)
                            r = min(index[a[i] / j], r);
                    }
                }
                index[a[i]] = i;
                R[i] = r;
            }
         int l1, r1;
         int  sum = 0;
        for(int i = 1; i <= n; i++){
            l1 = i - L[i], r1 = R[i] - i ;
            sum = (l1 * r1 % mod + sum) % mod;
        }
        printf("%d\n", sum);
    }
    return 0;
}

  

时间: 2024-12-23 23:30:21

多校7.21A——OO’s Sequence的相关文章

HDU 5288 OO&#39;s sequence (2015多校第一场 二分查找)

OO's Sequence Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 955    Accepted Submission(s): 358 Problem Description OO has got a array A of size n ,defined a function f(l,r) represent the nu

hdu5288(2015多校1)OO’s Sequence

OO's Sequence Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 353    Accepted Submission(s): 117 Problem Description OO has got a array A of size n ,defined a function f(l,r) represent the nu

HDU 5288 OO’s Sequence(多校第一场1001)

OO's Sequence Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 900    Accepted Submission(s): 339 Problem Description OO has got a array A of size n ,defined a function f(l,r) represent the nu

hdu 5228 OO’s Sequence 多校 思维题

点击打开链接 OO's Sequence Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 1317    Accepted Submission(s): 467 Problem Description OO has got a array A of size n ,defined a function f(l,r) represen

[HDOJ5288]OO&#39;s Sequence

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5288 转换成求从1到n可以整除A[i]的区间的数量.找离最近的A[i]最近的可以整除A[i]的l和r,因为再往左或者右必然包含l和r假如[l,i]有x个数字,[i,r]有y个数字,那么A[i]的贡献即(x+1)*(y+1)求A[i]对ans的贡献综合即求离A[i]最近的可以被A[i]整除的数 1 #include <cstdio> 2 #include <cstdlib> 3 #inc

hdu 5288 OO’s Sequence 分解因子

链接:http://acm.hdu.edu.cn/showproblem.php?pid=5288 OO's Sequence Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 588    Accepted Submission(s): 209 Problem Description OO has got a array A of

Hdu 5288 OO’s Sequence 2015多小联赛A题

OO's Sequence Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 1751    Accepted Submission(s): 632 Problem Description OO has got a array A of size n ,defined a function f(l,r) represent the n

HDU 5288 OO’s Sequence (暴力枚举因子)

题目链接:HDU 5288 OO's Sequence 题意:给出一个n,表示n个数的序列,函数f(l,r)定义,在l,r区间中存在多少个数,不能被其他数整除.求累加所有子区间的函数值 思路:从ai的小范围入手 1.a不能被b整除,即a的所有因子中不存在b,所以打表枚举所有的数的因子. 2.找到一个数(位置为i)满足条件时最左端l和最右端r,(i-l)*(r-i)就是对答案的贡献. AC代码: #include <stdio.h> #include <algorithm> #inc

HDOJ 5288 OO’s Sequence 水

预处理出每个数字的左右两边可以整除它的最近的数的位置 OO's Sequence Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 1880    Accepted Submission(s): 672 Problem Description OO has got a array A of size n ,defined a func