Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16028 Accepted Submission(s): 11302
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4 10 20
Sample Output
5 42 627
题解:相当于取砝码,每个砝码可以取多次;
4=1+1+1+1=1+1+2=1+3=2+2;
则母函数为:
相当于1的砝码取法从0....n,2的砝码0....n/2。。。。。。k的砝码从0....n/k;
代码:
1 #include<stdio.h> 2 const int MAXN=10010; 3 int main(){ 4 int a[MAXN],b[MAXN],N; 5 while(~scanf("%d",&N)){ 6 int i,j,k; 7 for(i=0;i<=N;i++){ 8 a[i]=1;b[i]=0; 9 } 10 for(i=2;i<=N;i++){ 11 for(j=0;j<=N;j++) 12 for(k=0;k+j<=N;k+=i) 13 b[j+k]+=a[j]; 14 for(j=0;j<=N;j++) 15 a[j]=b[j],b[j]=0; 16 } 17 printf("%d\n",a[N]); 18 } 19 return 0; 20 }