hdu hide handkerchief

hide handkerchief

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description

The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.
Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .
Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.
So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".

Input

There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.

Output

For each input case, you should only the result that Haha can find the handkerchief or not.

Sample Input

3 2
-1 -1

Sample Output

YES

对于题目的理解:

这个题目可以理解为下面的模型。

开始处于x的位置,每次隔M个访问一次,问最后能否把原来的N个全部访问。(不妨假设这N个序号是从0到N-1)

如果我们从开始一共走了K步,那么可以得到现在所处的位置是(x+k*M)%N。可以知道如果访问到某个节点的时候,这个节点在前面已经出现过了,且这N个节点没有全部访问完的时候结果是不可能访问完这N个节点。如果出现节点重复,此时恰好走了N步,那么就输出yes。以上的想法可以简单的画图理解。

由上述分析可知,如果(x+K*M)%N=x(表示出现重复节点),且K=N时结果是yes,所以化简这个式子有:(K*M)%N=0,那么要找到这个最小的K满足这个式子自然会想到最小公倍数。再进一步想如果N*M是M和N的最小公倍数,那么M和N的最大公约数必然是1。也就有了下面的程序。

#include<iostream>
#include<string>
#include<string.h>
using namespace std;
int gcd(int a, int b)
{
	if (a > b)
	{
		a = a + b;
		b = a - b;
		a = a - b;
	}
	while (a != 0)
	{
		int c = b%a;
		b = a;
		a = c;
	}
	return b;
}
int main()
{
	int n, m;
	while (cin >> n >> m)
	{
		if (n == -1 && m == -1)
			break;
		int temp= gcd(n, m);
		if (temp ==1)
			cout << "YES" << endl;
		else cout << "POOR Haha" << endl;
	}
	return 0;
}

  

时间: 2024-08-17 10:48:03

hdu hide handkerchief的相关文章

HDU 2104 hide handkerchief(辗转相除法--GCD)

hide handkerchief Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4693 Accepted Submission(s): 1547 Problem Description The Children's Day has passed for some days .Has you remembered something h

杭电OJ(HDU)-ACM Steps-Chapter Two-《Biker&#39;s Trip Odometer》《Climbing Worm》《hide handkerchief》《Nasty Hac》

1.2.1 Biker's Trip Odometer #include<stdio.h> #include<math.h> const double PI=acos(-1.0); /* 计算题,根据公式做就行,PI*d*r/(12*5280);res1/t*3600; Sample Input 26 1000 5 27.25 873234 3000 26 0 1000 Sample Output Trip #1: 1.29 928.20 Trip #2: 1179.86 1415

hide handkerchief

Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 5029 Accepted Submission(s): 1670   Problem Description The Children’s Day has passed for some days .Has you remembered something happened at your

(HDUStep 1.2.2)hide handkerchief(用辗转相除法来求最大公约数)

hide handkerchief Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 5050 Accepted Submission(s): 1676 Problem Description The Children's Day has passed for some days .Has you remembered something h

ACM step 1.2.3 hide handkerchief

The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.Now I introduce the game to you. Suppose there are N people played the g

hide handkerchief(hdu2104)

思考:这种找手绢就是,在判断是否互质.用辗转相除法(用来求最大公约数:a)进行判断.r=a%b;a=b;b=r;循环限制条件:除数b=0是结束除法.如果这时被除数a=1,则表示两个互质. #include<stdio.h> int main() { int N,M; char d; while(scanf("%d%d%c",&N,&M,&d)!=EOF) { if(N==-1&&M==-1) break; int r; while(M

hdu 2104(判断互素)

hide handkerchief Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3970    Accepted Submission(s): 1884 Problem Description The Children’s Day has passed for some days .Has you remembered someth

HDU 3988 Harry Potter and the Hide Story(数论-整数和素数)

Harry Potter and the Hide Story Problem Description iSea is tired of writing the story of Harry Potter, so, lucky you, solving the following problem is enough. Input The first line contains a single integer T, indicating the number of test cases. Eac

[数论] hdu 3988 Harry Potter and the Hide Story

题意: 给N.K,问满足 n!%(k^x)=0 最大的x. 思路: 首先当k=1的时候,输出inf 然后就是,因为要整除,所以我们就分解k的质因子 假设每个质因子有si个,那么对应的n!里面有sumi个 那么对于当前因子最大的x=suni/si 然后就是所有的因子找最小值了. 这里需要打表 10^7的素数表 代码: #include"cstdlib" #include"cstdio" #include"cstring" #include"