The Suspects-并查集(4)

C - The Suspects

Time Limit:1000MS     Memory Limit:20000KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there
are many student groups. Students in the same group intercommunicate
with each other frequently, and a student may join several groups. To
prevent the possible transmissions of SARS, the NSYSU collects the
member lists of all student groups, and makes the following rule in
their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the
suspects when a student is recognized as a suspect. Your job is to write
a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two
integers n and m in a line, where n is the number of students, and m is
the number of groups. You may assume that 0 < n <= 30000 and 0
<= m <= 500. Every student is numbered by a unique integer between
0 and n−1, and initially student 0 is recognized as a suspect in all
the cases. This line is followed by m member lists of the groups, one
line per group. Each line begins with an integer k by itself
representing the number of members in the group. Following the number of
members, there are k integers representing the students in this group.
All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1
#include <cstdio>
int pa[300000],a,n,num[100000];
int cha(int k)
{
    if(pa[k]!=k)
    {
        pa[k]=cha(pa[k]);
    }
    return pa[k];
}
bool bing(int x,int y)
{
    int x2=cha(x);
    int y2=cha(y);
    if(x2==y2)
        return false;
    pa[y2]=x2;//把他们都连在一起
    num[x2]+=num[y2];//num用作累计结点个数
    return true;
}
void  init(int n)
{
    for(int i=0; i<=n; i++)
    {
        pa[i]=i;
        num[i]=1;
    }
    return ;
}
int main()
{
    int m,n,k,t;
    while(scanf("%d%d",&n,&m))
    {
        init(n);
        if(m+n==0)
        {
            break;
        }
        for(int i=0; i<m; i++)
        {
            scanf("%d",&k);
            scanf("%d",&t);
            for(int j=1; j<k; j++)
            {
                scanf("%d",&a);
                bing(t,a);
            }
        }
        printf("%d\n",num[cha(0)]);//查出祖宗为0的结点个数
    }
    return 0;
}
时间: 2024-08-28 06:23:01

The Suspects-并查集(4)的相关文章

[ACM] POJ 1611 The Suspects (并查集,输出第i个人所在集合的总人数)

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 21586   Accepted: 10456 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T

The Suspects (并查集)

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. In the Not-Sprea

POJ 1611 The Suspects (并查集+数组记录子孙个数 )

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 24134   Accepted: 11787 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T

The Suspects(并查集维护根节点信息)

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 37090   Accepted: 17980 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T

POJ 1611 The Suspects (并查集求数量)

Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. In t

POJ 1611 The Suspects 并查集 Union Find

本题也是个标准的并查集题解. 操作完并查集之后,就是要找和0节点在同一个集合的元素有多少. 注意这个操作,须要先找到0的父母节点.然后查找有多少个节点的额父母节点和0的父母节点同样. 这个时候须要对每一个节点使用find parent操作.由于最后状态的时候,节点的parent不一定是本集合的根节点. #include <stdio.h> const int MAX_N = 30001; struct SubSet { int p, rank; }sub[MAX_N]; int N, M; v

The Suspects——并查集求联通块数量的模板题

题目链接 题意: n个学生分属m个团体,一个学生可以属于多个团体.一个学生疑似患病,则他所属的整个团体都疑似患病.已知0号疑似患病,以及每个团体都有哪些学生构成,求一共有多少个学生疑似患病 题解: 很经典的并查集的题目,找一个num[]数组记录每一个以当前下标为根节点的集合的个体数目,最后输出0号的根节点对应的num值,就是0号学生所在团体的人数. 代码: #include<iostream> #include<stdio.h> #include<math.h> usi

POJ 1611 The Suspects (并查集)

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 25130   Accepted: 12313 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T

The Suspects(并查集求节点数)

The Suspects Time Limit: 1000MS   Memory Limit: 20000K Total Submissions: 28164   Accepted: 13718 Description Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. T

POJ1611 The Suspects: 并查集入门

#include<iostream> using namespace std; #define Size 30000 int Pre[Size+1], Sum[Size+1];// Sum[i] 表示 第i组 的人数 int Get_Pre( int a ) { if( Pre[a]!=a ) a = Get_Pre( Pre[a] );// 路径压缩 return a; } void Union( int a, int b ) { int P1 = Get_Pre(a); int P2 =