hdu 5131 Song Jiang's rank list (水题)

Song Jiang‘s rank list

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 253    Accepted Submission(s): 128

Problem Description

《Shui Hu Zhuan》,also 《Water Margin》was written by Shi Nai‘an -- an writer of Yuan and Ming dynasty. 《Shui Hu Zhuan》is one of the Four Great Classical Novels of Chinese literature. It tells a story about 108 outlaws. They came from
different backgrounds (including scholars, fishermen, imperial drill instructors etc.), and all of them eventually came to occupy Mout Liang(or Liangshan Marsh) and elected Song Jiang as their leader.

In order to encourage his military officers, Song Jiang always made a rank list after every battle. In the rank list, all 108 outlaws were ranked by the number of enemies he/she killed in the battle. The more enemies one killed, one‘s rank is higher. If two
outlaws killed the same number of enemies, the one whose name is smaller in alphabet order had higher rank. Now please help Song Jiang to make the rank list and answer some queries based on the rank list.

Input

There are no more than 20 test cases.

For each test case:

The first line is an integer N (0<N<200), indicating that there are N outlaws.

Then N lines follow. Each line contains a string S and an integer K(0<K<300), meaning an outlaw‘s name and the number of enemies he/she had killed. A name consists only letters, and its length is between 1 and 50(inclusive). Every name is unique.

The next line is an integer M (0<M<200) ,indicating that there are M queries.

Then M queries follow. Each query is a line containing an outlaw‘s name.

The input ends with n = 0

Output

For each test case, print the rank list first. For this part in the output ,each line contains an outlaw‘s name and the number of enemies he killed.

Then, for each name in the query of the input, print the outlaw‘s rank. Each outlaw had a major rank and a minor rank. One‘s major rank is one plus the number of outlaws who killed more enemies than him/her did.One‘s minor rank is one plus the number of outlaws
who killed the same number of enemies as he/she did but whose name is smaller in alphabet order than his/hers. For each query, if the minor rank is 1, then print the major rank only. Or else Print the major rank, blank , and then the minor rank. It‘s guaranteed
that each query has an answer for it.

Sample Input

5
WuSong 12
LuZhishen 12
SongJiang 13
LuJunyi 1
HuaRong 15
5
WuSong
LuJunyi
LuZhishen
HuaRong
SongJiang
0

Sample Output

HuaRong 15
SongJiang 13
LuZhishen 12
WuSong 12
LuJunyi 1
3 2
5
3
1
2

题意: 给你n个人,然后下面 n 行告诉你这 n 个人的姓名和杀人数 。再给你一个 m ,表示

m 个询问。下面 m 行表示询问人的姓名 。

输出: 首先按照杀人数从大到小输出,当杀人数相同,按名字字典序从小到大规则输出。

然后对于每一个询问的名字,输出杀人数大于他自己的人的个数 +1 ;之后输出名字的字典序

小于他自己并且杀人数相同人数+1,如果这个数为1则不用输出。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string>
#include <map>
using namespace std;
const int maxn=210;

struct node
{
    string str;
    int ran;
}a[maxn];

int n,m;
string q[maxn];
map <string ,int > mp;

bool judge(node p,node q)
{
     if(p.ran==q.ran)  return p.str<q.str;
     return p.ran>q.ran;
}

void input()
{
    mp.clear();
    for(int i=0;i<n;i++)
    {
        cin>>a[i].str>>a[i].ran;
        mp[a[i].str]=a[i].ran;
    }
    cin>>m;
    for(int i=0;i<m;i++)  cin>>q[i];
}

void solve()
{
    sort(a,a+n,judge);
    for(int i=0;i<n;i++)  cout<<a[i].str<<" "<<a[i].ran<<endl;
    for(int i=0;i<m;i++)
    {
         int num=mp[q[i]],cnt=0,coun=1;
         for(int j=0;j<n;j++)
         {
             if(a[j].ran>num)   coun++;
             if(a[j].ran==num)  cnt++;
             if(a[j].str==q[i])  break;
         }
         if(cnt>1)  cout<<coun<<" "<<cnt<<endl;
         else   cout<<coun<<endl;
    }
}

int main()
{
     while(scanf("%d",&n)!=EOF)
     {
         if(n==0)  break;
         input();
         solve();
     }
     return 0;
}

hdu 5131 Song Jiang's rank list (水题)

时间: 2024-08-13 17:35:15

hdu 5131 Song Jiang's rank list (水题)的相关文章

HDU 5131 Song Jiang&#39;s rank list(水题)

Song Jiang's rank list Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 259    Accepted Submission(s): 134 Problem Description <Shui Hu Zhuan>,also <Water Margin>was written by Shi Nai'

hdu 5131 Song Jiang&#39;s rank list(模拟)

Song Jiang's rank list Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 662    Accepted Submission(s): 329 Problem Description <Shui Hu Zhuan>,also <Water Margin>was written by Shi Nai'

[ACM] HDU 5131 Song Jiang&#39;s rank list (模拟)

Song Jiang's rank list Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 36    Accepted Submission(s): 18 Problem Description <Shui Hu Zhuan>,also <Water Margin>was written by Shi Nai'an

HDU 5131 Song Jiang&#39;s rank list (结构体+MAP,2014广州现场赛)

题目链接:HDU 5131 Song Jiang's rank list 题意:对给出的好汉按杀敌数从大到小排序,若相等,按字典序排.M个询问,询问名字输出对应的主排名和次排名.(排序之后)主排名是在该名字前比他杀敌数多的人的个数加1,次排名是该名字前和他杀敌数相等的人的个数加1,(也就是杀敌数相等,但是字典序比他小的人数加1). AC代码: #include <stdio.h> #include <string> #include <map> #include <

hdu 5131 Song Jiang&#39;s rank list

题目连接 http://acm.hdu.edu.cn/showproblem.php?pid=5131 Song Jiang's rank list Description <Shui Hu Zhuan>,also <Water Margin>was written by Shi Nai'an -- an writer of Yuan and Ming dynasty. <Shui Hu Zhuan>is one of the Four Great Classical

HDU 5131 Song Jiang&#39;s rank list(排序)

题意看样例就可以了啊. 简单的二级排序+暴力查询. Song Jiang's rank list Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 264    Accepted Submission(s): 137 Problem Description <Shui Hu Zhuan>,also <Water Margin&

HDOJ 5131 Song Jiang&#39;s rank list 水

水排序 Song Jiang's rank list Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 71    Accepted Submission(s): 39 Problem Description <Shui Hu Zhuan>,also <Water Margin>was written by Shi Na

hdoj 5131 Song Jiang&#39;s rank list 【模拟】

Song Jiang's rank list Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others) Total Submission(s): 653    Accepted Submission(s): 323 Problem Description <Shui Hu Zhuan>,also <Water Margin>was written by Shi Nai'

【HDOJ】5131 Song Jiang&#39;s rank list

STL的使用. 1 /* 5131 */ 2 #include <iostream> 3 #include <map> 4 #include <cstdio> 5 #include <cstdlib> 6 #include <cstring> 7 #include <string> 8 #include <algorithm> 9 using namespace std; 10 11 #define MAXN 205 12