1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N?1?? a?N?1???? N?2?? a?N?2???? ... N?K?? a?N?K????

where K is the number of nonzero terms in the polynomial, N?i?? and a?N?i???? (,) are the exponents and coefficients, respectively. It is given that 1, 0.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
double a[1001] = { 0.0 }, b[1001] = { 0.0 }, c[2001] = { 0.0 };

int main() {
    int k;
    cin >> k;
    int i, j;
    while (k--) {
        cin >> i;
        cin >> a[i];
    }
    cin >> k;
    while (k--) {
        cin >> i;
        cin >> b[i];
    }

    for (i = 0; i <= 1000; i++) {
        for (j = 0; j <= 1000; j++) {
            c[i+j] += a[i] * b[j];
        }
    }
    int cnt = 0;
    char str[1000] = "", str1[100];
    for (i = 2000; i >= 0; i--) {
        if (c[i] != 0.0) {
            sprintf(str1, " %d %0.1lf", i, c[i]);
            strcat(str, str1);
            cnt++;
        }
    }
    cout << cnt << str;

}

原文地址:https://www.cnblogs.com/TBhacker/p/11293774.html

时间: 2024-09-28 21:58:45

1009 Product of Polynomials (25 分)的相关文章

1009 Product of Polynomials (25分) 多项式乘法

1009 Product of Polynomials (25分) This time, you are supposed to find A×B where A and B are two polynomials. Input Specification: Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomi

[PTA] PAT(A) 1009 Product of Polynomials (25 分)

目录 Problem Description Input Output Sample Sample Input Sample Output Solution Analysis Code Result Problem portal:1009 Product of Polynomials Description Input Output Sample Sample Input Sample Output Solution Analysis Code #include <bits/stdc++.h>

PAT Advanced 1009 Product of Polynomials (25分)

This time, you are supposed to find A×B where A and B are two polynomials. Input Specification: Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N?1?? a?N?1???? N?2?? a?N?2?

1009 Product of Polynomials (25)(25 分)

1009 Product of Polynomials (25)(25 分) This time, you are supposed to find A*B where A and B are two polynomials. Input Specification: Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a pol

PAT 1009. Product of Polynomials (25)

1009. Product of Polynomials (25) This time, you are supposed to find A*B where A and B are two polynomials. Input Specification: Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomi

1009. Product of Polynomials (25)——PAT (Advanced Level) Practise

题目信息: 1009. Product of Polynomials (25) 时间限制 400 ms 内存限制 32000 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue This time, you are supposed to find A*B where A and B are two polynomials. Input Specification: Each input file contains one test case. Each c

1009 Product of Polynomials (25)(25 point(s))

problem This time, you are supposed to find A*B where A and B are two polynomials. Input Specification: Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ..

1009. Product of Polynomials (25)

1 #include <stdio.h> 2 3 struct MyStruct 4 { 5 int exp; 6 double coe; 7 }; 8 9 int main() 10 { 11 int k1,k2,i,j; 12 MyStruct ans1[10],ans2[10]; 13 double dans[2001]; //两个 最高幂相乘 , 最高幂为2000 14 while(scanf("%d",&k1)!=EOF) 15 { 16 for(i=0;

PAT (Advanced Level) 1009. Product of Polynomials (25)

简单模拟. #include<iostream> #include<cstring> #include<cmath> #include<algorithm> #include<cstdio> using namespace std; double a[3000],b[3000],c[3000]; int k; int main() { for(int i=0;i<=2000;i++) a[i]=b[i]=c[i]=0; int Max=-1