Sorting It All Out (拓扑排序+思维)

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.代码:
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#include<vector>
#include<map>
#include<cmath>
const int maxn=1e5+5;
typedef long long ll;
using namespace std;
vector<int>vec[30];
int n,m;
int du[30];
int chu[30];
int du1[30];
int flag;
vector<int>ans1;
void Tpsort()
{
    priority_queue<int,vector<int>,greater<int> >q;
    priority_queue<int>q1;

    int s=0;
    for(int t=0;t<n;t++)
    {
        if(chu[t]==0&&du[t]==0)
        {
         s=1;
        }
    }
    for(int t=0;t<n;t++)
    {
        du1[t]=du[t];
    }
    for(int t=0;t<n;t++)
    {
        if(du1[t]==0)
        {
            q.push(t);
            q1.push(t);
        }
    }
    vector<int>ans,ans2;
    while(!q.empty())
    {
        int now=q.top();
        int now2=q1.top();
        q.pop();
        q1.pop();
        ans.push_back(now);
        ans2.push_back(now2);
        for(int t=0;t<vec[now].size();t++)
        {
            int next=vec[now][t];
            du1[next]--;
            if(du1[next]==0)
            {
                q.push(next);
                q1.push(next);
            }
        }
    }
    if(ans.size()!=n)
    {
        flag=1;
    }
//    cout<<ans.size()<<" "<<s<<endl;

    if(ans.size()==n&&s==0)
    {
        int sss=0;
        for(int t=0;t<ans.size();t++)
        {
            if(ans[t]!=ans2[t])
            {
                sss=1;
            }
        }
        if(sss==0)
        {
            flag=2;
            for(int t=0;t<ans.size();t++)
            {
                ans1.push_back(ans[t]);
            }
        }

    }

}
int main()
{ 

   while(cin>>n>>m)
   {
    if(n==0&&m==0)
    {
        break;
    }
    for(int t=0;t<n;t++)
    {
        vec[t].clear();
    }
       char str[5];
       memset(du,0,sizeof(du));
       memset(chu,0,sizeof(chu));
       flag=0;
       int ss=0;
       int k;
       ans1.clear();
       for(int t=1;t<=m;t++)
       {
           scanf("%s",str);
           vec[str[0]-‘A‘].push_back(str[2]-‘A‘);
           du[str[2]-‘A‘]++;
           chu[str[0]-‘A‘]++;
           if(ss)
           {
           continue;
        }
           Tpsort();
           if(flag==1)
           {
               printf("Inconsistency found after %d relations.\n",t);
               ss=1;
        }
        else if(flag==2)
        {
            ss=1;
            printf("Sorted sequence determined after %d relations: ",t);
            for(int j=0;j<n;j++)
            {
                printf("%c",ans1[j]+‘A‘);
            }
            printf(".\n");

        }
    }
    if(ss==0)
    puts("Sorted sequence cannot be determined.");

   }
   return 0;
}

原文地址:https://www.cnblogs.com/Staceyacm/p/11261298.html

时间: 2024-11-09 03:13:17

Sorting It All Out (拓扑排序+思维)的相关文章

Sorting It All Out 拓扑排序+确定点

这一道题的话  数据有一点问题    ........     例如 不过 还是   能理解一下  试试吧  ......... 3 5 A<B B<C C<A A<C B<A 这几组数据 明显反映出来 这是成环的 , 然后 按照 输入输出案例来说 这个是 有序的 ABC 题目要求     在每组数据的   第一行  给你需要排序 的 字母数    和  他们之间的关系数量      然后  输入每组数据    你首先许亚萍判断在输入  第几组 数据的时候 出现了 环    

nyoj349 poj1094 Sorting It All Out(拓扑排序)

nyoj349   http://acm.nyist.net/JudgeOnline/problem.php?pid=349poj1094   http://poj.org/problem?id=1094这两个题是一样的,不过在poj上A了才算真的过,ny上数据有一点弱. 题目大意输入n,m. 一共有n个字母(从A开始), m行语句每个语句“x﹤y”,说明x,y之间的偏序关系.让你判断是否可以通过这些关系得到一个唯一的升序序列,若能则输出这个序列并指出通过前多少条语句得出的,如果n个字母间存在矛

nyoj Sorting It All Out (拓扑排序)

三种情况分别是: 1. 在某位置可以确定拓扑排序. 2. 在某位置出现了环 3. 到最后都不能确定拓扑排序(某一位置入度为0的点有多个),可以续输入执行下去. 每输入一组数据都要做一次判断 1 #include<cstdio> 2 #include<cstring> 3 #include<vector> 4 #include<queue> 5 using namespace std; 6 const int N = 105; 7 int n, m, in[N

POJ 1094 Sorting It All Out 拓扑排序

Sorting It All Out Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%lld & %llu Description An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to

POJ1094 Sorting It All Out 拓扑排序(深搜)

题意:给定n和m,n表示大写字母的前n个,m表示m个关系对,求能否确定唯一排序. 分析:分三种情况 (1)当输入完当前的关系对之后,已经能确定矛盾(不需要完全输入m个关系对时) eg. 3 3       A<B       B<A         B<C       当输入到第二对已经能判断矛盾,此时记下当前的所需要用到的关系对数ans=2:       接着输入,但是后面的关系对不作处理 (2) 当输入完当前的关系对之后,已经能确定唯一排序(不需要完全输入m个关系对,    但是必须

zoj 1060 Sorting It All Out(拓扑排序)

#include<bits/stdc++.h> using namespace std; vector< vector<char> >v; int n,m,use[30],cnt[30]; char ans[30],s[10]; int topsort(int x) { int i,j,t[30],f=1,r,c; memset(ans,0,sizeof(ans)); for(i=0; i<30; i++) t[i]=cnt[i]; c=0; r=0; while

数据结构--图(下)--拓扑排序

拓扑排序 思维导图也是图的一种 拓扑序:如果图中从V到W有一条有向路径,则V一定排在W之前.满足此条件的顶点排序成为一个拓扑序.  V->W 获得一个拓扑序的过程就是拓扑排序 AOV如果有合理的拓扑序,则必定是有向无环图(Directed Acyclic Graph,简称DAG). 第一排没有预修课程的课.然后抹掉顶点和边, 每一次输出哪个顶点呢,没有前驱顶点,就输出(入度为0的顶点). 最后的拓扑序就产生了 DAG有向无环图. 拓扑排序的应用 AOE(Activity On Edge)网络  

[ACM] POJ 1094 Sorting It All Out (拓扑排序)

Sorting It All Out Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 26801   Accepted: 9248 Description An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from sm

POJ 1094 Sorting It All Out【floyd传递闭包+拓扑排序】

Sorting It All Out Time Limit: 1000MS Memory Limit: 10000K Total Submissions: 31994 Accepted: 11117 Description An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from small