1654: [Usaco2006 Jan]The Cow Prom 奶牛舞会

1654: [Usaco2006 Jan]The Cow Prom 奶牛舞会

Time Limit: 5 Sec  Memory Limit: 64 MB
Submit: 471  Solved: 339
[Submit][Status][Discuss]

Description

The
N (2 <= N <= 10,000) cows are so excited: it‘s prom night! They
are dressed in their finest gowns, complete with corsages and new shoes.
They know that tonight they will each try to perform the Round Dance.
Only cows can perform the Round Dance which requires a set of ropes and a
circular stock tank. To begin, the cows line up around a circular stock
tank and number themselves in clockwise order consecutively from 1..N.
Each cow faces the tank so she can see the other dancers. They then
acquire a total of M (2 <= M <= 50,000) ropes all of which are
distributed to the cows who hold them in their hooves. Each cow hopes to
be given one or more ropes to hold in both her left and right hooves;
some cows might be disappointed. For the Round Dance to succeed for any
given cow (say, Bessie), the ropes that she holds must be configured
just right. To know if Bessie‘s dance is successful, one must examine
the set of cows holding the other ends of her ropes (if she has any),
along with the cows holding the other ends of any ropes they hold, etc.
When Bessie dances clockwise around the tank, she must instantly pull
all the other cows in her group around clockwise, too. Likewise, if she
dances the other way, she must instantly pull the entire group
counterclockwise (anti-clockwise in British English). Of course, if the
ropes are not properly distributed then a set of cows might not form a
proper dance group and thus can not succeed at the Round Dance. One way
this happens is when only one rope connects two cows. One cow could pull
the other in one direction, but could not pull the other direction
(since pushing ropes is well-known to be fruitless). Note that the cows
must Dance in lock-step: a dangling cow (perhaps with just one rope)
that is eventually pulled along disqualifies a group from properly
performing the Round Dance since she is not immediately pulled into
lockstep with the rest. Given the ropes and their distribution to cows,
how many groups of cows can properly perform the Round Dance? Note that a
set of ropes and cows might wrap many times around the stock tank.

约翰的N(2≤N≤10000)只奶牛非常兴奋,因为这是舞会之夜!她们穿上礼服和新鞋子,别上鲜花,她们要表演圆舞.

只有奶牛才能表演这种圆舞.圆舞需要一些绳索和一个圆形的水池.奶牛们围在池边站好,顺时针顺序由1到N编号.每只奶牛都面对水池,这样她就能看到其他的每一只奶牛.为了跳这种圆舞,她们找了M(2≤M≤50000)条绳索.若干只奶牛的蹄上握着绳索的一端,绳索沿顺时针方绕过水池,另一端则捆在另一些奶牛身上.这样,一些奶牛就可以牵引另一些奶牛.有的奶牛可能握有很多绳索,也有的奶牛可能一条绳索都没有对于一只奶牛,比如说贝茜,她的圆舞跳得是否成功,可以这样检验:沿着她牵引的绳索,找到她牵引的奶牛,再沿着这只奶牛牵引的绳索,又找到一只被牵引的奶牛,如此下去,若最终能回到贝茜,则她的圆舞跳得成功,因为这一个环上的奶牛可以逆时针牵引而跳起旋转的圜舞.如果这样的检验无法完成,那她的圆舞是不成功的.

如果两只成功跳圆舞的奶牛有绳索相连,那她们可以同属一个组合.

给出每一条绳索的描述,请找出,成功跳了圆舞的奶牛有多少个组合?

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains
two space-separated integers A and B that describe a rope from cow A to
cow B in the clockwise direction.

第1行输入N和M,接下来M行每行两个整数A和B,表示A牵引着B.

Output

* Line 1: A single line with a single integer that is the number of groups successfully dancing the Round Dance.

成功跳圆舞的奶牛组合数.

Sample Input

5 4
2 4
3 5
1 2
4 1

INPUT DETAILS:

ASCII art for Round Dancing is challenging. Nevertheless, here is a
representation of the cows around the stock tank:
_1___
/**** \
5 /****** 2
/ /**TANK**|
\ \********/
\ \******/ 3
\ 4____/ /
\_______/

Sample Output

1

思路;

  统计点数不为一的强连通分量数量即可, !******!

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <stack>
#include <cctype>
#define ms(a) (memset(a, 0, sizeof(a)))
#define min(a, b) (a<b?a:b)
using namespace std;
const int N = 111000, M = 310100;
int head[N], to[M], nxt[M], cnt;
int dfn[N], low[N], place[N], tot;
int ins[N], idx;
int ind[N];
stack<int>s;
int x[M], y[M];
int num[N];
inline char nc() {
    static char buf[100000], *p1, *p2;
    return p1 == p2 && (p2 = (p1 = buf) + fread(buf, 1, 100000 ,stdin), p1==p2)?EOF:*p1++;
}
inline char gc() {
    char c = nc();
    while(isspace(c)) c = nc();
    return c;
}
inline int read() {
    int x ;
    scanf("%d", &x);
    return x; /*char c = nc();
    while(!isdigit(c))c=nc();
    while(isdigit(c)) {x=(x<<3)+(x<<1)+(c^48), c=nc();}
    return x;*/
}
void add(int x, int y) {
    to[++cnt] = y;
    nxt[cnt] = head[x];
    head[x] = cnt;
}
void Tarjan(int p) {
    dfn[p] = low[p] = ++idx;
    s.push(p);
    ins[p] = 1;
    for(int i=head[p];i;i=nxt[i]) {
        if(!dfn[to[i]]) {
            Tarjan(to[i]);
            low[p] = min(low[p], low[to[i]]);
        }
        else if(ins[to[i]]) {
            low[p] = min(low[p], dfn[to[i]]);
        }
    }
    if(low[p]==dfn[p]) {
        tot++;
        int t = 0;
        while(t!=p) {
            t = s.top();s.pop();
            ins[t] = 0;
            place[t] = tot;
            num[tot]++;
        }
    }
}
int main() {
    int n = read(), m = read();
    for(int i=1;i<=m;i++) {
        x[i] = read(), y[i] = read();
        add(x[i], y[i]);
    }
    for(int i=1;i<=n;i++) if(!dfn[i]) Tarjan(i);
    int ans = 0;
    for(int i=1;i<=tot;i++) {
        if(num[i]>1)ans++;
    }
    printf("%d\n", ans);
}

原文地址:https://www.cnblogs.com/Tobichi/p/9230903.html

时间: 2024-08-28 22:21:39

1654: [Usaco2006 Jan]The Cow Prom 奶牛舞会的相关文章

bzoj:1654: [Usaco2006 Jan]The Cow Prom 奶牛舞会

Description The N (2 <= N <= 10,000) cows are so excited: it's prom night! They are dressed in their finest gowns, complete with corsages and new shoes. They know that tonight they will each try to perform the Round Dance. Only cows can perform the

bzoj 1654: [Usaco2006 Jan]The Cow Prom 奶牛舞会【tarjan】

几乎是板子,求有几个size>1的scc 直接tarjan即可 #include<iostream> #include<cstdio> #include<cstring> using namespace std; const int N=10005; int n,m,h[N],cnt,ans,tmp,dfn[N],low[N],s[N],top; bool v[N]; struct qwe { int ne,to; }e[N*10]; int read() { i

【BZOJ1654】[Usaco2006 Jan]The Cow Prom 奶牛舞会 赤果果的tarjan

Description The N (2 <= N <= 10,000) cows are so excited: it's prom night! They are dressed in their finest gowns, complete with corsages and new shoes. They know that tonight they will each try to perform the Round Dance. Only cows can perform the

【强连通分量】Bzoj1654 [Usaco2006 Jan]The Cow Prom 奶牛舞会

Description 约翰的N(2≤N≤10000)只奶牛非常兴奋,因为这是舞会之夜!她们穿上礼服和新鞋子,别上鲜花,她们要表演圆舞. 只有奶牛才能表演这种圆舞.圆舞需要一些绳索和一个圆形的水池.奶牛们围在池边站好,顺时针顺序由1到N编号.每只奶牛都面对水池,这样她就能看到其他的每一只奶牛.为了跳这种圆舞,她们找了M(2≤M≤50000)条绳索.若干只奶牛的蹄上握着绳索的一端,绳索沿顺时针方绕过水池,另一端则捆在另一些奶牛身上.这样,一些奶牛就可以牵引另一些奶牛.有的奶牛可能握有很多绳索,也有

BZOJ1654 [Usaco2006 Jan]The Cow Prom 奶牛舞会

看不懂题,蒟蒻中文英文都太差了... 于是Orz itwiiioi巨巨! 结果终于理解了:就是求有向图非单点的强连通分量个数. tarjan妥妥的...(板子*1 get√) 1 /************************************************************** 2 Problem: 1654 3 User: rausen 4 Language: C++ 5 Result: Accepted 6 Time:32 ms 7 Memory:1476 kb

P1654: [Usaco2006 Jan]The Cow Prom 奶牛舞会

裸的强连通 1 const maxe=50001; 2 type 3 node=record 4 f,t:longint; 5 end; 6 var n,m,dgr,i,u,v,num,ans:longint; 7 bfsdgr,low,head,f:array[0..maxe] of longint; 8 b:array[0..maxe] of node; 9 p:array[0..maxe] of boolean; 10 procedure insert(u,v:longint); 11 b

[USACO06JAN]牛的舞会The Cow Prom

[USACO06JAN]牛的舞会The Cow Prom 题目描述 The N (2 <= N <= 10,000) cows are so excited: it's prom night! They are dressed in their finest gowns, complete with corsages and new shoes. They know that tonight they will each try to perform the Round Dance. Only

P2863 [USACO06JAN]牛的舞会The Cow Prom

洛谷——P2863 [USACO06JAN]牛的舞会The Cow Prom 题目描述 The N (2 <= N <= 10,000) cows are so excited: it's prom night! They are dressed in their finest gowns, complete with corsages and new shoes. They know that tonight they will each try to perform the Round D

[BZOJ1648][Usaco2006 Dec]Cow Picnic 奶牛野餐

1648: [Usaco2006 Dec]Cow Picnic 奶牛野餐 Time Limit: 5 Sec  Memory Limit: 64 MB Submit: 781  Solved: 483 [Submit][Status][Discuss] Description The cows are having a picnic! Each of Farmer John's K (1 <= K <= 100) cows is grazing in one of N (1 <= N &