(string高精度)A + B Problem II hdu1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 399645    Accepted Submission(s): 77352

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2

1 2

112233445566778899 998877665544332211

Sample Output

Case 1:

1 + 2 = 3

Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110

用JAVA

import java.math.BigInteger;
import java.util.Scanner;
public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int n;
        BigInteger a,b;
        n=in.nextInt();
        int i=0;
        while(n>0) {
            n--;
            a=in.nextBigInteger();
            b=in.nextBigInteger();
            i++;
            System.out.println("Case" + " " + i + ":");
            if(n>0) {
                System.out.println(a + " + " + b + " = "+a.add(b));
                System.out.println();
            }
            else {
                System.out.println(a + " + " + b + " = "+a.add(b));
            }
        }
    }
}

C++:

要审清题意,注意输出格式!
#include<string>
#include <cstdio>
#include<iostream>
using namespace std;
string add(string a,string b)
{
    int len1=a.length();
    int len2=b.length();
    if(len1>len2)
    {
        for(int i=1;i<=len1-len2;i++)
            b="0"+b;
    }
    else
    {
        for(int i=1;i<=len2-len1;i++)
            a="0"+a;
    }
    int len=a.length();
    int cf=0,t;
    string str;
    for(int i=len-1;i>=0;i--)
    {
        t=a[i]-‘0‘+b[i]-‘0‘+cf;
        cf=t/10;
        t%=10;
        str=char(t+‘0‘)+str;
    }
    if(cf!=0)
        str=char(cf+‘0‘)+str;
    return str;
}
int main()
{
    int t;
    cin>>t;
    int k=0;
    while(t--)
    {
        k++;
        string a,b;
        cin>>a>>b;
        string str;
        str=add(a,b);
        cout<<"Case "<<k<<":"<<endl;
        cout<<a<<" + "<<b<<" = "<<str<<endl;
        if(t)
            cout<<endl;
    }
    return 0;
}

原文地址:https://www.cnblogs.com/Weixu-Liu/p/9165365.html

时间: 2024-10-12 17:40:01

(string高精度)A + B Problem II hdu1002的相关文章

hdoj 1002 A + B Problem II 高精度 java

A + B Problem II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 241933    Accepted Submission(s): 46646 Problem Description I have a very simple problem for you. Given two integers A and B, you

hdoj 1023 Train Problem II 【卡特兰】+【高精度】

题意:询问有多少种进站出站的顺序. 经典卡特兰.我对卡特兰目前的认识就是有n个1和n个-1,组成一个为2n的数列的方式有多少种.这就跟火车进站出站类似, 至于具体的卡特兰数的介绍,百度解释的很详细. 代码1(c语言): /* h(n) = h(n-1)*(4*n-2)/(n+1); */ #include <stdio.h> #include <string.h> #define M 110 int s[M][M] = {0}, b[M]; void init(){ s[1][0]

hdu1002 A + B Problem II(大数题)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1002 A + B Problem II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 230247    Accepted Submission(s): 44185 Problem Description I have a very sim

HDU1002 -A + B Problem II(大数a+b)

A + B Problem II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 315214    Accepted Submission(s): 61139 Problem Description I have a very simple problem for you. Given two integers A and B, you

HDU1002 A + B Problem II 大数问题

题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=1002 A + B Problem II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 409136    Accepted Submission(s): 79277 Problem Description I have a very si

C - Train Problem II——(HDU 1023 Catalan 数)

传送门 Train Problem II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7616    Accepted Submission(s): 4101 Problem Description As we all know the Train Problem I, the boss of the Ignatius Train

杭电1023Train Problem II

地址:http://acm.hdu.edu.cn/showproblem.php?pid=1023 题目: Train Problem II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 7675    Accepted Submission(s): 4131 Problem Description As we all know the

Train Problem II 卡特兰裸题(入门题)

Train Problem II  题目大意:给你一个数n,表示有n辆火车,编号从1到n,从远方驶过来,问你有多少种出站的可能. 解题思路:模拟栈的问题而已.  卡特兰问题. 1 import java.math.*; 2 import java.util.*; 3 import java.io.*; 4 5 public class Main 6 { 7 static int MS=101; 8 public static void main(String[] args) 9 { 10 Sca

hdoj 1002 A + B Problem II

A + B Problem II Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 242959    Accepted Submission(s): 46863 Problem Description I have a very simple problem for you. Given two integers A and B, you