C# 移除字符串头尾指定字符

 1  private void button1_Click(object sender, EventArgs e)
 2         {//去掉字符串头尾指定字符
 3             string MyInfo= "--中华人民共和国--";
 4             //显示 "中华人民共和国"
 5             MessageBox.Show(MyInfo.Trim(new char[1] { ‘-‘ }), "信息提示", MessageBoxButtons.OK, MessageBoxIcon.Information);
 6             MyInfo = ",-中华人民共和国-,-";
 7             //显示 "中华人民共和国"
 8             MessageBox.Show(MyInfo.Trim(new char[2] { ‘-‘, ‘,‘ }), "信息提示", MessageBoxButtons.OK, MessageBoxIcon.Information);
 9             MyInfo = "--中华人民共和国--";
10             //显示 "中华人民共和国--"
11             MessageBox.Show(MyInfo.TrimStart(new char[1] { ‘-‘ }), "信息提示", MessageBoxButtons.OK, MessageBoxIcon.Information);
12             MyInfo = ",-中华人民共和国-,-";
13             //显示 "中华人民共和国-,-"
14             MessageBox.Show(MyInfo.TrimStart(new char[2] { ‘-‘, ‘,‘ }), "信息提示", MessageBoxButtons.OK, MessageBoxIcon.Information);
15             MyInfo = "--中华人民共和国--";
16             //显示 "--中华人民共和国"
17             MessageBox.Show(MyInfo.TrimEnd(new char[1] { ‘-‘ }), "信息提示", MessageBoxButtons.OK, MessageBoxIcon.Information);
18             MyInfo = ",-中华人民共和国-,-";
19             //显示 ",-中华人民共和国"
20             MessageBox.Show(MyInfo.TrimEnd(new char[2] { ‘-‘, ‘,‘ }), "信息提示", MessageBoxButtons.OK, MessageBoxIcon.Information);
21         }

原文地址:https://www.cnblogs.com/Scholars/p/9162598.html

时间: 2024-10-10 08:47:14

C# 移除字符串头尾指定字符的相关文章

C# 移除字符串末尾指定字符

#region 移除字符串末尾指定字符 /// <summary> /// 移除字符串末尾指定字符 /// </summary> /// <param name="str">需要移除的字符串</param> /// <param name="value">指定字符</param> /// <returns>移除后的字符串</returns> public static s

JS trim去除字符串收尾指定字符

String.prototype.trim = function (char, type) { if (char) { if (type == 'left') { return this.replace(new RegExp('^\\'+char+'+', 'g'), ''); } else if (type == 'right') { return this.replace(new RegExp('\\'+char+'+$', 'g'), ''); } return this.replace(

统计字符串中指定字符的个数

输入一个字符串和一个字符,统计这个字符在字符串中出现的次数 输入格式: 输入2行.第1行是字符串,第2行是要查找的字符. 输出格式: 字符出现的次数 输入样例: abcdefgabcdefg a 输出样例: 2 a=input() b=input() def CountAa(s): return s.lower().count(b) if __name__ == "__main__": s = a print(CountAa(s)) 原文地址:https://www.cnblogs.c

struct模块拆分字符串为指定字符数的字符串或元组

import struct # unpack() parses the string to a tuple format = '1s2s1s1s' line = '12345' col = struct.unpack(format, line) print col # calcsize() returns the number of characters # in a given format string format = '30s30s20s1s' print struct.calcsize

移除字符串中的字符和移除字符串数组中的字符

/** * Remove a SASL mechanism from the list to be used. * * @param mech the SASL mechanism to be removed */ public static void removeSaslMech(String mech) { if( defaultMechs.contains(mech) ) { defaultMechs.remove(mech); } } /** * Remove a Collection

java字符串 删除指定字符的那些事

公司突然有这麽这需求: 1.算出2周以前的时间,以正常日期格式返回 2.如果月份和日期前面有0需要去掉返回结果,什么意思呢,比如:2017-08-15  就需要显示2017-8-15,你们说操蛋不,什么鬼需求,好了言归正传,直接撸代码. Calendar calendar = Calendar.getInstance();calendar.add(Calendar.DATE, -14);Date date = calendar.getTime();SimpleDateFormat sdf = n

iOS开发改变字符串中指定字符颜色,大小等等

NSString *strJTGZ = [NSString stringWithFormat:@"交通管制%d处 ",[jtgz intValue]]; NSMutableAttributedString *attributedStr = [[NSMutableAttributedString alloc]initWithString:strJTGZ]; [attributedStr addAttribute:NSForegroundColorAttributeName value:[

计算字符串中指定字符最大连续出现的次数

//连中次数public static int LzNum(String str) { // 分割成数组 char[] c = str.toCharArray(); // 定义一个记住最大次数的变量 int max = 0; // 循环比较 for (int i = 0; i < c.length; i++) { // 定义一个中间值 int is = 1;// 以为是两两比较所以中间会上一次,就像断木头一样,你想想哈 for (int j = i; j < c.length - 1; j++

删除或替换字符串中特定字符

1 replace( ) replace()函数只有三个参数,第三个参数是最大替代次数 特别注意replace()函数作用完后,并没有改变原字符串 参考:https://www.runoob.com/python/att-string-replace.html 2 strip( ) strip() 方法用于移除字符串头尾指定的字符(默认为空格或换行符)或字符序列 参考:https://www.runoob.com/python/att-string-strip.html 3 lstrip( )