(KMP 暴力)Corporate Identity -- hdu -- 2328

http://acm.hdu.edu.cn/showproblem.php?pid=2328

Corporate Identity

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 698    Accepted Submission(s): 281

Problem Description

Beside other services, ACM helps companies to clearly state their “corporate identity”, which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently asked ACM for a help with their new identity. IBM do not want to change their existing logos and trademarks completely, because their customers are used to the old ones. Therefore, ACM will only change existing trademarks instead of creating new ones.

After several other proposals, it was decided to take all existing trademarks and find the longest common sequence of letters that is contained in all of them. This sequence will be graphically emphasized to form a new logo. Then, the old trademarks may still be used while showing the new identity.

Your task is to find such a sequence.

Input

The input contains several tasks. Each task begins with a line containing a positive integer N, the number of trademarks (2 ≤ N ≤ 4000). The number is followed by N lines, each containing one trademark. Trademarks will be composed only from lowercase letters, the length of each trademark will be at least 1 and at most 200 characters.

After the last trademark, the next task begins. The last task is followed by a line containing zero.

Output

For each task, output a single line containing the longest string contained as a substring in all trademarks. If there are several strings of the same length, print the one that is lexicographically smallest. If there is no such non-empty string, output the words “IDENTITY LOST” instead.

Sample Input

3

aabbaabb

abbababb

bbbbbabb

2

xyz

abc

0

Sample Output

abb
IDENTITY LOST

其实就是一个暴力解决的问题,以我现在的程度只能暴力,可是我也想写个更好的方法呀,下次一定要学

可坑了,我没有给我的存子串的串赋初值,导致我在用strcmp的时候老是出错,弄的我稀里糊涂的写了个Judge函数用来比较串,可道理是一样的呀,于是又wa了,还好在队友的帮助下找到了,初值这个问题不知道害了我多少次,可我还往里面跳,以后要更加注意了,有的错找不出来了,可以往初值上想想,另外以后要注意赋初值

代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;

#define M 40005
#define N 210

char s[M][N];
int Next[N];

void FindNext(char b[])
{
    int i=0, j=-1, blen=strlen(b);
    Next[0] = -1;

    while(i<blen)
    {
        if(j==-1 || b[i]==b[j])
            Next[++i] = ++j;
        else
            j = Next[j];
    }
}

int KMP(char a[], char b[])
{
    int i=0, j=0;
    int alen=strlen(a), blen=strlen(b);

    FindNext(b);

    while(i<alen)
    {
        while(j==-1 || (a[i]==b[j] && i<alen && j<blen))
            i++, j++;
        if(j==blen)
            return 1;
        j = Next[j];
    }
    return 0;
}

int main()
{
    int n;
    while(scanf("%d", &n), n)
    {
        int i, j, k, MinLen=1000, len;
        char ss[N];

        memset(s, 0, sizeof(s));

        for(i=0; i<n; i++)
        {
            scanf("%s", s[i]);
            len = strlen(s[i]);

            if(len<MinLen)
            {
                MinLen = len;
                memset(ss, 0, sizeof(ss));
                strcpy(ss, s[i]);
            }
        }

        char b[N]="{";
        int index=0;

        for(i=MinLen; i>0; i--)
        {
            for(j=0; j<=MinLen-i; j++)
            {
                char a[N];

                memset(a, 0, sizeof(a));

                strncpy(a, ss+j, i);

                for(k=0; k<n; k++)
                {
                    if(KMP(s[k], a)==0)
                        break;
                }

                if(k==n && strcmp(a, b)<0)
                {
                    index = i;
                    strcpy(b, a);
                }

                if(index && j==MinLen-i)
                    i=-1, j=1000;
            }
        }

        if(index)
            printf("%s\n", b);
        else
            printf("IDENTITY LOST\n");

    }
    return 0;
}

时间: 2024-10-05 19:55:16

(KMP 暴力)Corporate Identity -- hdu -- 2328的相关文章

Corporate Identity - HDU 2328(多串求共同子串)

题目大意:给你N(2-4000)个字符串,求出来他们的共同子串   分析:因为上次就说了再出现这种题就不用那种暴力的做法了,于是看了一些别的知识,也就是后缀树,把一个字符串的所有的后缀全部都加入字典树,然后用别的串去匹配,这样匹配的时候速度那是飕飕的啊,不过第一次我把前N-1个串的所有前缀搞进了字典树里面,然后想如果某个节点被访问N-1次,并且第N个串也能访问到此节点,那么这一定就是他们的共同子串了,不过总归是太天真,直接返回MLE,一细琢磨,想着最糟糕的情况也就是有8000(N)个串,每个串都

hdu 2328 Corporate Identity(kmp)

Problem Description Beside other services, ACM helps companies to clearly state their “corporate identity”, which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recentl

POJ 题目3450 Corporate Identity(KMP 暴力)

Corporate Identity Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 5493   Accepted: 2015 Description Beside other services, ACM helps companies to clearly state their "corporate identity", which includes company logo but also other

HDU - 2328 Corporate Identity

Description Beside other services, ACM helps companies to clearly state their "corporate identity", which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently a

hdu2328 Corporate Identity【string库使用】【暴力】【KMP】

Corporate Identity Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 3308    Accepted Submission(s): 1228 Problem Description Beside other services, ACM helps companies to clearly state their "cor

POJ 3450 Corporate Identity KMP题解

本题要求求一组字符串的最长公共子串,其实是灵活运用KMP快速求最长前缀. 注意肯爹的题意:要求按照字典顺序输出. 还有要提醒的就是:有人也是用KMP来解这道题,但是很多人都把KMP当成暴力法来用了,没有真正处理好细节,发挥KMP的作用.而通常这些人都大喊什么暴力法可以解决本题,没错,的确暴力法是可以解决本题的,本题的数据不大,但是请不要把KMP挂上去,然后写成暴力法了,那样会误导多少后来人啊. 建议可以主要参考我的getLongestPre这个函数,看看是如何计算最长前缀的. 怎么判断你是否把本

hdu2328 Corporate Identity 扩展KMP

Beside other services, ACM helps companies to clearly state their "corporate identity", which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently asked ACM for

POJ-3450 Corporate Identity (KMP+后缀数组)

Description Beside other services, ACM helps companies to clearly state their "corporate identity", which includes company logo but also other signs, like trademarks. One of such companies is Internet Building Masters (IBM), which has recently a

POJ 3450--Corporate Identity【KMP &amp;&amp; 暴力】

Corporate Identity Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 5696   Accepted: 2075 Description Beside other services, ACM helps companies to clearly state their "corporate identity", which includes company logo but also other