1094. The Largest Generation (25) 此题和六度空间一个道理,记录BFS的层次

1094. The Largest Generation (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family
members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID‘s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated
by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13

21 1 23

01 4 03 02 04 05

03 3 06 07 08

06 2 12 13

13 1 21

08 2 15 16

02 2 09 10

11 2 19 20

17 1 22

05 1 11

07 1 14

09 1 17

10 1 18

Sample Output:

9 4

//有同学用并查集也可以过的

//六度空间http://blog.csdn.net/u013167299/article/details/42321615

#include<iostream>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<queue>
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn=105;
const int inf=210000;
vector<int> g[maxn];
bool vis[maxn];
int lev=1;
int sum;
int ans=1;//ans=0的话第二个样例过不去,能找到这个错误,我也是醉了
void bfs(int s)
{
    queue<int> q;
    q.push(s);
    vis[s]=true;
    int tail;
    int last=s;
    int cnt=1;
    while(!q.empty())
    {
        int k=q.front();
        q.pop();
        int n=g[k].size();
        for(int i=0;i<n;i++)
        {
            if(!vis[g[k][i]])
            {
                q.push(g[k][i]);
                vis[g[k][i]]=true;
                tail=g[k][i];
                sum++;
            }
        }
        if(k==last)
        {
            last=tail;
            cnt++;
            if(ans<sum)
            {
                ans=sum;
                lev=cnt;
            }
            sum=0;
        }
    }
}

int main()
{
    int n,m,i,j,k,t;
    freopen("in.txt","r",stdin);
    scanf("%d%d",&n,&m);
    for(i=0;i<m;i++)
    {
        int id;
        cin>>id>>k;
        for(j=0;j<k;j++)
        {
            cin>>t;
            g[id].push_back(t);
            g[t].push_back(id);
        }
    }
    bfs(1);
    printf("%d %d\n",ans,lev);
    return 0;
}
时间: 2024-12-27 10:29:37

1094. The Largest Generation (25) 此题和六度空间一个道理,记录BFS的层次的相关文章

1094. The Largest Generation (25)【二叉树】——PAT (Advanced Level) Practise

题目信息 1094. The Largest Generation (25) 时间限制200 ms 内存限制65536 kB 代码长度限制16000 B A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the

1094. The Largest Generation (25)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population. Input Specification: Each input file contains one test ca

PAT (Advanced Level) 1094. The Largest Generation (25)

简单DFS. #include<cstdio> #include<cstring> #include<cmath> #include<algorithm> #include<map> #include<queue> #include<stack> #include<vector> using namespace std; const int maxn=200; int n,m; vector<int>

pat1094. The Largest Generation (25)

1094. The Largest Generation (25) 时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find

PAT 1094 The Largest Generation[bfs][一般]

1094 The Largest Generation(25 分) A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population. Input Specification: Ea

PAT 1094. The Largest Generation(BFS)

CODE: #include<cstdio> #include<cstring> #include<queue> using namespace std; bool mat[105][105]; bool root[105]; int n,m; int R; int cnt[105]; int ans1,ans2; struct TNode { int num; int level; }; void BFS() { queue<TNode> Q; TNode

1094 The Largest Generation

题意:略. 思路:层序遍历:在结点中增加一个数据域表示结点所在的层次. 代码: #include <cstdio> #include <queue> #include <vector> using namespace std; struct Node{ int layer; vector<int> child; }; vector<Node> tree(110); int level[110]={0}; int maxLevel=1,maxNum

The Largest Generation (25)(BFS)(PAT甲级)

#include<bits/stdc++.h>using namespace std;int n,m,l,t;int a[1307][137][67];int vis[1307][137][67];typedef struct{    int x,y,z;}node;int xx[6]={0,0,0,0,1,-1};int yy[6]={0,0,1,-1,0,0};int zz[6]={1,-1,0,0,0,0};node p;int bfs(int x,int y,int z){    qu

1094 The Largest Generation (25point(s)) Easy only once

基本思想: 层序遍历问题: 关键点: 无: #include<iostream> #include<stdlib.h> #include<stdio.h> #include<vector> #include<string> #include<math.h> #include<algorithm> #include<cstring> #include<map> #include<queue>