A Mathematical Curiosity

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 27597 Accepted Submission(s): 8787

Problem Description

Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n
<= 100.

Output

For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

Sample Input

1

10 1
20 3
30 4
0 0

Sample Output

Case 1: 2
Case 2: 4
Case 3: 5

源代码:

#include <stdio.h>
#include <stdlib.h>

int main()
{
  int i,t,n,m,a,b;
  int num,count;
  scanf("%d",&t);
  for(i = 0;i < t;i++)
  {
    num = 0;
    while(scanf("%d%d",&n,&m) && (m!=0 || n!=0))
    {
      num ++;
      count = 0;
      for(a = 1;a < n;a++)
        for(b = a+1;b < n;b++)
          if(((a*a + b*b + m)%(a*b)) == 0)
            count++;             
      printf("Case %d: %d\n",num,count);                        
    }
    if(i < t-1)//用于设置两个测试用例之间有一空行 
      printf("\n");                   
  }
  system("pause");
  return 0;    
}

时间: 2024-10-11 07:26:56

A Mathematical Curiosity的相关文章

Hdu 1017 A Mathematical Curiosity

 A Mathematical Curiosity Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 41387    Accepted Submission(s): 13311 Problem Description Given two integers n and m, count the number of pairs of inte

HDU 1017 A Mathematical Curiosity【看懂题意+穷举法】

//2014.10.17    01:19 //题意: //先输入一个数N,然后分块输入,每块输入每次2个数,n,m,直到n,m同一时候为零时 //结束,当a和b满足题目要求时那么这对a和b就是一组 //注意: //每一块的输出中间有一个回车 A Mathematical Curiosity Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s)

A Mathematical Curiosity(坑水题)

A Mathematical Curiosity Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 31228    Accepted Submission(s): 10004 Problem Description Given two integers n and m, count the number of pairs of inte

HDU 1017 A Mathematical Curiosity (数学)

A Mathematical Curiosity Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 25871    Accepted Submission(s): 8174 Problem Description Given two integers n and m, count the number of pairs of integ

A Mathematical Curiosity 水

A - A Mathematical Curiosity Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit Status Description Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +

HDU 1017A Mathematical Curiosity (暴力统计特殊要求个数)

传送门: http://acm.hdu.edu.cn/showproblem.php?pid=1017 A Mathematical Curiosity Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 47658    Accepted Submission(s): 15285 Problem Description Given two

HDUOJ A Mathematical Curiosity 1017

 此题不难就是输出格式麻烦 #include<stdio.h> int main(){ int T; scanf("%d",&T); while(T--) { int n,m,num=0; while(scanf("%d %d",&n,&m)&&n!=0) { int a,b,sum=0; for(a=1;a<100;++a) for(b=a+1;b<n;++b) { if((a*a+b*b+m)%

Hdu oj 1017 A Mathematical Curiosity

题目:点击打开链接 #include<stdio.h> int main() { int t; scanf("%d",&t); while(t--) { int a=0; int m,n; while(scanf("%d%d",&n,&m)) { if(m==0&&n==0) break; a++; int i,j,k,z=0; for(i=1;i<n;i++) for(j=i+1;j<n;j++)//

HDU 1017 A Mathematical Curiosity (输出格式,穷举)

#include<stdio.h> int main() { int N; int n,m; int a,b; int cas; scanf("%d",&N); while(N--) { cas=1;//必须在这儿初始化cas,坑 while(scanf("%d%d",&n,&m),n||m) { int count=0; for(a = 1; a < n; a++)//穷举法 { for(b = a + 1; b <