HDU1114 Piggy-Bank 【完全背包】

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11149    Accepted Submission(s): 5632

Problem Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has
any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay
everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility
is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank
that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled
with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency.
Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it‘s weight in grams.

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total
weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

题意:给定一个空储钱罐的重量和满储钱罐的重量。再给定一些硬币种类的价值和重量,每一种硬币都有无数个。问:在储钱罐里怎样放硬币能使得总价值最小且总重量正好和满储钱罐重量相等。

题解:完全背包入门题。状态转移方程为dp[i][j] = min(dp[i-1][j-k*w[i]]) 0<=k<=totalWeight/w[i],跟01背包一样,完全背包dp数组也可以压缩成一维数组。只不过内层循环要顺序,而01背包是逆序。

另外这题在初始化dp数组时有个陷阱:对于在函数外定义的数组,若对它使用memset(dp + 1, -1, sizeof(dp + 1));那么将只有一个元素被初始化为-1,其余的全为0.但是若是memset(dp, -1, sizeof(dp));数组就可以全部初始化为-1。

#include <stdio.h>
#include <string.h>

int dp[10002];

int main()
{
    int totalWeight, weight, val, n, t, i, j;
    scanf("%d", &t);
    while(t--){
        scanf("%d%d", &weight, &totalWeight);
        totalWeight -= weight;
        scanf("%d", &n);
        memset(dp + 1, -1, sizeof(int) * 10001);
        for(i = 1; i <= n; ++i){
            scanf("%d%d", &val, &weight);
            for(j = weight; j <= totalWeight; ++j){
                if(dp[j - weight] != -1){
                    if(dp[j] == -1 || dp[j] > dp[j - weight] + val)
                        dp[j] = dp[j - weight] + val;
                }
            }
        }
        if(dp[totalWeight] == -1) printf("This is impossible.\n");
        else printf("The minimum amount of money in thepiggy-bank is %d.\n",
			 dp[totalWeight]);
    }
    return 0;
}
时间: 2024-08-25 19:30:31

HDU1114 Piggy-Bank 【完全背包】的相关文章

BZOJ 1531: [POI2005]Bank notes( 背包 )

多重背包... ---------------------------------------------------------------------------- #include<bits/stdc++.h> #define rep(i, n) for(int i = 0; i < n; i++) #define clr(x, c) memset(x, c, sizeof(x)) using namespace std; const int maxn = 209, maxk =

HDU1114 Piggy-Bank(完全背包)

题意:给一个储钱罐,已知空的储钱罐和装了硬币的储钱罐的质量.然后给了n种硬币的质量和价值. 问储钱罐里最少有多少钱. 解法:完全背包.注意要初始化为 INF,要正好装满,如果结果是INF,输出This is impossible. /* *********************************************** Author :devil Created Time :2015/12/21 21:16:56 ***********************************

hdu1114 dp(完全背包)

题意:已知空钱罐质量和满钱罐质量(也就是知道钱罐里的钱的质量),知道若干种钱币每种的质量以及其价值,钱币都是无限个,问最少钱罐中有多少钱. 这个题在集训的时候学长给我们做过,所以你会做是应该的,由于已经有固定的质量,所以是必须正好放满的完全背包问题.然后```具体过程就不细讲了完全背包依旧是经典,你要是还不会就滚回去看背包九讲并且无颜见学长们了``` 1 #include<stdio.h> 2 #include<string.h> 3 #define min(a,b) a<b

ACM Piggy Bank

Problem Description Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has

寒假训练5解题报告

1.HDU 1114 Piggy Bank 一道简单的背包问题 #include <iostream> #include <cstdio> #include <cstring> using namespace std; #define ll long long const int N = 10005; const int INF = 0x3f3f3f3f; int dp[N]; int main() { // freopen("a.in" , &qu

动物名词

dog    n. 狗 I love dogs. Dogs are man's best friends. The dog is very cute. cat    n. 猫 I have a cat The cat is white The cat likes sleeping puppy    n. 小狗 doggie    n. 小狗 kitty    n. 小猫 rooster    n. 公鸡 It's hard to see a rooster in big cities. I sa

MapReuce中对大数据处理最合适的数据格式是什么?

本节作为<Hadoop从入门到精通>大型专题的第三章第二节将教大家如何在Mapreduce中使用XML和JSON两大常见格式,并分析比较最适合Mapreduce大数据处理的数据格式. 在本章的第一章节介绍中,我们简单了解了Mapreduce数据序列化的概念,以及其对于XML和JSON格式并不友好.本节作为<Hadoop从入门到精通>大型专题的第三章第二节将教大家如何在Mapreduce中使用XML和JSON两大常见格式,并分析比较最适合Mapreduce大数据处理的数据格式. 3.

一步步学习如何安装并使用SAP HANA Express Edition

使用Jerry这篇文章在Google Cloud platform上的Kubernetes集群部署HANA Express里介绍的方法在Google Cloud Platform的Kubernetes cluster上安装SAP HANA Express. 文中介绍了一个yaml文件,里面声明了容器镜像文件store/saplabs/hanaexpress:2.00.033.00.20180925.2. 安装完成后,在启动的pod里有两个容器,分别运行着SQLPad和HANA Express.

hdu1114 Piggy-Bank 完全背包

转载请注明出处:http://blog.csdn.net/u012860063 题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1114 Problem Description Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes