POJ 3984 迷宫问题(简单bfs+路径打印)

传送门:

http://poj.org/problem?id=3984

迷宫问题

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 33105   Accepted: 18884

Description

定义一个二维数组:

int maze[5][5] = {
	0, 1, 0, 0, 0,
	0, 1, 0, 1, 0,
	0, 0, 0, 0, 0,
	0, 1, 1, 1, 0,
	0, 0, 0, 1, 0,
};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

Source

分析:

虽然bfs写得多一点,但路径打印的这还是第1个!!!

利用栈的特性打印出来就好

code:

#include <stdio.h>
#include <iostream>
#include <stdlib.h>
#include <algorithm>
#include <string.h>
#include<queue>
#include<stack>
using namespace std;
int G[10][10];
int dir[4][2]={1,0,0,1,-1,0,0,-1};
int vis[10][10];
struct node
{
    int x,y;
}pre[10][10];

void pri()
{
    stack<node> s;
    node p;
    p.x=4,p.y=4;

    while(1)
    {
        s.push(p);
        if(p.x==0&&p.y==0)
            break;
        p=pre[p.x][p.y];
    }
    int x,y;
    while(!s.empty())
    {
        x=s.top().x;
        y=s.top().y;
        printf("(%d, %d)\n",x,y);
        s.pop();
    }
}
void bfs(int x,int y)
{
    queue<node> q;
    node p,next;

    p.x=x,p.y=y;
    q.push(p);
    vis[x][y]=1;

    while(!q.empty())
    {
        p=q.front();
        q.pop();

        if(p.x==4&&p.y==4)
        {
            pri();
            return ;
        }
        for(int i=0;i<4;i++)
        {
            next.x=p.x+dir[i][0];
            next.y=p.y+dir[i][1];

            if(next.x>=0&&next.x<5&&next.y>=0&&next.y<5&&vis[next.x][next.y]==0&&G[next.x][next.y]==0)
            {
                pre[next.x][next.y]=p;
                vis[next.x][next.y]=1;
                q.push(next);
            }
        }
    }
}
int main()
{
    memset(G,0,sizeof(G));
    for(int i=0;i<5;i++)
    {
        for(int j=0;j<5;j++)
        {
            cin>>G[i][j];
        }
    }
    memset(vis,0,sizeof(vis));
    memset(pre,0,sizeof(pre));
    bfs(0,0);
    return 0;
}

原文地址:https://www.cnblogs.com/yinbiao/p/9400551.html

时间: 2024-10-14 17:24:25

POJ 3984 迷宫问题(简单bfs+路径打印)的相关文章

POJ 3984 迷宫问题【BFS/路径记录】

迷宫问题 Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 31428 Accepted: 18000 Description 定义一个二维数组: int maze[5][5] = { 0, 1, 0, 0, 0, 0, 1, 0, 1, 0, 0, 0, 0, 0, 0, 0, 1, 1, 1, 0, 0, 0, 0, 1, 0, }; 它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编

poj 3984 迷宫问题 (BFS+记录路径)

题目连接:http://poj.org/problem?id=3984 题解:简单的BFS+记录路径,具体题解看代码注释. #include <iostream> #include <queue> #include <cstdio> using namespace std; struct point { int x; int y; }; queue<point>q; int map[5][5]; int vis[5][5];//标记走过的路 int g[4]

(简单) POJ 3984 迷宫问题,BFS。

Description 定义一个二维数组: int maze[5][5] = { 0, 1, 0, 0, 0, 0, 1, 0, 1, 0, 0, 0, 0, 0, 0, 0, 1, 1, 1, 0, 0, 0, 0, 1, 0, }; 它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线. 水题,BFS然后记录路径就好. 代码如下: #include<iostream> #include<cstring> #

poj(3984)——迷宫问题(输出路径)

题目的大致意思是:给你一个5*5的迷宫,然后你只能往上,下,左,右四个方向走,然后0代表的是可以走的路,1代表的是墙不可以走.然后让我们求出从左上角到右下角的最短路线及其长度. 求长度是好做的,但是输出路径这个我还是第一次碰到. 这里我们使用的队列不可以是STL中的queue了,要用数组来写,因为我们在这里需要头尾两个指针. 然后我们这里还要用到一个保存前驱节点的数组pre,这样在我们输出路径的时候就可以回溯上去. #include<stdio.h> #include<string.h&

POJ 3984:迷宫问题【BFS】

迷宫问题 Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 11603   Accepted: 6946 Description 定义一个二维数组: int maze[5][5] = { 0, 1, 0, 0, 0, 0, 1, 0, 1, 0, 0, 0, 0, 0, 0, 0, 1, 1, 1, 0, 0, 0, 0, 1, 0, }; 它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,

BFS(最短路+路径打印) POJ 3984 迷宫问题

题目传送门 1 /* 2 BFS:额,这题的数据范围太小了.但是重点是最短路的求法和输出路径的写法. 3 dir数组记录是当前点的上一个点是从哪个方向过来的,搜索+,那么回溯- 4 */ 5 /************************************************ 6 Author :Running_Time 7 Created Time :2015-8-4 9:02:06 8 File Name :POJ_3984.cpp 9 ********************

poj 3984:迷宫问题(广搜,入门题)

迷宫问题 Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7635   Accepted: 4474 Description 定义一个二维数组: int maze[5][5] = { 0, 1, 0, 0, 0, 0, 1, 0, 1, 0, 0, 0, 0, 0, 0, 0, 1, 1, 1, 0, 0, 0, 0, 1, 0, }; 它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要

POJ 3984 迷宫问题 搜索题解

本题可以使用BFS和DFS解题,也可以构建图,然后利用Dijsktra解题. 不过因为数据很少,就没必要使用Dijsktra了. BFS和DFS效率都是一样的,因为都需要搜索所有可能的路径,并记录最短路径和当前路径. 推荐使用DFS,感觉会方便很多,BFS会麻烦很多,因为需要记录并比较路径. #include <stdio.h> #include <string.h> #include <limits.h> const int MAX_N = 5; const int

POJ - 3984 迷宫问题 (搜索)

Problem Description 定义一个二维数组: int maze[5][5] = { 0, 1, 0, 0, 0, 0, 1, 0, 1, 0, 0, 0, 0, 0, 0, 0, 1, 1, 1, 0, 0, 0, 0, 1, 0, }; 它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线. Input 一个5 × 5的二维数组,表示一个迷宫.数据保证有唯一解. Output 左上角到右下角的最短路径,格式如