poj3009 Curling 2.0

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game
is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed
until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.

Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).

      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.

Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).

Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board

First row of the board

...

h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position

The dataset for Fig. D-1 is as follows:

6 6

1 0 0 2 1 0

1 1 0 0 0 0

0 0 0 0 0 3

0 0 0 0 0 0

1 0 0 0 0 1

0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10

-1

这题可以用深搜做,广搜想了想很难实现。主要要注意一个方向走到尽头的实现,这里需要不少判断,其他的就是基础的深搜写法了,注意剪枝。
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
int map[30][30],t;
int tab[10][2]={0,0,0,1,-1,0,0,-1,1,0};
int x2,y2,x3,y3,n,m;

void dfs(int x,int y,int time)
{
	int i,j,xx,yy,flag1;
	if(time>10)return;
	if(time==10 && (x!=x3 && y!=y3))return;
	if(x==x3 && y==y3){
		if(t>time)t=time;
		return;
	}
	if(time>=t)return;
	for(i=1;i<=4;i++){
		flag1=1;xx=x;yy=y;
		if(map[x+tab[i][0]][y+tab[i][1]]==1)continue;
		while(1)
		{
			xx=xx+tab[i][0];yy=yy+tab[i][1];
			if(xx==x3 && yy==y3)break;
			if(xx<1 || xx>n || yy<1 || yy>m){
				flag1=0;break;
			}
			if(map[xx][yy]==0)continue;
			if(map[xx][yy]==1){
				flag1=2;xx=xx-tab[i][0];yy=yy-tab[i][1];break;
			}
		}
		if(flag1==0 )continue;
		//printf("%d %d\n",xx,yy);
		if(flag1==2){
			map[xx+tab[i][0]][yy+tab[i][1]]=0;
			dfs(xx,yy,time+1);
			map[xx+tab[i][0]][yy+tab[i][1]]=1;

		}
		else{
			dfs(xx,yy,time+1);
		}
	}
}

int main()
{
	int i,j;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		if(n==0 && m==0)break;
		memset(map,0,sizeof(map));
		for(i=1;i<=n;i++){
			for(j=1;j<=m;j++){
				scanf("%d",&map[i][j]);
				if(map[i][j]==2){
					x2=i;y2=j;
				}
				else if(map[i][j]==3){
					x3=i;y3=j;
				}
			}
		}
		t=12;
		dfs(x2,y2,0);
		if(t==12){
			printf("-1\n");
		}
		else printf("%d\n",t);
	}
	return 0;
}

时间: 2024-10-23 10:37:07

poj3009 Curling 2.0的相关文章

POJ3009——Curling 2.0(DFS)

Curling 2.0 DescriptionOn Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single

poj3009 Curling 2.0 (DFS按直线算步骤)

Curling 2.0 Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 14563   Accepted: 6080 Description On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is

POJ3009 Curling 2.0(DFS 好题)

Curling 2.0 Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 15262   Accepted: 6334 Description On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is

poj3009 Curling 2.0(很好的题 DFS)

https://vjudge.net/problem/POJ-3009 做完这道题,感觉自己对dfs的理解应该又深刻了. 1.一般来说最小步数都用bfs求,但是这题因为状态记录很麻烦,所以可以用dfs. 2.在用dfs的时候,mp时一个全局变量,对于平等的走法,每一个走法结束后一定要状态复原!!!(也就是代码36-38行)否则会对其他走法产生影响. 1 #include<iostream> 2 #include<cstdio> 3 #include<queue> 4 #

poj3009 Curling 2.0(DFS回溯)

题目大意是:给你一个球,刚开始是静止的,可以通过触碰给他一个初速度,一旦球运动起来就不会停止,除非遇到一个石头.遇到石头以后小球就原地停止了,然后石头就被砸碎了.小球越界就算失败了.问你最少进行多少次操作,可以让小球到达终点.题中还有一个要求,如果超过10步,就算失败了. 这道题目做了好久啊.可能方法太麻烦了. #include<stdio.h> #include<string.h> int map[105][105],si,sj,ei,ej,w,h; //1 right    2

poj3009 Curling 2.0 深搜

PS:以前看到题目这么长就没写下去了.今天做了半天,没做出来.准备看题解,打开了网站都忍住了,最后还是靠自己做出来的.算是一点进步吧. 分析: 题目的意思没明白或者理解有偏差都没办法做题.看样例3和样例4,数据差不多的,但是一个输出4,但是另外的一个却是-1.再去看题目就会发现,题目的意思是在撞碎石头之前必须走一个为值0的格子.我理解为需要加速.对样例4,答案4是这样出来的:初始位置为(1,3),第一步是到达(1,2),并且使得(1,1)点的值为0(撞碎了这里的石头,0代表可以通行):第二步是到

poj3009 Curling 2.0 DFS水

http://poj.org/problem?id=3009 题意:给定一个m*n的网格,在这些网格上一些地方有障碍物,给定起点与终点的位置,当石头从起点开始走,撞上障碍才会转弯,否则会一直沿着来时的方向继续前进.撞到障碍后停在障碍前的位置,障碍消失.然后石头可以选择四个方向(相邻处无障碍的方向)前进,问至少需要停多少次才能从起点到达终点.不能到达或者多余10步后游戏失败.如果能到达输出最少的步数,否则输出-1. 思路:DFS,多余10步为剪枝条件. 1 #include<iostream>

POJ3009 Curling 2.0(DFS)

迷宫问题求最短路.略有不同的是如果不碰到石头的话会沿着一个方向一直前进,出界就算输了.碰到石头,前方石头会消失,冰壶停在原地.把这个当作状态的转移.DFS可以求出其最小操作数. #include<iostream> #include<cstdio> #include<cstring> #include<cstdlib> #include<algorithm> #include<queue> #include<vector>

POJ3009 Curling 2.0【DFS】

题目链接: http://poj.org/problem?id=3009 题目大意: 一种在宽为M高为N大小的矩阵上玩的冰壶游戏,起点字符为'2',终点字符为'3',矩阵上'0'为可移动区域, '1'为石头区域.冰壶刚开始是静止的,每走一步都会选择某个方向运动,而且会沿着该方向一直运动不停, 也不会改变方向,除非冰壶碰到石头或者到达终点,才会停下(这算一步).冰壶在运动的时候,不能改变方 向.冰壶碰到石头会变成静止状态,这时候石头会破裂,该区域变为可移动区域,而冰壶就可以改变方向了. 冰壶一旦走