/*简单计算器
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14933 Accepted Submission(s): 5087
Problem Description
读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。
Input
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。
Output
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。
Sample Input
1 + 2
4 + 2 * 5 - 7 / 11
0
Sample Output
3.00
13.36
Source
浙大计算机研究生复试上机考试-2006年
Recommend
JGShining | We have carefully selected several similar problems for you: 1230 1235 1234 1236 1229
*/
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<stack>
using namespace std;
stack<double> num;
char s;
double a,b;
int main()
{
while(scanf("%lf",&a))//看清题目条件 一行中只有一个0时输入结束 不是出现0时输入结束
{
int i=1;
num.push(a);
while(getchar()!=‘\n‘)
{
i=0;
scanf("%c %lf",&s,&a);
if(s==‘+‘||s==‘-‘)
{
if(s==‘+‘) num.push(a);
else num.push(-a);
}
if(s==‘*‘||s==‘/‘)
{
b=num.top();
num.pop();
if(s==‘*‘) num.push(b*a);
else num.push(b/a);
}
}
if(i) break;
double sum=0;
while(!num.empty())
{
sum+=num.top();
num.pop();
}
printf("%.2lf\n",sum);
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。