POJ2385——Apple Catching

Apple Catching

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8062   Accepted: 3951

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must
wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds.

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under
only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts
at tree 1.

Input

* Line 1: Two space separated integers: T and W

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS:

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice.

OUTPUT DETAILS:

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

Source

USACO 2004 November

简单的dp题,设dp[i][j][0], dp[i][j][1]分别表示到第i分钟时,一共走了j个来回,此时在1/2树下所能得到的苹果的最多数目

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cstdlib>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

int dp[1010][33][2];
int app[1010];

int main()
{
	int t, w;
	while (~scanf("%d%d", &t, &w))
	{
		for (int i = 1; i <= t; ++i)
		{
			scanf("%d", &app[i]);
		}
		memset (dp, 0, sizeof(dp));
		for (int i = 1; i <= t; ++i)
		{
			dp[i][0][0] = dp[i - 1][0][0] + (app[i] == 1 ? 1 : 0);
			dp[i][0][1] = dp[i - 1][0][1] + (app[i] == 2 ? 1 : 0);
			for (int j = 1; j <= (i - 1 > w ? w : i - 1); ++j)
			{
				dp[i][j][0] = max(dp[i - 1][j][0], dp[i - 1][j - 1][1]) + (app[i] == 1 ? 1 : 0);
				dp[i][j][1] = max(dp[i - 1][j][1], dp[i - 1][j - 1][0]) + (app[i] == 2 ? 1 : 0);
			}
		}
		int ans = 0;
		for (int i = 0; i <= w; ++i)
		{
			ans = max(ans, max(dp[t][i][0], dp[t][i][1]));
		}
		printf("%d\n", ans);
	}
	return 0;
}

虽然本来内存就很够,但我还是用滚动数组写了下

#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cstdlib>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

int dp[2][33][2];
int app[1010];

int main()
{
	int t, w;
	while (~scanf("%d%d", &t, &w))
	{
		for (int i = 1; i <= t; ++i)
		{
			scanf("%d", &app[i]);
		}
		memset (dp, 0, sizeof(dp));
		for (int i = 1; i <= t; ++i)
		{
			dp[i % 2][0][0] = dp[1 - i % 2][0][0] + (app[i] == 1 ? 1 : 0);
			dp[i % 2][0][1] = dp[1 - i % 2][0][1] + (app[i] == 2 ? 1 : 0);
			for (int j = 1; j <= (i - 1 > w ? w : i - 1); ++j)
			{
				dp[i % 2][j][0] = max(dp[1 - i % 2][j][0], dp[1 - i % 2][j - 1][1]) + (app[i] == 1 ? 1 : 0);
				dp[i % 2][j][1] = max(dp[1 - i % 2][j][1], dp[1 - i % 2][j - 1][0]) + (app[i] == 2 ? 1 : 0);
			}
		}
		int ans = 0;
		for (int i = 0; i <= w; ++i)
		{
			ans = max(ans, max(dp[t % 2][i][0], dp[t % 2][i][1]));
		}
		printf("%d\n", ans);
	}
	return 0;
}
时间: 2024-10-11 15:40:31

POJ2385——Apple Catching的相关文章

POJ2385 Apple Catching 【DP】

Apple Catching Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 8018   Accepted: 3922 Description It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, eac

poj2385 Apple Catching

思路: 简单dp. 实现: 1 #include <iostream> 2 #include <cstdio> 3 #include <cstring> 4 using namespace std; 5 int t,w,x[1005]; 6 int dp[1005][2][35]; 7 int dfs(int now,int cur,int rem) 8 { 9 if(dp[now][cur][rem] != -1) 10 return dp[now][cur][rem

BZOJ 3384: [Usaco2004 Nov]Apple Catching 接苹果( dp )

dp dp( x , k ) = max( dp( x - 1 , k - 1 ) + *** , dp( x - 1 , k ) + *** ) *** = 0 or 1 ,根据情况 (BZOJ 1750双倍经验) ------------------------------------------------------------------------ #include<cstdio> #include<cstring> #include<algorithm>

Apple Catching(POJ 2385)

Apple Catching Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 9978   Accepted: 4839 Description It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, eac

Apple Catching(dp)

Apple Catching Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 9831   Accepted: 4779 Description It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, eac

3384/1750: [Usaco2004 Nov]Apple Catching 接苹果

3384/1750: [Usaco2004 Nov]Apple Catching 接苹果 Time Limit: 1 Sec  Memory Limit: 128 MBSubmit: 18  Solved: 16[Submit][Status][Discuss] Description 很少有人知道奶牛爱吃苹果.农夫约翰的农场上有两棵苹果树(编号为1和2),每一棵树上都长满了苹果.奶牛贝茜无法摘下树上的苹果,所以她只能等待苹果从树上落下.但是,由于苹果掉到地上会摔烂,贝茜必须在半空中接住苹果(没

POJ 2385 Apple Catching 接苹果 DP

题目链接:POJ 2385 Apple Catching Apple Catching Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 7858   Accepted: 3846 Description It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently number

POJ 2385 Apple Catching

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall.

POJ 2385 Apple Catching(简单DP)

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall.