Description
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1..F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
其实就是计算连通图中是否存在负权环路,虫洞就表示负权路,正常的路是双向的,虫洞就覆盖一条单向路就行
#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 5005
#define mod 1000000007
using namespace std;
int n,m,w,e;
int dis[MAXN];
struct Node
{
int beg,end,t;
};
Node edge[MAXN<<1];
void add(int b,int en,int t)
{
edge[e].beg=b;
edge[e].end=en;
edge[e].t=t;
e++;
}
bool relax(int p)
{
int t=dis[edge[p].beg]+edge[p].t;
if(dis[edge[p].end]>t)
{
dis[edge[p].end]=t;
return true;
}
return false;
}
bool bellman()
{
for(int i=1;i<=n;++i)
dis[i]=INF;
dis[1]=0;
for(int i=1; i<n; ++i)
{
bool flag=false;
for(int j=0; j<e; ++j)
{
if(relax(j))
flag=true;
}
if(dis[1]<0)
return true;
if(!flag)
return false;
}
for(int j=0; j<e; ++j)
if(relax(j))
return true;
return false;
}
int main()
{
int f;
scanf("%d",&f);
while(f--)
{
e=0;
scanf("%d%d%d",&n,&m,&w);
int a,b,c;
while(m--)
{
scanf("%d%d%d",&a,&b,&c);
add(a,b,c);
add(b,a,c);
}
while(w--)
{
scanf("%d%d%d",&a,&b,&c);
add(a,b,-c);
}
if(bellman())
printf("YES\n");
else
printf("NO\n");
}
return 0;
}