poj2240

Arbitrage

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 20021   Accepted: 8497

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange
rates as input and then determines whether arbitrage is possible or not.

Input

The input will contain one or more test cases. Om the
first line of each test case there is an integer n (1<=n<=30),
representing the number of different currencies. The next n lines each contain
the name of one currency. Within a name no spaces will appear. The next line
contains one integer m, representing the length of the table to follow. The last
m lines each contain the name ci of a source currency, a real number rij which
represents the exchange rate from ci to cj and a name cj of the destination
currency. Exchanges which do not appear in the table are impossible.
Test
cases are separated from each other by a blank line. Input is terminated by a
value of zero (0) for n.

Output

For each test case, print one line telling whether
arbitrage is possible or not in the format "Case case: Yes" respectively "Case
case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

Source

Ulm Local 1996

题意:求自身到自身的最大转换率。
   最简单的方法就是floryd算法变形,求最大路径后,求最大环,看它是否满足条件。
  
每一个结点都必须有到自身的环(不甚清楚原因)。
注意:该double的地方一定不能为int,切记!!!

#include<iostream>
#include<cstdio>
#include<map>
#include<string>
#include<cstring>
using namespace std;
const int inf=1e6;      //无限大
int n;//货币种类
int m;//兑换方式
map<string,int>f;     //建立一个 使字符串与整数有一一对应关系 的容器f,以便利用邻接矩阵存储数据
double rate;
char str[50],str1[50],str2[50];
double dist[31][31];
int main()
{
    int cases=0;
    for(;;)
    {
        memset(dist,inf,sizeof(dist));
        cin>>n;
        if(!n) return 0;
        for(int i=1;i<=n;i++){
            cin>>str;
            f[str]=i;          //将输入的货币从1到n依次编号
            dist[i][i]=1;        //到自身的转换率默认为1,但通过floyd可能会被改变
        }//有向图的顶点(一般)存在环
        cin>>m;
        for(int i=1;i<=m;i++){
            cin>>str1>>rate>>str2;
            dist[f[str1]][f[str2]]=rate;      //构造图
        }
        for(int k=1;k<=n;k++)
            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                    if(dist[i][j]<dist[i][k]*dist[k][j])//变形的最大路径,变"+"为"*"
                       dist[i][j]=dist[i][k]*dist[k][j];
        int flag=0;
        for(int i=1;i<=n;i++)
            if(dist[i][i]>1){
                flag=1;break;
            }
         if(flag)
            cout<<"Case "<<++cases<<": Yes"<<endl;
        else
            cout<<"Case "<<++cases<<": No"<<endl;
    }
    return 0;
}
时间: 2024-12-21 20:17:52

poj2240的相关文章

poj-------(2240)Arbitrage(最短路)

Arbitrage Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 15640   Accepted: 6563 Description Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currenc

POJ-2240 -Arbitrage(Bellman)

题目链接:Arbitrage 让这题坑了,精度损失的厉害,用赋值的话,直接全部变成0.00了,无奈下,我只好往里输了,和POJ1860一样找正环,代码也差不多,稍微改改就可以了,但是这个题精度损失的比那个....水过 POJ计划的最短路模块,刷完了,最短路问题,挺坑的,但是就是那点东西,变来变去,就是改改dis[]的更新条件. 明天就要开始POJ的最小生成树了, ME                  TI 704Kb            46Ms #include <iostream> #

poj2240(Arbitrage)

题目大意: 给你各国的货币名称,和国家与国家之间兑换的汇率,问你通过一系列的兑换能否是自己的财富增加. 解题思路: 先建图,因为给的是字符串不是阿拉伯数之间的联系,所以建图可以用map<string,int>mp 建图.赋值给结构体中的u,v.然后利用bellman—ford算法,因为如果财富能够通过兑换增值说明会有一条正权回路.所以利用bellman—ford算法 判断是否出现正权回路说明可以增值否则NO. 代码: #include <algorithm> #include &l

POJ2240——Arbitrage(Floyd算法变形)

Arbitrage DescriptionArbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys

用SPFA 解决POJ2240

Arbitrage Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 30790   Accepted: 12761 Description Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same curren

poj2240——Arbitrage(Bellman-Ford算法)

Description Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 Fre

poj2240 floyd

1 //Accepted 732 KB 782 ms 2 //floyd应用 3 #include <cstdio> 4 #include <cstring> 5 #include <iostream> 6 #include <queue> 7 #include <cmath> 8 #include <map> 9 #include <algorithm> 10 using namespace std; 11 /** 12

poj2240 Arbitrage (spfa判环)

Arbitrage Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 10997   Accepted: 4622 Description Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currenc

poj2240最短路 floyd

Arbitrage Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 17360   Accepted: 7308 Description Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currenc