Pat(Advanced Level)Practice--1090(Highest Price in Supply Chain)

Pat1090代码

题目描述:

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one‘s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly
one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and
hence they are numbered from 0 to N-1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si
is the index of the supplier for the i-th member. Sroot for the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers.
It is guaranteed that the price will not exceed 1010.

Sample Input:

9 1.80 1.00

1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

AC代码:

其实就是求树的高度以及该高度上的叶子节点数目,直接BFS就行。

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<vector>
#include<deque>
#define MAXN 100005

using namespace std;

int n;
int root;
double p,r;
int visited[MAXN];
vector<int> v[MAXN];
deque<int> q;

void BFS(int root,int *height,int count[]){
	int endNode;
	int maxlevel=-1;
	q.push_back(root);
	visited[root]=1;
	endNode=q.back();
	while(!q.empty()){
		int index=q.front();
		q.pop_front();
		for(int i=0;i<v[index].size();i++){
			int j=v[index][i];
			if(!visited[j]){
				visited[j]=1;
				q.push_back(j);
			}
		}
		if(index==endNode){
			(*height)++;//height of the tree
			count[*height]=q.size();//reserve the nodes of each level
			endNode=q.back();
		}
	}
}

int main(int argc,char *argv[]){
	int height=0,count[MAXN];
	count[0]=1;
	scanf("%d %lf %lf",&n,&p,&r);
	for(int i=0;i<n;i++){
		int index;
		scanf("%d",&index);
		if(index==-1){
			root=i;
		}else{
			v[index].push_back(i);
		}
	}
	BFS(root,&height,count);
	printf("%.2lf %d\n",p*pow((1+r/100.0),height-1),count[height-1]);
	return 0;
}
时间: 2024-10-26 04:17:53

Pat(Advanced Level)Practice--1090(Highest Price in Supply Chain)的相关文章

1090. Highest Price in Supply Chain (25)【树】——PAT (Advanced Level) Practise

题目信息 1090. Highest Price in Supply Chain (25) 时间限制200 ms 内存限制65536 kB 代码长度限制16000 B A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)– everyone involved in moving a product from supplier to customer. Starting from o

PAT 1090 Highest Price in Supply Chain[较简单]

1090 Highest Price in Supply Chain(25 分) A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone on the chain bu

PAT 1090. Highest Price in Supply Chain (25)(DFS啊 )

题目链接:http://www.patest.cn/contests/pat-a-practise/1090 A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone o

PAT 1090. Highest Price in Supply Chain

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone on the chain buys products from one's supplier in a pric

1090. Highest Price in Supply Chain (25)

时间限制 200 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplie

1090 Highest Price in Supply Chain (25 分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone on the chain buys products from one's supplier in a pric

1090 Highest Price in Supply Chain (25 分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer. Starting from one root supplier, everyone on the chain buys products from one's supplier in a pric

PAT (Advanced Level) 1090. Highest Price in Supply Chain (25)

简单dfs. #include<cstdio> #include<cstring> #include<cmath> #include<algorithm> #include<map> #include<queue> #include<stack> #include<vector> using namespace std; const int maxn=100000+10; vector<int>g[

PAT:1090. Highest Price in Supply Chain (25) AC

#include<stdio.h> #include<vector> using namespace std; const int MAX=100010; int DEPest=0,times=0; vector<int> child[MAX]; //child[父亲][孩子] 二维数组表示树形结构 void DFS(int root,int depth) { if(child[root].size()==0) //叶子节点开始判断深度 { if(depth>DE

1090 highest price in supply chain

p,r用double类型,pat多题如果用float会WA AC代码 #include <vector> #include <cstdio> #include <cmath> using namespace std; int main(){ int n; double p,r; scanf("%d %lf %lf",&n,&p,&r); r /= 100.0; vector<int> s; vector<in