三个数找最大 2.0

#include<stdio.h>

void swap(int*a,int*b)
{
    int tmp=*a;
    *a=*b;
    *b=tmp;
}
int main ()
{
    int a,b,c;
    scanf("%d %d %d",&a,&b,&c);
    if(a<b)
    {
       swap(&a,&b);
    }
    if(b<c)
    {
       swap(&b,&c);
    }
    printf("%d %d %d",a,b,c)
return 0;
}
时间: 2024-11-10 07:36:03

三个数找最大 2.0的相关文章

三个数找最大 1.0

#include<stdio.h> int main() {     int a,b,c;     int i;     scanf("%d %d %d",&a,&b,&c);     if(a>b)     {        i=a;        if(i>c)        {           printf("max=%d\n",i);        }        else        {       

C#实战--三个数找最大值(4种方法)

using System; using System.Collections.Generic; using System.Linq; using System.Text; /* * 编一个程序 * 从键盘上输入三个数 * 用三元运算符(? :)把最大数找出来. */ namespace PI { class Program { static void Main(string[] args) { Int32 var_a, var_b, var_c,max; var_a = int.Parse(Co

ytu 1061: 从三个数中找出最大的数(水题,模板函数练习 + 宏定义练习)

1061: 从三个数中找出最大的数Time Limit: 1 Sec  Memory Limit: 128 MBSubmit: 154  Solved: 124[Submit][Status][Web Board] Description 定义一个带参的宏(或者模板函数),从三个数中找出最大的数. Input 3个短整型数,空格隔开 3个实数,空格隔开 3个长整数,空格隔开 Output 最大的数,对于实数保留2位小数. Sample Input 1 2 3 1.5 4.7 3.2 123456

LeetCode 16 3Sum Closest 找出最接近指定target的三个数的和

题目: Given an array S of n integers, find three integers in S such that the sum is closest to a given number, target. Return the sum of the three integers. You may assume that each input would have exactly one solution. For example, given array S = {-

算法试题 - 找出一个序列中出现频率最高的三个数

题目 找出一个序列中出现频率最高的三个数 解析 思路一 创建一个新字典, k 为 序列的值, 然后 v 的初始值 0, 然后循环序列进行计数, 然后进行新字典的处理..... 不行, 不好处理了. 此思路不行 思路二 利用 colletctions 的 Counter 模块, 内部有个方法可以解决 k 值问题 答案 答案一 可以往下继续实现, 但是有点麻烦了 li = [2, 5, 3, 4, 1, 8, 1, 2, 6, 6, 1, 5, 1, 5] d = dict.fromkeys(li,

求N!末尾的0的个数--找规律+递归

0\'s Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^ 题目描述 计算整数n!(n的阶乘)末尾有多少个0. 输入 第一行输入一个数T代表测试数据个数(T<=20).接下来T行每行1个数代表n(0<=n< 2^31). 输出 对于每个测试数据输n!末尾有多少个0,每行输出一个结果. 示例输入 3 1 5 10 示例输出 0 1 2 提示 中国海洋大学第三届"朗讯杯"编程比赛高级组试题 声明(摘抄至某前辈)--

三个数中找最大

using System; using System.Collections.Generic; using System.Linq; using System.Text; namespace 三个数中找最大 { class Program { static void Main(string[] args) { Console.WriteLine("三个数中找最大"); int A = int.Parse(Console.ReadLine()); //Console.ReadLine()

【LeetCode-面试算法经典-Java实现】【015-3 Sum(三个数的和)】

[015-3 Sum(三个数的和)] [LeetCode-面试算法经典-Java实现][所有题目目录索引] 原题 Given an array S of n integers, are there elements a, b, c in S such that a + b + c = 0? Find all unique triplets in the array which gives the sum of zero. Note: Elements in a triplet (a,b,c) m

数组中唯一出现一次的一个,两个,三个数,其余数都是偶数次出现(java版本)

首先在leetcode上面有这样类似的题,做法大致类似 1,首先是只出现一次的一个数 比较简单,直接全部亦或值就得到了 //只出现一次的一个数 public static int singleNumber1(int[] A) { int res=0; for(int i=0;i<A.length;i++) res^=A[i]; return res; } 2,只出现一次的两个数 则所有的值亦或肯定不为0,设最后的抑或结果为M,找到M从低到高为最先为1的位置,然后根据所有数在该位置为0或者1,分为